BUG?! Assigned categories vanish when locations are updated!

Home Forums Store Locator Plus BUG?! Assigned categories vanish when locations are updated!

This topic contains 31 replies, has 2 voices, and was last updated by  Cici 1 month, 3 weeks ago.

Viewing 25 posts - 1 through 25 (of 32 total)
  • Author
    Posts
  • #45166

    Wolfram
    Participant

    I just realized when assigning categories via “Bulk” editing to a location or more locations, they vanish when I go into the location to edit something there and update!! Help!!

    <p class=”envinfo”>Site below is behind password:
    User: test
    Password: 12345</p>

    Plugin Environment:
    Store Locator Plus:4.7.5
    Experience:4.7.4
    Power:4.7.1
    +Pages , Contacts
    User Managed Locations:4.5.03
    Site URL:http://www.tuning-plaza.de
    This Info Cached:1487338457
    Network Active:No
    WordPress Version:4.7.2
    PHP Version:5.4.39-0+deb7u2
    MySQL Version:5.5.52
    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:68 MB
    PHP Post Max Size:8M

    </div>
    </div>
    </div>
    </div>
    </div>

    #45189

    Cici
    Keymaster

    I will mention to Lance, he is working on another bug that has to do with some center map at when associayed with other functions. He is preparing and testing SLP 4.7.6 for release. I haven’t seen this particular one so thank you and I will mention it to Lance

    #45195

    Wolfram
    Participant

    Thanks Cici 🙂

    I think it might be since the last update, since we have edited locations before and never stumbled across this (and we surely would have realized….)

    #45207

    Cici
    Keymaster

    SLP 4.7.6 has been released for production.  When you update SLP to 4.7.6 you will be required to update POWER and EXP  to version 4.7.6  I havent had a chance to do a post, Busy with elderly parent. Please let us know if after updating you experience any issues. Make sure to include your plugin environment and the url that you are having problems with in each post as you have been doing. Thanks

    #45220

    Wolfram
    Participant

    hmm can’t seem to post stuff….?

    #45222

    Wolfram
    Participant

    oh now ok – Experience and base plugin upgraded fine, for Power, I have the note under plugins saying:

    “Version 4.7.1 | Von Store Locator Plus | Plugin-Seite aufrufen | Documentation | Settings | Version 4.7.6 in production

    So this will be available for upgrade soon? Will test as soon as I can update and reactivate Power.

    #45223

    Wolfram
    Participant

    downloaded Power 4.7.6 via my user account here and tested – categories still deleted when I edit and update an entry 🙁

    Plugin environment and site see above:

    https://wordpress.storelocatorplus.com/forums/topic/bug-assigned-categories-vanish-when-locations-are-updated/#post-45166

    #45224

    Wolfram
    Participant

    Store Locator Plus:4.7.6
    Erfahrung:4.7.6
    Power:4.7.6
    +Pages , Contacts
    User Managed Locations:4.5.03
    Site URL:http://www.tuning-plaza.de
    This Info Cached:1487769553
    Network Active:No
    WordPress Version:4.7.2
    PHP Version:5.4.39-0+deb7u2
    MySQL Version:5.5.52
    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:67 MB
    PHP Post Max Size:8M

    </div>
    </div>
    </div>
    </div>
    </div>

    #45229

    Cici
    Keymaster

    Wolfram, Can you use Janitor and tell us exactly what the option settings are under Power and see if you ahve any legacy settings showing up? i.e. did you have tagalong before?

     

    I tested on my site. I added a new category, I assigned that category to a location under Lactation manager, I thenlooked at my page with results and searched for that new category, I received the result with that one category instantly.

    I then went under Location Manager, I edited the location category to another existing category. I saved ad refreshed, went to the map page and searched for the newly assignmed category and the location was showing correctly as the newly assigned category.

     

    So I guess we need to know

    1) Do you have any legacy settings under Tagalong

    2) Where are you changing or editing the category?  Are you editing it under settings or taxonomy or under the Location Manager or as an import?

    Lastly, (I maybe reaching here but I noticed the title Experience was translated and the title for power in your posted plugin environment was not)

     

    I noticed your Experience add-on title has been translated. Is everything in Power being translated in German (I believe its German correct me if I am wrong)  If so check under loco- Translate or Translate Locations under Translate org to see if your language is translating.  I’m reaching here on that, only because taxonomy and categories is WordPress

    If you check Power and if it needs to be translated, and if you translate it for SLP Lance will comp you with a Premier plugin (not the subscription just the plug in) See the link below:

    https://docs.storelocatorplus.com/blog/translating-store-locator-plus/

     

     

    In that case please contact us and send the file to contact us support.

    #45256

    Wolfram
    Participant

    Hi Cici,

    this is what I’m doing:

    • Go to “Store Locator Plus” -> “Locations”
    • Check the location I want to assign a category to
    • Under “Bulk Actions” choose “Categorize”
    • Check the category/categories I want
    • Click “Apply” at the top
    • —> Category is assigned correctly
    • then I edit something within(!) this location, i.e. street name or phone or whatever and click the blue “Update” button to save
    • I am redirected to location list BUT my previously assigned category is gone!

    Maybe you can re-test this with your setting and give me a feedback if this all works fine, then we can discuss further 🙂

    Thanks for the help!

    #45257

    Wolfram
    Participant

    oh and no, what is Tagalong….? Never used it (before) ….

    As far as for the categories, we both import them and assign them via the process I described above in the locations list. But both get deleted as soon as you change something within a location.

    As for the translation… yes, it’s German, and it got translated automatically on install (at least some parts of it translated, not all) – I don’t mind using the English version but it would be great to be able to edit some German phrases since some of them are not quite well translated 😉

    #45262

    Cici
    Keymaster

    Wolfram,

    1) The way you are describing the categorization is the way it is supposed to work, if you make changes to you locations name or address, and update , also select the categories at the same time to ensure they are all updated correctly,   I will try to recreate your issue on my test site.

    Q. are you importing and updating multiple locations via csv file?

    When a location is uploaded it is assigned  sl_id.  So if you are importing the changes you need to have a column called sl_id and enter the sl_id

     

    https://docs.storelocatorplus.com/blog/locator-data-the-field-names/

     

    2) we do not do the translations, since we do not speak all the languages here. You can translate (in your spare time haha) and send the files, I provided you the documentation on how to do that.

     

     

    +

     

    #45263

    Cici
    Keymaster

    Wolfram

     

    I followed your steps .

    1) Under bulk actions I selected a few of my locations and Categorized them with a different category and updated and saved. It saved correctly.

    2) Using Location Manage I then edited a y locations name and address. I did not reselect a category, I clicked update.

    3) I went back in to see the updated location with new name and address and the category (the new one) I had selected remained exactly as I had changed it.

    I cannot recreate your issue. Please clarify , are you changing Location name or are you changing something in Stores?

     

    Are you editing via “User managed Locations ”

    That is the only thing different from my site then yours, I do not have User Managed Locations and apparently DeBaat has not updated User Manged Locations beyond 4.5.03..

     

    Please let me know

     

    #45264

    Cici
    Keymaster

    P.S. I cannot access the site url you have listed, assume it is your dev site?

    #45266

    Wolfram
    Participant

    Hi Cici, I recorded a screen cap to clarify (see attached mp4, I hope it works)

    Is this the way it is supposed to?! This would be not really good since you have to re-assign categories each time you change i.e. a store name/phone number or whatever…..

    No, I’m not editing via User Managed Locations, I have it installed though but this should not interfere with the Power plugin?

    Thanks!

    Yes, site above is behind password, as mentioned above:

    User: test
    Password: 12345

     

    #45267

    Wolfram
    Participant

    #45278

    Cici
    Keymaster

    That isnt happening in my test site. I just checked it and ran it again,

     

    Clear your cache.

     

    AS A SIDE NOTE, I noticed you have no addresses so you are just changing the name of the location?  So perhaps you are trting something unique, do you have special code or did you change something that interatcs or uses the WP taxonomy used for SEO Pages  and categories? I cannot figure out what is different from your and mine but I do not have all the other plugins and UML running so it is difficult to assist you.

     

    The developer will check when he has time but he is working with Premier customers and customization customers as well as dev.   If it is unique to your site setup and you need troubleshooting with someone logging in that is done thru Paid Troubleshooting support. We do not log into customers sites without express permission via the paid troubleshooting support option , the developer will tell you what you need to do, at that time  before he logs into your site. If it does turn out to be a bug in SLP we will compensate you via the paid support ticket. If it turns out that you have multiple plugins or a theme or WP  issue /conflict that is unrelated to SLP then he  will not fix the other plugins or themes since that is beyond the scope of troubleshooting.

     

     

    #45286

    Wolfram
    Participant

    Hi,

    cleared cache, tried in empty/ other browser, still all the same.

    Deactivated all plugins except Store Locator Plus, Power and Experience.

    Still same thing happening 🙁

    No special other setup or unique changes here, especially after deactivating all other plugins.

    No change of WP taxonomy.

    Oh and we do have addresses for each location….

    Would be great if Lance could check, can you notify him? Or how would this work? I can wait a few days since we have other things to work on too on that page, so we might go with normal support on this issue – will you give me a feedback here if he finds the time?

    Thanks!

     

    • This reply was modified 5 months, 3 weeks ago by  Wolfram.
    #45288

    Wolfram
    Participant

    As far as I can tell, this seemed to have occured after the last upgrade (not the one you suggested to 4.7.6 but the one before that which we did on the base plugin)

    • This reply was modified 5 months, 3 weeks ago by  Wolfram.
    #45590

    Cici
    Keymaster

    Update your version to the latest Power and SLP

    #45613

    Wolfram
    Participant

    Still happening 🙁 – I’m on 4.7.8 for both SLP and Power, Experience is at 4.7.6 – is there also an upgrade? If so, my wordpress isn’t showing one to me so far, any place else where to get it directly?

    #45614

    Wolfram
    Participant

    oh by the way…. would there be any “paybacks” if we decided to go from our EXP and POWER to PREMIER….? The only feature we would need from Premier would be the pagination (or is there ANY other hack to wrap results to pages 1, 2, etc….?) but we already bought EXP and POWER for 500 bucks so to have another 425 bucks for a setup fee is a little too much for us atm…..

    #45619

    Cici
    Keymaster

    I mentioned in our initial email concerning Premier, you had concerns about upgrading to Premier. But if you upgrade to Premier in a reasonable amount of time we can generate a coupon to offset the sign up fee.  You can request a coupon via email to  support .  The coupon would only be valid for a one time use to offset the sign up fee.

    We do not provide “hacks”.  It isnt  advisable nor  supportable with future updates

    #45891

    Wolfram
    Participant

    Hi Cici,

    this problem just got worse after the latest upgrade of base, Power and Experience to 4.7.9. …..before, categories disappeared after editing and saving a location, but we could reassign them in the list.

    Now, I can’t even reassign them via the list….. weird thing is, if I go into a location to edit it and have a look under the “Categories” list there (which is new in edit view?), I do see the categories assigned to thios location but they are not searchable in front end…….?

    Any idea???

    I can give you admin access to the site if needed…..

    Appreciate any help on this….. need this fixed asap….

    #45892

    Wolfram
    Participant

    Hi Cici,

    here are my Power Janitor settings, see attachment, and the Environment again:

    Store Locator Plus:4.7.9
    Experience:4.7.9
    Power:4.7.9
    +Pages , Contacts
    Social Media Extender:4.5.02
    User Managed Locations:4.5.03
    Janitor:4.6.5
    Site URL:http://www.tuning-plaza.de
    This Info Cached:1491119963
    Network Active:No
    WordPress Version:4.7.4
    PHP Version:5.4.45-0+deb7u7
    MySQL Version:5.5.52
    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:105 MB
    PHP Post Max Size:8M

    </div>
    </div>
    </div>
    </div>
    </div>
     

    Attachments:
    You must be logged in to view attached files.
Viewing 25 posts - 1 through 25 (of 32 total)

You must be logged in to reply to this topic.