This topic contains 2 replies, has 2 voices, and was last updated by  Cici 2 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46816

    Terry
    Participant

    We use blue and yellow icons to differentiate types of businesses where our equipment can be found, but it seems a gray icon keeps appearing. Possibly, this is marking the searcher’s starting point?

    See: https://pulsecenters.com/locate/

    Otherwise, what does gray icon signify? How do we get rid of it?

    Thanks,

    T

    #46818

    Cici
    Keymaster

    First, your versions are not updated to latest releases of SLP

     

    Second: Check your theme CSS , it appears that the grey bulb is showing the “center of the map”, i.e what Google thinks is the center of the US. , so yes it may be a home marker  if you do not have Locate sensor turned on and you have hide radius

    Third : Your web site has warning about mixed content.  Your icons are under http but your site is https

    Mixed Content: The page at ‘https://pulsecenters.com/locate/’ was loaded over HTTPS, but requested an insecure image ‘http://pulsecenters.com/wp-content/plugins/store-locator-le/images/icons/bulb_azure.png’. This content should also be served over HTTPS.

    (index):1 Mixed Content: The page at ‘https://pulsecenters.com/locate/’ was loaded over HTTPS, but requested an insecure image ‘http://162.144.204.20/~pulsecen/micro/wp-content/plugins/store-locator-le/images/icons/bulb_azure.png’. This content should also be served over HTTPS.

    (index):1 Mixed Content: The page at ‘https://pulsecenters.com/locate/’ was loaded over HTTPS, but requested an insecure image ‘http://162.144.204.20/~pulsecen/micro/pulsecenters/wp-content/plugins/store-locator-le/images/icons/bulb_azure.png’. This content should also be served over HTTPS.

    #55638

    Cici
    Keymaster

    Hi Terry,
    I revisited your site and noticed you had updated the add-ons but not SLP. You might want to update SLP to work with current versions.

    You still have mixed content messages. This often happens when a site is served over https but the images are being uploaded from the older site http.

    I had same situation.
    The fix is fairly easy. Just look at your markers on SLP and either re-select or if you have custom icons select from the media library and paste in the icon file location.
    The correct format in the marker field (or icon field) string should end in

    /wp-content/uploads/slp/saved-icons/arrow.png

    the old string would end in
    /wp-content/plugins/store-locator-le/images/icons/arrow.png

    the problem with adding them to the SLP directory was that every time WordPress would update they would overwrite the directory. Thus your images would be deleted.

    If you do not want a “home marker to appear, just select the blank under Settings/ map hide home marker.

    You can also change the home map marker same way as eplained above, by selecting an image you wish to display as home marker.

    Thanks, I will close this forum post. If you have any questions please post a new topic.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘What's the gray icon?’ is closed to new replies.