Store Locator Plus for WordPress Forums Store Locator Plus This site most likely needs a Google Maps API key

This topic contains 6 replies, has 2 voices, and was last updated by  Cici 3 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #56664

    Wolfram
    Participant

    Hi, since yesterday, we’re getting this error – just regenerated our Google API key but this still doesn’t work – no restrictions for the key.
    We have a 4.8.3 running plus Power and Experience (can’t upgrade since we have some custom code running) – but all worked fine until yesterday. Any ideas?
    http://www.tuning-plaza.de

    Thanks!

    #56669

    Cici
    Keymaster

    No idea, if you didn’t update anything on our end. Did you update WOrdPress or any other plugins?

    I just went to your site and a pop up window came up and states “this site most likely needs an API key.” That is not coming from us but most likely direct from Google, I guess it is their way of giving you a warning before the June 11 deadline. As far as I know they didnt move the deadline up but who knows, its google.

    You probably need to find a solution to not being able to update the plugins soon. Google requires an API key and a billing account for everyone now. we cannot guarantee old versions of the plugin or insecure sites are going to continue to work as a result.

    The developer is also making changes to the base plug-in as a result of the new google API key requirements and concerns about privacy.

    Starting with 4.9.15 there will be two keys, one for browser key (allowing for HTTP referrers) and then another for a geocoding key.

    #56670

    Wolfram
    Participant

    ohhh right. the deadline and the billing account, that could be it? We haven’t added billing details to our Google account yet.

    Or we might have to find a way to upgrde… will try the billing details first. Thanks.

    #56671

    Wolfram
    Participant

    Hi, ok, so we managed to upgrade all 3 plugins (Base, Experience and Power) to the latest versions – no Google popup any longer, but weird thing, in Firefox it seems to work fine, but in all other browsers when I try the search it shows an empty map frame and no results…. any idea?

    #56672

    Wolfram
    Participant

    ….I think it only works at the moment when I’m logged in with my Google account?! Then it’s all fine. But doesn’t work when not logged in to Google?!!

    #56673

    Wolfram
    Participant

    GOT IT!! It was our caching plugin. WP Fastest Cache. Deleted Cache and now everything works fine again 🙂

    #56675

    Cici
    Keymaster

    LOL, I am glad you found the issue. Please let us know if you have any problems after the next updates scheduled to be released sometime before (hopefully) June 11. Most people will not be effected by the change in Google quotas as long as they add billing credentials to their API projects but we know it will scare a lot of people , especially those who never got an API key since will no longer have geocoding functions without one. We have posted news content about the upcoming changes and will do so again.

    I will close this support ticket . Thanks

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.