Store Locator Plus for WordPress Forums Store Locator Plus Store Locator working within backend but not frontend?

This topic contains 3 replies, has 2 voices, and was last updated by  Cici 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #57614

    David
    Participant

    Hi Guys,

    My store locator is working fine when I am logged in to the WordPress CMS however when I am logged out the locator is down?

    Lates versions of WordPress and Store Locator Plus installed.

    See attached for some screen grabs.

    Thanks in advance.

    David.

    Attachments:
    You must be logged in to view attached files.
    #57620

    Cici
    Keymaster

    I do not know what those screen shots are showing us.

    Please refer to the posting guidelines. The only screenshot we need is that of your WPSLP plugin environment  and site url would help.

    Grey map or blank map (DOCS INFO here) indicates Javascript issue. You need to use the debugger or troubleshoot , i.e  deactivate  other plugins one by one. If you have Smush deactivate it.

     

    #57692

    David
    Participant

    Hi Cici,

    Apologies, see attached for the plugin environment.
    Firefox Console is showing a few of the below.
    Loading failed for the with source “https://maps.googleapis.com/maps/api/js/AuthenticationService.Authenticate?1shttps%3A%2F%2Fwww.sidchrome.com.au%2Fstore-locator%2F&4sAIzaSyBeUG7dlPwEg1bnIRhu2jmQ2Txkm9MF22U&callback=_xdc_._rwo8ff&key=AIzaSyBeUG7dlPwEg1bnIRhu2jmQ2Txkm9MF22U&token=59329”.store-locator:1

    Thanks in advance for your assistance.
    David.

    • This reply was modified 3 weeks ago by  David.
    Attachments:
    You must be logged in to view attached files.
    #57701

    Cici
    Keymaster

    That type of  situation is caused by a plugin or a theme that is breaking  Javascript.

    See Troubleshooting here, grey map or blank map.

     

    I provided you the link in above answer. Did you follow the Troubleshooting? Did you use WordPress debugger (not firefox) , that is the log we would need to assist you, not your console log.  Additionally your browser console is showing the errors that state: The Google Maps JavaScript API must be downloaded directly from Google’s servers. Learn more: https://developers.google.com/maps/documentation/javascript/tutorial#Loading_the_Maps_API

     

    So I am not sure if you have a theme that is also using some Google Maps API , if it is using outdated Javascripts or if it is another plugin .  Anything that is breaking Javascript will break the Map.

    https://docs.storelocatorplus.com/blog/q-i-see-a-gray-map-or-blank-map-and-search-does-not-work/

     

    https://docs.storelocatorplus.com/blog/debugging-with-debug-log/

     

     

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.