Store Locator Plus for WordPress Forums Store Locator Plus Store Locator Plus conflicting with another plugin

This topic contains 6 replies, has 2 voices, and was last updated by  Cici 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #56792

    Mike
    Participant

    Hi,

    I am using Store Locator Plus:4.9.16, Experience:4.9.14, Power:4.9.15. Plugin environment attached.

    I am having an issue getting the Toolset Views plugin to work with Store Locator Plus. Every time I activate the Views plugin, the SLP map does not appear. Instead, a Javascript error (attached) appears on the page (visible with Google’s “Inspect elements” feature) and the map disappears. Our map is located at https://tafb.org/find-food.

    I have been working with the support team at Toolset on this issue, but they are running into a wall. I installed the Duplicator plugin on our site and created a Duplicator package that I shared with Toolset’s support team so that they could try and replicate the issue.

    They installed the Duplicator package on but the SLP plugin doesn’t work. On the Find Food page there is no content (no map) shown at all, irrespective of whether Views is active or not.

    Do you know why SLP is not working on their test site? Any help you can provide is greatly appreciated. Thank you!

    • This topic was modified 3 months, 1 week ago by  Mike.
    Attachments:
    You must be logged in to view attached files.
    #56796

    Cici
    Keymaster

    Thank you for providing your plugin info.
    The js error attached does not provide any details for us to assist you.
    A couple of suggestions:

    1) On your test site did you add a Google API key?
    2) Troubleshooting for javascript errors..See this Page in documentation

    #56800

    Mike
    Participant

    Yes, a Google API key was added on the test site. That did not change anything. I will take a look at the page you shared. Thank you!

    #56802

    Cici
    Keymaster

    Mike, if you could share what you have found once resolved that would be of great benefit to other users. There are so many plug-ins out there, some orphaned, some not tested fully with latest version of WP, some that conflict with themes. Any info is helpful. For instance we had a forum contributor recently answer another post that Smush was causing SLP and other plugin admin panel to not work.

    #56803

    Cici
    Keymaster

    One other suggestion i.e. regarding the the duplicator plugin. The Google API key you obtained for the cloned site. Did you have ANY referrer restrictions? Referrer restrictions are not suggested for testing or staging sites. you should have no restrictions for the purpose of testing. Check for errors on the console https://developers.google.com/maps/documentation/javascript/error-messages

    If you do have an IP Https referrer restriction you will also need a Geocoding key.

    https://docs.storelocatorplus.com/blog/mixed-content-warnings-site-migration/

    https://www.storelocatorplus.com/google-api-key-changes-for-wordpress-plugins/

    #56830

    Mike
    Participant

    Thank you for the information, Cici! We are still working to resolve the issue. Hopefully we will get to the bottom of it soon.

    #57000

    Cici
    Keymaster

    Hello Mike, it looks like you have resolved the error on the production site at least. Did you find what the issue was? Was it a migration issue or a url path or javascript or other plugin or theme conflict?.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.