State and Country Selections Won't work

Home Forums Store Locator Plus State and Country Selections Won't work

This topic contains 14 replies, has 2 voices, and was last updated by  Cici 1 week, 4 days ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #46242

    Terry
    Participant

    <span style=”color: #43454b; font-family: ‘Source Sans Pro’, HelveticaNeue-Light, ‘Helvetica Neue Light’, ‘Helvetica Neue’, Helvetica, Arial, ‘Lucida Grande’, sans-serif; font-size: 12px;”>No matter where I set the “selector” on STATE and COUNTRY, .the search doesn’t work.  I’ve tried every setting the “selector” tabs offer. Perhaps there is a setting somewhere else that needs to be changed? Please see attach and offer some guidance.</span>

    Attachments:
    You must be logged in to view attached files.
    #46259

    Cici
    Keymaster

    Under city setting is correct, use drop down  address input or discrete.

    Under State use dropdown discrete

    Under country use dropdown discrete

     

    Make sure you click the green save box on upper right of your page and when you check the site url, refresh your page

    #46260

    Cici
    Keymaster

    If you mean after you click you need to check your results radius settings. You want to disable initial directory. Not sure if I understand your question.  You only want the locations to show for the state or city they searched in results. Disable initial directory, set default radius higher.

    They can search by city or state or country but all 3 together will confuse the logic of the system . That is why the city also shows the state with it, you cannot have them select a city and a state that does not belong to the city associated with it in your locations database.

    You might want to deploy the widget tool so behind the scenes they are redirected to a map page with only that State or Country criteria. More info  in docs site

     

    Additional Auto guess features are built into the premier add-on

    #46286

    Terry
    Participant

    I used “Dropdown, Discrete Filter” on both states and countries (see attached), but countries still doesn’t work.

     

    Attachments:
    You must be logged in to view attached files.
    #46288

    Terry
    Participant

    Is there any setting in “Functionality” that should change?

     

    Attachments:
    You must be logged in to view attached files.
    #46299

    Cici
    Keymaster

    Put either city or state as hidden, you cant use all three at same time. Or you can use the WIDGET part of the Experience add-on and it will show all three to select from.  Are you asking people in the label section what to input on city? If not then there is no reason to show them city unless you only want them to be able to search in the city

     

    #46300

    Cici
    Keymaster

    Further explanation in documentation on how to use those functions.

    The ” Hide radius” feature was added to Experience and allows you to disable the radius limitation, effectively allowing the product to show all locations regardless of distance.  This helps resolve some of the issues, but in the case noted above it may still show locations outside of the state, especially if your limit on number of results returned is a high number or a particular state has one or two locations.  As an aside: it is recommended that you hide your radius selections when this feature is enabled.

     

    In discrete search mode the data is filtered to match EXACTLY with the data selected on the drop down menu.   If the user chooses the city drop down (it shows city plus state to avoid confusion in like-named cities) it will ONLY show entries in the database that match the city and state exactly as displayed.   If the user selects a country or state then it  only shows either the locations in the specific country or the specified state.    Locations outside of those selected will not be shown.    This mode works best if the “ignore radius input” is active.    If you do not wish to ignore the radius on ALL searches then having a large default radius is prudent as the discrete mode will start by placing the “search from here” marker in the middle of the city, state, or country being selected.  In a large state such as Texas this may not return ALL of the results in Texas if your default radius is set to 50 miles.

     

     

    Store Locator Plus Discrete Searches

    #46301

    Terry
    Participant

    Re: “<span style=”color: #43454b; font-family: ‘Source Sans Pro’, HelveticaNeue-Light, ‘Helvetica Neue Light’, ‘Helvetica Neue’, Helvetica, Arial, ‘Lucida Grande’, sans-serif; font-size: 12px;”>Put either city or state as hidden, you cant use all three at same time”</span>

    We did previously, before upgrading WP, upgrading SLP, and changing web hosts.

    Nevertheless, making cities “hidden”

    state “Dropdown, discrete filter”

    County “Dropdown, discrete filter”

    Did not work. Nothing worked with those settings.

     

    Attachments:
    You must be logged in to view attached files.
    #46306

    Cici
    Keymaster

    I do not understand, what exactly do you mean by “we did previously” . You changed Web hosts? Is your IP address the same?  Have you checked to see if your hosts is blocking the AJAX jquery?

    (See info in documentation on that….”It is common for web hosts and system administrators to disable the built-in WordPress AJAX processing.   Store Locator Plus requires AJAX to be enabled.   This typically manifests itself with the AJAX call to the admin-ajax.php script not executing.” )

    Search and results not loading

    Please provide your site url where you are having issues.  We cannot inspect or test or troubleshoot without it. It is impossible to second guess all of your other settings and plugins. If you do not wish to share the info in the forum you can opt for  email paid support.  We have not had any  other reports from sites saying they could no longer use the Experience add-on the way that it was designed so something must have been changed on your site besides updating.  If your site requires further debugging beyond what is customarily done and if you need the developer to troubleshoot your site there is also an option for that under support.

    #46312

    Terry
    Participant

    I did the AJAX test and it came back as successful (<span style=”color: #000000; font-family: Consolas, Monaco, monospace; white-space: pre-wrap;”>{“success”:true,)</span>

    http://www.pulsecenters.com/locate/

    On our previous host (GoDaddy) we provided search by city, state, and country. I’ve tried every option available with those three selectors (even hiding one), but I’m unable to search by country.

    Since we are again changing webhosts (Bluehost is terrible, not because of this issue specifically, but in customer service and just about every regard), it might be best to wait until we’ve made the switch.

    Thanks.

    #46315

    Cici
    Keymaster

    it may be best but if you inspect the page on the link you provided you see this FAILURE

    js?v=3.exp&ver=1497539285:96 You have included the Google Maps API multiple times on this page. This may cause unexpected errors.

     

    Have you added the  Google MAP API in multiple places or is another plugin also using the Google MAP API or possibly the theme?

    Review the developers post, scroll down to Servers here.

    He has a lot of experience about shared hosts, servers, etc. You might want to check out the MY.SLP.com plans and see if that is a viable alternative for you as well

    #46316

    Cici
    Keymaster

    See Lances NEWS Posts here

     

    #46317

    Cici
    Keymaster

    See Lances NEWS Posts here

     

    #46319

    Terry
    Participant

    I got a new API key only to find out the old one apparently worked (after my DNS was re-pointed).

    So, you’re telling me that there’s a conflict of dual API keys. Where are they inserted into WP?How do I clean one out?

    Why are you now telling me that I can have only two of three selectors visible? On our previous host, with a previous version, city-state-country all worked, as indicated by an article I had downloaded from your website several months ago.

    I’ve put a lot of work into trying to correct my problem, as you might see from the attached.

    How about you specifically indicate what you think will fix the problem, instead of “see Lance post”

     

    Attachments:
    You must be logged in to view attached files.
    #46323

    Cici
    Keymaster

    The NEWS was about server options since you said “lets wait” it was onyl to provide you some feedback. Since we are doing show and tell, I am attaching screenshots of my settings and the discrete filters, all 3 are working as described on my site. Also in the back end user interface you will see all types of documentation written into the panels settings themselves.  when you highlight a certain line , such as allow selector or discrete filters it tells you what it does  … such as “should I allow selector or disable selector”   there is an explanation in the box to the right telling you exactly what it does,

     

    I understand you are frustrated but I am not in the back end of your site changing buttons in a multitude of ways  and have no idea what you changed first ,second, third, and fourth

    I went to the trouble of looking at your site url and seeing the error messages.  Troubleshooting your site is not part of the support forum. If you need a developer to troubleshoot your site that is a paid support option so I will not do it again. My apologies for trying to solve your issue.  You can inspect your own site by using any developer tools on any of your browsers, I assume you are a web designer, IT admin,or developer?  I am none of the above and I can  look at someones site and see what errors might be on their site by  right clicking on the page using any browser.

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.