Store Locator Plus for WordPress Forums Store Locator Plus Split: Sorry it was nother plugin causing my Functionality Issues with Latest Update

This topic contains 8 replies, has 2 voices, and was last updated by  Cici 1 month, 1 week ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #55338

    Joe
    Participant

    No, that is not my site. My info is as follows:

     

    Store Locator Plus:4.9.1

    Experience:4.8.4

    Power:4.9

    Premier:4.9

    Extended Data Manager:4.5.01

     

    Site URL:http://www.hamiltonmfg.com

    This Info Cached:1512134006

    Network Active:No

     

    WordPress Version:4.9.1

    PHP Version:5.6.32

    MySQL Version:5.6.36

     

    PHP Limit:768M

    WordPress General Limit:128M

    WordPress Admin Limit:768M

    PHP Peak RAM:97 MB

    PHP Post Max Size:128M

    #55339

    Cici
    Keymaster

    @ Joe

    Lance was answering Suzanne who glommed onto your post.  That is what happens when people add onto another post, we are not chastising anyone but it is difficult when you start seeing multiple conversations when users add on and  use same topi. The topic functionality issues…..it is so general…

    Go Here and you can download any version of WPSLP, Scroll under advanced view, previous versions all the versions are in there.

    #55340

    Cici
    Keymaster

    @ Joe, your console shows these error messages .

     

     

    js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:94 You have included the Google Maps API multiple times on this page. This may cause unexpected errors.

    bh @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:94

    js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:38 Google Maps API error: RefererNotAllowedMapError https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error

    Your site URL to be authorized: http://www.hamiltonmfg.com/locator/

    _.Pb @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:38

    util.js:249 Google Maps API warning: SensorNotRequired https://developers.google.com/maps/documentation/javascript/error-messages#sensor-not-required

    FC.j @ util.js:249

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:145

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:59

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    _.P @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    _.x @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:31

    fe @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:145

    util.js:249 Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

    FC.j @ util.js:249

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:145

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:59

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    _.P @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    _.x @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:31

    fe @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:61

    (anonymous) @ js?language=en&region=US&key=AIzaSyAxUXrqsb4hbDXJycqw-Vor0tmvso-YW_0&ver=4.9.1:145

    #55341

    Joe
    Participant

    OK, so I installed 4.8.7  (the last version we had before the issues started) and now my site is popping an error message saying it’s requesting an API key. Our API key was already saved in SLP, but I generated a new one any way and am still getting the error. Any ideas?

    #55342

    Joe
    Participant

    Now the map is showing again, but search functionality is still broken. At this point I’ll just pay to have someone fix it, this is crippling our business. How quickly can one of your team do this for us?

    #55343

    Cici
    Keymaster

    @ Joe

    Please refer to troubleshooting…as I began to mention but hit submit button too fast   this is not coming from SLP…It is another plugin and/or your theme that is also using a Google MAP API.  Your Site has multiple map APIS, it also has error message “sensor not required” which hasn’t been an issue with SLP for over 3 plus years

    …and you have referrers which Google does not allow

    See your Google developers console error messages.

    Here is Troubleshooting guide

    Did you migrate your site  or update ANY other plugins or themes?

    Turn them off one by one (basic WP debugging) switch to a WP theme, etc

    These issues most likely did not pop up overnight without some updates occurring, unfortunately the map or search not working almost always raises an alarm.

     

    P.S. Also if you do not have a valid SSL certificate there is a good chance Google will not return much of anything. They are getting very strict with their protocols and security.

     

    Attachments:
    You must be logged in to view attached files.
    #55345

    Joe
    Participant

    I cannot believe this… and I am kicking myself for not doing basic debugging. We installed an anti-spam plugin (CleanTalk) and that was it! Sorry for the panic, but we rely on SLP daily. Thank you for your help!

    #55346

    Cici
    Keymaster

    We have a team that can work on your site through a retainer program.

    Do you have a virtual or staging site? They will require that a backup of your site is done (that is separate if you do not have a backup WP plugin like JetPack )  If it is your theme that was copied over wrong…not sure how many hours it will take.  You will have to discuss with the  developer and get on schedules. All troubleshooting, building or   fixing WP sites  is done through cybersprocket.

    #55443

    Cici
    Keymaster

    @ Joe.

    I hope you found our help useful.   The developer stopped  his customization project to answer  but it was Suzanne’s site who was over query limit and who had added onto your post , good example of why we ask people to start a new topic  🙂

    Sorry about that.!

    I am glad you were able to find the error was another plugin and we are very happy that you use SLP extensively to promote your business.  If you have a minute to write a review that would be appreciated.  If you feel as though we were not responsive or too slow in responding and do not warrant five stars, please send an email to contact us and the boss will get right on it. (and  I will get coal in my stocking for sure. )

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Split: Sorry it was nother plugin causing my Functionality Issues with Latest Update’ is closed to new replies.