This topic contains 22 replies, has 3 voices, and was last updated by  Lance Cleveland 2 years, 5 months ago.

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #39067

    wselwood
    Participant

    The shortcodes on my store pages seem to be broken.  It’s only a fairly new thing as far as I know, all the plugins are up to date (included the version history too).

    I’ve attached the lines of code for the store page set up, the results of the code (status bar) and the field in the database.  I’m not sure why it’s not functioning, can you let me know why it’s not working?

    Attachments:
    You must be logged in to view attached files.
    #39097

    Cici
    Keymaster

    You need to update all your versions, you are not on the latest versions.

    I am glad you added the screenshot of your plugin Environment, this is why we ask for it before posting…Actually, the only thing you do have updsated and current is the base SLP plugin

    First:

    You need to download the Experience addon that replaces ALL the Enhanced addons and Widget pack. As a premier subscriber you are not charged  any additional amounts for the EXP add-on.

    You MUST download the EXPERIENCE add on to 4.4.07 or above before updating  the base plugin to 4.4.27. This is not the normal way of doing it but for those people who did not Upgrade to Experience when it was released will have an issue when updating SLP.

    Pages is on 4.4.03

    ProPAck is on 4.4.01

    Tagalong is on 4.4.01

    Social Media is on 4.4.01

    etc

    Here is where you can check to see if you are  current on your releases and release notes

    Also if you look at the INFO tab in your SLP admin panel you will see the blogs and posts and news on the right hand side, they are usually posted when an important update or release is made.

     

    #39213

    wselwood
    Participant

    Ok, well that didn’t fix the problem and now ALL the customisations I made to the code have been overridden by the new module…

    So can we try again to fix my problem?

    #39214

    wselwood
    Participant

    it’s also deactivated the FIND NOW button too…

    #39216

    Cici
    Keymaster

    If you saw the Release Notes for Pages, It states you must be running WP 4.4.   Also something on your site is causing Google Maps API to be called.  (see attached)

    I went to your main site and the Find church now Button worked, I do not know what the screenshots you included in first post is intended to show , when I tried to access that http://crossroadschurchsydney….URL I could not  so is that a permalink issue perhaps?

    How to setup Store Pages

    A lot has changed with the Pages and WP codex on how you could set up pages (which is a Post )

    So could you provide more detail about your page template.

    Nothing in SLP updates effected CSS if they were saved correctly as far as I know.

     

     

     

    Attachments:
    You must be logged in to view attached files.
    #39218

    Cici
    Keymaster

    P.S. When you updated to EXP did you install that before updating SLP as warned in latest INFO NEWS (which can also be seen under your SLP Admin panel INFO tabs ?

    Pages Release Notes

     

    #39223

    Lance Cleveland
    Keymaster

    Provide your public site URL and I can tell you what is wrong with your WP setup.   Without that I cannot venture a guess as to what may be interfering.

     

    99% of the time it is another plugin or something in your theme that has messed up their JavaScript implementation.

    #39224

    Cici
    Keymaster

    I have spoken to Lance already and he cannot help us solve your issue  without more information, he needs the exact site url that you are experiencing issues with and since you updated can you provide your  new Plugin Environment (since you stated the update broke more things??)

     

    Thanks

     

    #39245

    wselwood
    Participant

    Ok in answer to your many questions:

    1. updating to WP 4.4 now.  we have to be careful as the theme can’t keep up with the latest WP versions sometimes.

    2. updating to EXP was done as per your last instructions – EXP download, then update SLP.

    3. FIND button is now working, it wasn’t before.

    4. site is http://www.churchfinder.com.au

    5. the original enquiry was that the short codes for sending an email or visiting a webpage no longer work.  So if I choose Church A from the map, it takes me to Church A’s Store Page.  Down the bottom we have a link that says Send An Email, but the code (even though the field is correctly filled (see this screenshot – https://wordpress.storelocatorplus.com/wp-content/uploads/2016/02/Screenshot-2016-02-29-11.11.24.png) doesn’t actually do what it should – the code is incomplete on the page (see the status bar at the bottom of the image) –  https://wordpress.storelocatorplus.com/wp-content/uploads/2016/02/Screenshot-2016-02-29-11.09.23.png).  So what we have is a short code that says: Send Email To [storepage field= and that’s it, so it’s a broken short code.  Same with the webpage link as well.

    6. plugin environment attached.

    Attachments:
    You must be logged in to view attached files.
    #39246

    wselwood
    Participant

    This is the code for the store pages:

    Click Here to Send Email

    [storepage field=”sl_url”]

    <p></p>

    Social Media: [storepage field=”socialiconarray”]

    <p></p>

    #39288

    Cici
    Keymaster

    Lance suggests the following:
    Replace the email in the straight HTML version with a dynamic field from the database…. [storepage field=email] for example.
    There are some caveats on email as some of the fields are special cases with extra formatting.
    You can add other weird stuff to mailto: hyperlinks, but anyone messing with that needs to really know HTML and the premises to create the rules. There are ways to add a from and subject line but it is complicated.
    Regardless the premise is the same. Start with the “vanilla” HTML without SLP shortcodes. Get that working then rip out each element that should be “dynamic” (replaced with SLP data fields).

    #39292

    Cici
    Keymaster

    P.S. I looked at your lines for those two  on your site, and there is a space before the field attribute name…not as shown above. If you take out that space before the field attribute does it now work?
    The Lines look like this:
    href=”mailto:[storepage field=” sl_email”
    and for the site url href="[storepagefield=" sl_url"]

    Also there are still error messages that indicates another plugin is also loading Google Maps on the individual store pages.

    You have included the Google Maps API multiple times on this page. This may cause unexpected errors.Qg @ js?language=en&ver=4.4.27:90

    js?language=en&ver=4.4.27:76 Uncaught TypeError: Cannot read property ‘offsetWidth’ of null

    #39402

    Lance Cleveland
    Keymaster

    Appears you now have an issue with Store Pages, so we are on a completely different topic here.

    You have an issue with how your Pages template is constructed.

    Please paste the full page template you have crafted here. It is not parsing properly.

    Also be advised that WordPress changed how shortcodes handle quotes. It cannot handle shortcodes with quotes for attributes within an HTML element that has quotes. There has been a lot of controversy over this move by WordPress but they refuse to change their position citing security concerns. It may require some creative templates to do what you want, but let’s start with pasting your Page template setting here.

    #39428

    wselwood
    Participant

    Thanks Lance.  Hadn’t caught up with the change in WP formats – that sucks…

    Code as follows:

    <span class=”store name”>[storepage field=”sl_store”]</span>

    [storepage field=”sl_address”]

    [storepage field=”sl_address2″]

    [storepage field=”sl_city”] [storepage field=”sl_state”] [storepage field=”sl_zip”]

    [storepage field=”sl_country”]

    <br><br />

    <h2>Description</h2>

    <p>[storepage field=”sl_description”]</p>

    <p></p>

    <p></p>

    </ br>

    <h2>Contact Info</h2>

    Phone: [storepage field=”sl_phone”]

    Minister/s: [storepage field=”sl_fax”]

    Service Times: [storepage field=”sl_hours”]

    Click Here to Send Email

    [storepage field=”sl_url”]

    <p></p>

    Social Media: [storepage field=”socialiconarray”]

    <p></p>

     

    Affiliation: [storepage field=”sl_tags”]

    #39477

    Cici
    Keymaster

    Hi Wes,
    There are three new Updates that were released today. Pages, ProPack and SLP.
    Before you get too far down the rabbit hole in redoing the Page template you may want to update those.
    Info about todays releases.

    And yeah, WP screwed up a LOT of people and pissed off a lot of developers if you follow the trail in their July 2015, I wrote about the double quotes and shortcodes it in a post a while back. You can keep up to date with News about releases and other important issues under your SLP plugin in under INFO, the News appears on the right side of that panek now.

    #40195

    wselwood
    Participant

    I’m almost done with this plugin – I’ve changed the code and tried to update the records but it’s just not working!

    This is the new code that I changed in the PAGES tab:

    <em><a href='mailto:[storepage field="sl_email"]?subject=Contact from Church Finder Website'>Click Here to Send Email</a></em>
    
    <em><a href='[storepage field="sl_url"]'>[storepage field="sl_url"]</a></em>
    

    which worked with ONE record but won’t update any others.  I’ve selected the records and hit create page and NOTHING CHANGES.

    I’ve tried in bulk, I’ve tried in small batches and I’ve tried individually not apart from the initial record none of the others have updated.

    What is going on?  I have over 9000 records to update and I’m not doing these one at a time!

    #40196

    wselwood
    Participant
    <a href='mailto:[storepage field="sl_email"]?subject=Contact from Church Finder Website'>Click Here to Send Email</a>
    <a href='[storepage field="sl_url"]'>[storepage field="sl_url"]</a>
    #40209

    Cici
    Keymaster

    I’ve put this back on Lance’s radar to assist you , there was an update to Pages March 24th, did you update then along with SLP 4.4.36?

    PAGES UPDATE

    #40224

    wselwood
    Participant

    As far as I can tell – everything is up to date:

    Store Locator Plus:4.4.36
    Contact Extender:4.3.02
    Experience:4.4.10
    Janitor:4.4.03
    Pages:4.4.07
    Pro Pack:4.4.04
    Tagalong:4.4.03
    Social Media Extender:4.4.01

    This Info Cached:1459836446
    WordPress Version:4.4.2
    Site URL:http://churchfinder.com.au

    MySQL Version:5.5.5
    PHP Version:5.5.32

    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:39 MB
    PHP Post Max Size:128M

    #40229

    Lance Cleveland
    Keymaster

    @wselwood

    Are you editing each individual page and not the Page Template under the Pages tab?

    You need to go to the Store Locator Plus / Pages tab and set your template there, then go to the Locations / Manage subtab and create/recreate your pages. Keep in mind any edits you made on each individual page is overwritten.

    Read this article for assistance:
    Generating Store Pages

    Also, in Pages 4.4 there are specific shortcodes for setting the email hyperlink automatically, as well as one for a location map and website link. It is part of the default template. You may want to copy out whatever your existing template code is now to save it and then delete it (set the field completely blank) and save settings. The default page template for Pages 4.4 should be restored. It will likely have a lot of elements you want it will certainly have WordPress 4 friendly shortcode formatting without quotes.

    #40231

    wselwood
    Participant

    <p style=”text-align: left;”>Hi Lance, this is exactly how I’ve done it. Change the code under the pages tab in SLP. Then goto locations, select Bulk (or individual record or batches of) and select Create page – BUT the records don’t update.</p>
    <p style=”text-align: left;”>We don’t do any mods to individual store pages.</p>
    <p style=”text-align: left;”>So you’re saying, remove the page code to blank and start again?</p>

    #40247

    Cici
    Keymaster

    Hi , Yes that is what Lance is saying…As noted on the Page Template documentation

    ” The revised Default Page Template has eliminated any href of shortcodes in an html string as WordPress 4.2.3 no longer allows that.”

    So if you are still using this: you will have issues   <a href=’mailto:[storepage field=”sl_email”]?subject=Contact from Church Finder Website’>Click Here to Send Email</a>

    <a href='[storepage field=”sl_url”]’>[storepage field=”sl_url”]</a>

    #40262

    Lance Cleveland
    Keymaster

    @wselwood – try selecting a small subset of pages first.  Start setting manage locations to display 100 locations, check the “select all” box and permanently delete pages.    Those 100 locations should no longer show a linked page in the pages column.

    Then select the same 100 locations and use the bulk action create page.

    If that works try a larger subset of locations.

    It is very possible that trying to do 9,000 pages at once is overloading your WordPress server.  It SHOULD do SOME of the pages even if it crashes due to resource issues, but try 100 locations at a time first.

    Also make sure you try first with the default template.  I’m not sure what WordPress 4.4+ will do with extra quotes in shortcodes.  They really buggered up the shortcode processor in the name of “security”.

Viewing 23 posts - 1 through 23 (of 23 total)

The topic ‘Shortcode Broken?’ is closed to new replies.