Store Locator Plus for WordPress Forums Store Locator Plus Remote file retrieval settings

Tagged: ,

This topic contains 21 replies, has 2 voices, and was last updated by  Cici 1 month, 2 weeks ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #55512

    Amanda
    Participant

    Hi, I’m trying to set up my client with a daily Remote File Retrieval of a Google Drive CSV. I have no trouble manually uploading the CSV from my computer. When I enter the file link and set it to daily, and put in a time (say 00:30:00), there’s no way to save the settings. If I go to another tab in the SLP settings and come back it is erased, I have tried a number of combinations of inputting the setup and other places there is a ‘save’ button (like under General) but it always just gets cleared out. Any ideas?

    SLP environment below:
    Store Locator Plus:4.9.2

    Experience:4.9.1

    Power:4.9.1

    Site URL:http://www.hydroassoc.org

    This Info Cached:1508530221

    Network Active:No

    WordPress Version:4.9.1

    PHP Version:5.6.31-4+wpengine10

    MySQL Version:5.6.37

    PHP Limit:512M

    WordPress General Limit:256M

    WordPress Admin Limit:512M

    PHP Peak RAM:121 MB

    PHP Post Max Size:100M

    • This topic was modified 4 months, 1 week ago by  Amanda.
    • This topic was modified 4 months, 1 week ago by  Amanda.
    #55515

    Cici
    Keymaster

    Hi Amanda, Had you used the remote file retrieval before this latest update?
    WordPress cron is not exact, it executes the next time a visitor comes to your site, but if the remote file retrieval worked before and isn’t working now, I will have Lance look into that. I know he is working on some changes that effected Power with the Latest WP changes.

    #55518

    Amanda
    Participant

    Thanks for the reply, Cici. In this case, we never had used the remote file retrieval yet, I’ve only done the updates manually so far. The thing I’m concerned about is not that it didn’t happen yet, but that the fields that hold the file URL, and the settings and time, do not stay populated, making me think it is not going to run on a daily schedule. I can’t see how to save the information in those fields.

    #55522

    Cici
    Keymaster

    The issue has been identified to the developer. Thank you for posting this issue. There have been some changes to WP and their related functionalities that may have changed some of the settings. He will work on a patch in the next Power release.

    We apologize for the inconvenience. Stay tuned to the versions history for next update

    #55596

    Cici
    Keymaster

    Hi Amanda, Power 4.9.2 has been released. See post
    it should fix remote file retrieval,

    https://www.storelocatorplus.com/improved-import-power-4-9-2/

    #55656

    Amanda
    Participant

    Hi Cici
    Thanks for the note. I did download and install the new Power, but still my remote file retrieval settings won’t ‘stick’. I’m putting it in like this: https://www.screencast.com/t/wuiL1QkEq using the ‘sharable link’ for the Google doc (also tried with just the URL in my address bar). And if I click to another settings page and come back, it’s cleared out: https://www.screencast.com/t/ZCjwUp2vqJ. Using the shareable link made it so that the time and schedule stayed (those didn’t before), but the file seems to be cleared out. Maybe it saves the file URL but doesn’t display it? I can’t tell whether this will run or not…

    You can see this is the latest Power:
    === Store Locator Plus – Power ===
    Plugin Name: Store Locator Plus – Power
    Contributors: charlestonsw
    Donate link: https://wordpress.storelocatorplus.com/product/power/
    Tags: bulk import, seo, data management
    Required PHP: 5.3
    Requires at least: 4.4
    Tested up to: 4.9.1
    Stable tag: 4.9.2

    #55657

    Cici
    Keymaster

    Is the URL a public accessible url?

    when I add a remote file retrieval, my url is not cleared out and is sitting there waiting for the WPCron.

    not sure what your screenshots are showing us?

    The “latest Power” Does not show us your current plugin environment.

    #55659

    Amanda
    Participant

    Cici. I believe the issue is the ‘public’ link. I thought by getting the ‘share link’ from google docs, that that would be public, but I see now that it requires login, and so that’s likely the issue.
    Here’s the environment to be thorough, but I believe that is what is going on. Thanks for the reply.

    Store Locator Plus:4.9.2
    Experience:4.9.1
    Power:4.9.2

    Site URL:http://www.hydroassoc.org
    This Info Cached:1513109071
    Network Active:No

    WordPress Version:4.9.1
    PHP Version:5.6.31-4+wpengine10
    MySQL Version:5.6.37

    PHP Limit:512M
    WordPress General Limit:256M
    WordPress Admin Limit:512M
    PHP Peak RAM:121 MB
    PHP Post Max Size:100M

    #55660

    Amanda
    Participant

    Just to follow up, I changed the settings of that file so that anyone with the link can view it, and that solved the problem. I thought that’s how it would be before, but it turns out it was restricted to specific people.
    Thanks again.

    #55661

    Cici
    Keymaster

    Any remote URL must be accessible to the public.

    If you can’t surf to it in private mode in a browser w/o entering credentials it won’t work.
    If you have different versions of your plugin environment when you respond , please provide them . Alsao make sure your WPcron is not disabled.

    #55662

    Cici
    Keymaster

    Ok, I think our answers crossed paths, but yes, it cannot be restricted. WP must be able to get to it.

    let me know how it works out for you. I will close the post in a few days if all is well.
    Thanks for providing the information in your reply.

    #55921

    Amanda
    Participant

    Hi Cici, sorry to bring this up again.
    I have a remote file, it is accessible to anyone with the link. I have set up daily sync to that file. When my client makes changes they don’t reflect in the locations. I let it go over a few day-cycles, and also just set the daily import time to something that is a minute or two ahead of current time to test. I made sure to visit the site a bunch to make sure it was triggering the cron.
    here’s a snapshot of the file, with two new locations: https://www.screencast.com/t/kqLstidTg
    here’s the setting for remote file: https://www.screencast.com/t/1oQhqrPYwlBt
    Here’s the locations list, in reverse order so you can see newest at the top… it stops at #511: https://www.screencast.com/t/to8toS5F
    Let me know your thoughts, or whether you need admin login to check. Thanks

    #55922

    Cici
    Keymaster

    The screenshot needed to better assist you is actually the

    Plugin environment    This shows us versions you are using, PHP ,  MYSQL and  WP, SLP and SLP add-ons.  (Note: some people may be reading this and  I just want to clarify, it is not the same as screenshot of peoples WP Plugin list)  Please see    posting guidelines. and under your INFO page

    If partial files are being imported the most common reason is under powered servers or being on a shared host servers.  The result is servers timing out before the job is finished.  There could be other limitations based on your configuration

    See the authors Post about configuring to improve import.

    If they are updating a location and do not need to geocode it, set the import to skip geocoding

    If you are  on a shared host, you could have hit your google query  geocoding limits.

    To alleviate that issue you could try scheduling the geocoding . There is a function under General settings to schedule timing of geocodoing, that is available with premier subscription.

    Unfortunately, logging into your site would not help , hopefully the info above will help. You can also try to have the csv file broken into smaller chunks, or have geocoding to skip, etc.  if you cannot upgrade server or PHP., etc..

    #55990

    Amanda
    Participant

    HI cici, sorry for the delay. I got pulled away last week on some other projects. here is the plugin environment:

    Store Locator Plus:4.9.7
    Experience:4.9.1
    Power:4.9.2
    Site URL:http://www.hydroassoc.org
    This Info Cached:1513972438
    Network Active:No
    WordPress Version:4.9.2
    PHP Version:5.6.31-4+wpengine10
    MySQL Version:5.6.38
    PHP Limit:512M
    WordPress General Limit:256M
    WordPress Admin Limit:512M
    PHP Peak RAM:122 MB
    PHP Post Max Size:100M

    The whole CSV only has 500 locations, which doesn’t seem huge, most are already geocoded, and I have had it set to skip geocoding for a while already. I told my client to just run the geocoding herself once in a while after it imports. I don’t think the limits are on Google’s side. It is both updating existing locations, and sometimes adding new ones (like 3 or 4 at a time). I’ve looked at that post, and can investigate our PHP/server settings, but with only 500 locations, and changes of only on the order of 3-5 at a time, should that even be an issue?

    I ran an update just fine manually from the same file, and it added the new locations no problem and very quickly. It’s only the daily scheduled ones that don’t seem to work. Thanks.

    #56008

    Cici
    Keymaster

    Thanks for the additional information.

    Note: f you are on a staging/development site you may need to force WP-Cron to run by adding /wp-cron.php to the site address in your browser. Normal production sites should not have any problems with the new import process.

    Also, please see there are new updates to Experience add-on and Power, we are on version 4.9.7  You should update

    A couple of  questions, when you client changes the files, are they saving it as a new  file? If so is that link still public?

    Also are they checking off Duplicate ADD and Not Skip?  When they “change” the list are they adding new locations or just Updating?  what are they changing?

     

     

    #56009

    Amanda
    Participant

    This site is the production site. I will get the updates to Power and Experience done today.

    Changes are made directly to the google sheet, and saved (not renamed or saved new).
    I have had Duplicates set to Update so far all along.
    In some cases, there are a couple new locations along with an update to existing, so the changes can be ‘mixed’.
    Because at one point, I had downloaded the SLP csv and used that as a starting point for our updating one, there are sl_id numbers in the columns. Maybe we need to get rid of those so the auto-updating file has no id’s.

    #56010

    Amanda
    Participant

    OK I ran all the updates, including the WP system:

    Store Locator Plus:4.9.7
    Experience:4.9.7
    Power:4.9.7
    Site URL:http://www.hydroassoc.org
    This Info Cached:1517863687
    Network Active:No
    WordPress Version:4.9.4
    PHP Version:5.6.31-4+wpengine10
    MySQL Version:5.6.38
    PHP Limit:512M
    WordPress General Limit:256M
    WordPress Admin Limit:512M
    PHP Peak RAM:122 MB
    PHP Post Max Size:100M

    #56027

    Cici
    Keymaster

    when you save to google sheet, you mean the CSV file docs correct? So only CSV file should be updating. Plus you might want to clear out the old ones from the media library so that you can isolate any issues. Now I see that WP updated automatically again, so I will have to test and make sure they didnt change anything with WPCRON etc. ugh.

    #56028

    Amanda
    Participant

    yes, per the recommendations, we have a CSV saved as a Google doc, publicly available by link, that’s the one that should do a scheduled update. When I do it manually I just use the upload button, but want my client to be able to just update the CSV in google doc.
    WP ever-changing. I bet it keeps you busy 🙂

    #56033

    Cici
    Keymaster

    If you are still having issues, could you send the public link of the csv file to support e mail and someone (probably me) can test it or can take a look at the data fields.

    The thing about the sl_id….you have to make certain that the sl_id matches what is really in the location panel.

    But if I can see the link in the meantime I will try to test sometime this week

    #56220

    Amanda
    Participant

    Hi Cici, been swamped with other work. I removed all the sl_id column values, and will see whether that affects our ability to auto-update. Meanwhile I will email the current spreadsheet, it’s all up to date with locations.

    #56226

    Cici
    Keymaster

    Hi Amanada, if the email was from “Mick” I answered today. Delete sl_id column and there are some other inconsistencies in the file. Also make sure you have now updated to latest versions of Power and SLP etc.

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.