Store Locator Plus for WordPress Forums Store Locator Plus Power fields missing labels after update

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #82860
    Amanda
    Participant

    Hi, we ran all the updates on the Power, Experience, and SLP plugins but now the Power add-on extended data fields don’t show any labels in the back end, making it very hard to edit locations. Here is an example looking at editing a single location: https://www.screencast.com/t/wyAnvKh3w.
    <div class=”inside”>
    <div id=”” class=”input-group wpcsl-details” data-related_to=””>
    <div class=”input input-field”>
    <div class=”left_side”>
    <div class=”content_pad”>
    <p class=”envinfo”><span class=”label”>Store Locator Plus®:</span>5.14.1</p>
    <p class=”envinfo”><span class=”label”>Experience:</span>5.14</p>
    <p class=”envinfo”><span class=”label”>Power:</span>5.13</p>
    <p class=”envinfo”><span class=”label”>Site URL:</span>https://www.hydroassoc.org</p&gt;
    <p class=”envinfo”><span class=”label”>This Info Cached:</span>1661372975</p>
    <p class=”envinfo”><span class=”label”>Network Active:</span>No</p>
    <p class=”envinfo”><span class=”label”>WordPress Version:</span>6.0.1</p>
    <p class=”envinfo”><span class=”label”>PHP Version:</span>7.4.28</p>
    <p class=”envinfo”><span class=”label”>MySQL Version:</span>5.7.38</p>
    <p class=”envinfo”><span class=”label”>PHP Limit:</span>512M</p>
    <p class=”envinfo”><span class=”label”>WordPress General Limit:</span>40M</p>
    <p class=”envinfo”><span class=”label”>WordPress Admin Limit:</span>512M</p>
    <p class=”envinfo”><span class=”label”>PHP Peak RAM:</span>52 MB</p>
    <p class=”envinfo”><span class=”label”>PHP Post Max Size:</span>100M</p>

    </div>
    </div>
    </div>
    </div>
    </div>
     

    #82863
    Cici
    Keymaster

    Hello Amanada,

    I do not understand the screenshot you are showing me. What Power extended fields are you referring to?

    Could you tell me which browser you are using when you  load or edit locations?  I see that when I use Safari there seems to be an issue the way the back end appears as I opposed to Chrome. If this is the case for you I need to notify the developers since the previous releases were tested for that and fixed, but if it is a recurring bug they will have to delve into further

     

    #82864
    Cici
    Keymaster

    I think this is a formatting issue as mentioned above and I am identifying it to the developer to fix this ASAP with our next release. Thank you for bringing to our attention…but if you could try Chrome and confirm I would really appreciate it

    #82865
    Cici
    Keymaster

    Amanda , I am texting the Pre release for SLP and Power and it appears that the formatting bug has  been addressed in the next release which we are expecting to have out this weekend, fingers crossed. !

    #82867
    Amanda
    Participant

    Cici (it’s Mick again, I sign in as Amanda to make these posts)

    Sounds like you guys got on it right away.

    In case you still need to know what I meant, Basically with the Power add-on, you can use ‘extended data fields’ it adds more fields to each location. In the Inspector portion of my screenshot you can see the Id’s and input names that mention what those fields are, like for example “facility_type”. There are a number of these that Power adds on. But in the backend as you noticed, they have no labels to identoifu them so it;s hard to edit those data for the location.

     

    Thank you!

    Mick

    #82868
    Amanda
    Participant

    It was the same thing in Chrome too.

     

    Thanks

    #82869
    Cici
    Keymaster

    Mick,

    Thank you for the thorough explanation.  I hate to say it but I totally forgot about those fields.   I am wondering if the latest WordPress update caused the issue since I am comparing  the previous versions of the PLUG In as well as our new releases. The developer found a lot of issues with the Last WP update that effected layouts. I am going to sk him if we can roll back on of our test sites to earlier WP versions

     

    I will keep you  posted

     

    #82870
    Cici
    Keymaster

    Mick,

    Thank you for the thorough explanation.  I hate to say it but I totally forgot about those fields.   I am wondering if the latest WordPress update caused the issue since I am comparing  the previous versions of the PLUG In as well as our new releases. The developer found a lot of issues with the Last WP update that effected layouts. I am going to sk him if we can roll back on of our test sites to earlier WP versions

     

    I will keep you  posted

     

    #82872
    Cici
    Keymaster

    Yes, I am testing the Power pre release beta now that should fix those labels as well as a couple of other issues.

    the delete and having it re appear sounds vaguely familiar with an older version that since was fixed, I thought…I will have to check the bugs report in our new reporting system to refresh my memory.  Is that customer also using the latest versions?

    If you have a test site and or a Premier account you can download the Power pre release , it also has fixes and new reporting interface.   If you do not have Premier but want to help us test it I can send you a Pre release version for use only on a backed up test site . If you are interested send an email to support.

     

    #82873
    Cici
    Keymaster

    @amanda

    I checked both SLP Version 5.13.8 and SLP version 15.14 and the delete functionality is working.  There  was an issue in a prior release where that was fixed.

     

    Is your client using the trash baskets on individual  one at a time, or using the Bulk actions /delete permanently method?

    I tested both and they are fine. I refreshed and the ones I deleted are gone.   So if you could check if they are using an old version that would be great …You can see the changelings and SVN repository in the SLP WordPress directory 

    #82882
    Cici
    Keymaster

    @ Mick AKA Amanda…

    I sent you the pre release zip files but they are not making it through your email firewall

     

    #82886
    Amanda
    Participant

    Hi Cici

    I got the Beta plugins, installed them on a staging site, and the labels on the Power fields look great. I still am waiting to hear which records I can test the delete function on, but for now I installed them on our live site!

    #82887
    Cici
    Keymaster

    Hi Mic

    Yes the developer published the releases last night.  For Both the SLP Base plugin and the Power plugin.

    It should be ok to download updates from your Plugin admin panel now.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.