PHP 7 warning on Store Locator Plus

Home Forums Store Locator Plus PHP 7 warning on Store Locator Plus

Tagged: ,

This topic contains 1 reply, has 2 voices, and was last updated by  Cici 2 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #54571

    Johanna
    Participant

    Hi, we’re using a PHP 7 compatibility checker and Store Locator Plus is giving a warning. Do you know if this is a false positive? Or will this be fixed soon?

    Is your plugin compatible with PHP 7?

    Here is the warning:

    FILE: .../wp-content/plugins/store-locator-le/include/SLPlus.php
    -------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -------------------------------------------------------------------------------------------------
     506 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
    -------------------------------------------------------------------------------------------------
    #54573

    Cici
    Keymaster

    SLP uses PHP 7 and is tested with PHP 7. In fact most of our customers who are also developers use the php 7 version.

    My personal test site,( under INFO/ Plugin environment) shows PHP Version:7.0.22-0ubuntu0.16.04.1

    MySQL Version:5.6.29

    I do not see any warnings.

     

    Do you have a question specific to SLP? if so could you please provide the information regarding versions, your site url etc.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.