Store Locator Plus for WordPress Forums Store Locator Plus No locations found… Searches not working with Power add on

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #46043
    Krista Ducey
    Participant

    Hi I just purchased and added the power add on. I have 21 store locations – I activated the power add on and now it does not find any results when I search by zip/postal code or city.  No locations found…

    Please help me figure out why it won’t work. I want to import about 100 more locations. Thanks.

     

    Store Locator Plus:4.7.9
    Power:4.7.9
    Site URL:http://2017.amantii.com
    This Info Cached:1495228375
    Network Active:No
    WordPress Version:4.7.5
    PHP Version:5.6.30
    MySQL Version:5.5.55
    PHP Limit:2000M
    WordPress General Limit:40M
    WordPress Admin Limit:2000M
    PHP Peak RAM:98 MB
    PHP Post Max Size:67108864

    <p class=”envinfo”></p>

    </div>
    </div>
    </div>
    </div>
    </div>
     

    #46080
    Cici
    Keymaster

    Are you searching by categories? If so please update Power add-on to 4.7.10 there was a bug fix  in Power 4.7.10

    #46091
    Krista Ducey
    Participant

    I updated to Power 4.7.10 – I search by “any” category and still no results found. I search by a category and still no results found… 🙁  Please help…

    #46095
    Cici
    Keymaster

    Is this a new domain, as in it didn’t exist before June 2016?   Since it is being called 2017 amanti I assume you are revamping or creating a new one. In any event you will need the Google MAP API, see the getting started guide

    You are receiving a warning that you do not have the Google MAP APi and you  need one.  That has nothing to do with categories. No search even without categories will work on any WP locator plugin without it unless you were grandfathered in by Google pre 2016

     

    #46136
    Cici
    Keymaster

    Power is now 4.7.11,.have you tried changing  your radius? What are your settings under the Categories admin panel, I did not see a list of categories, did you remove the Power add-on or deactivate it recently from this site . I went to your site and cannot see anywhere to enter a categories dropdown.

     

    #46141
    Krista Ducey
    Participant

    OK I had to deactivate the Power plug in 4.7.10 – I was getting an error message. I have upgraded to 4.7.11 now. I have two categories set for now. I still get no results found. I put in a zip code of a location and search by category for its category and I get – No Locations Found… I do not know what information you need now. http://2017.amantii.com/dealer-locator/

    I have the Google MAP API set up in under the General / Server tab in the Google Developers Console panel.

    Please help.

    #46144
    Cici
    Keymaster

    What are you referring to exactly when you say no categories no results, those are two different topics

    Unless you have the Category manager set to show the categories in either a drop down menu or cascading it will not give you a choice to search by category.

    In the documentation read   Search using Category

    Turn on a simple drop down menu or cascading parent category menu with automatically displayed/hidden child menus for users to filter location results by assigned categories.

    Or you can use a shortcode to show categories only in your results on your WP page or Post, see documentation if you want to change results settings

    Also make sure your radius is set high enough on initial search under Settings/Search. How search works documentation

    What Settings do you have for  Results after start up?

    Have you set the categories to search with a drop down, cascading or other?

    What style are you using do you want or have a legend?  Do you have the category set to have an icon? If you are saying that you have No results found at all when searching in the correct zip code I need to know more, all I see is your test or dev site which doesn’t tell me much.

    https://docs.storelocatorplus.com/blog/layout-shortcode-cheat-sheet/

    Did you move Tables and categories from another site, see documentation about how the taxonomy and WP database  works here

     

    #46145
    Cici
    Keymaster

     

    Are you restricting using a referrer id from  the Google MAP API,?  When I look at your link it is definitely doing something weird and thus is not from the SLP plugin. Google MAP API will NOT work if you have that situation, (It is a known failure from Google Developer console)

    https://maps.googleapis.com/maps/api/js/GeocodeService.Search?4s35002&7sus&9sen&key=AIzaSyB3oiG8JgpS1uuKOy02-Xg1KCRksy0w3gE&callback=_xdc_._adnry6&token=94645

     

    If it isn’t that then you will need to follow debugging or other hints that are in  the Troubleshooting guide to see if your theme or another plugin is causing a hiccup which will cause  Locator to not work.

    #46146
    Krista Ducey
    Participant

    I am finding no locations found when search with correct zip code. 100 mile radius. I have drop down menu for categories. What other info do you need to know? Please let me know and I will send to you…

    Settings for Results after start:
    <h4 class=”settings-header ui-accordion-header”>At Startup</h4>

    Show Locations

    </div>

    Initial Search Radius

    </div>

    Number To Show Initially

    </div>
    </div>
    </div>
     
    <h4 class=”settings-header ui-accordion-header”>After Search</h4>

    Number To Show

    </div>
    </div>
    </div>
     
    <h4 class=”settings-header ui-accordion-header”>Appearance</h4>

    No Results Message

    </div>

    Show Tags In Output

    </div>
    </div>
    </div>

     
    <h4 class=”settings-header ui-accordion-header”>Labels</h4>
     

    Instructions

    </div>
     

    Website URL

    </div>
     

    Directions

    </div>
     
    Hours

    ——————————–
    I exported locations from another site using Power Add on  and imported into this site. I added categories in this site.  The searches do work when power add on is disabled.
    http://2017.amantii.com/dealer-locator/

    I am not restricting anything from Google MAP API as far as I know…
    What is the link above you gave me? https://maps.googleapis.com&#8230;. It wants to save a file to my computer.
     

    Please help… 🙂

    #46147
    Krista Ducey
    Participant

    I changed the theme to a default theme and still no locations found… 🙁

    #46158
    Cici
    Keymaster

    You Exported from an old site and imported to a new site?  Did you read the Documentation  explaining how to do that and about  the sl_id etc (which you would not use on a new site because the id will not be the same.)

    https://docs.storelocatorplus.com/blog/q-we-are-developing-a-new-website-and-want-to-move-the-content-can-i-add-the-plug-in-data-we-already-have-into-the-new-website/

    The link for the Maps API is to the Google Developer console and how to get the API. You need to put the key in the right box on SLP under General/Server/Google Developers Console/   Google Browser key (NOT   Google Business license.)

    Are you trying to find locations closest to the person (location sensor enabled) or do you have a specific search map area in mind (requires Experience add-on) where you would use the short code something like this.

    [SLPLUS center_map_at=”Brisbane,Australia”]

    If you still cant get what you need, after setting either your center map either under the settings /Map or on the Dealer page itself , then you need to use the debug log and use Troubleshooting to find out if another Plugin or your theme is preventing SLP from working correctly  because I cannot recreate your issue.

    if you need pro help from the developer to log into your site or another team support person to look into your specific situation there is an option to purchase the help at the level you need via the Paid support button

     

    This isn’t a simple setting issue and you have something else going on that I cannot assess here.

     

     

    #46168
    Krista Ducey
    Participant

    Hi Cici

    Yes I exported the info after reading the documentation.

    I placed the API correctly in SLP under General/Server/Google Developers Console/   Google Browser key (NOT   Google Business license.)

    I feel like you are not understanding the problem:

    “Are you trying to find locations closest to the person (location sensor enabled) or do you have a specific search map area in mind (requires Experience add-on) where you would use the short code something like this.”

    Right now I am just trying to find a location via it’s zip code. I enter a zip code of a known location and I get “no location found” – I have entered the location so it should be found.

    SLP works and finds the locations fine when I disable the Power Add on.

    I just spent $240 for this add on and it is not working and you are not understanding my problem that no locations are found when using the Power add on.

    I have checked all the settings. Please tell me what settings I should have active in order to have this add on work.

    Thanks.

    #46188
    Cici
    Keymaster

    We cannot help you without you providing the  debug log. Instructions are Under Troubleshooting

    #46196
    Krista Ducey
    Participant

    Where do I find the Troubleshooting?

    I had to launch the site today with out the Power add on activated.

     

    #46231
    Cici
    Keymaster

     Troubleshooting is in our documentation.

    https://docs.storelocatorplus.com/blog/search-and-results-not-loading/

     

    Is this your current site or the old one because you are still getting the invalid Google API key warning,

     

    inspect your page with any browser by right clicking and using Inspect

    Check to make sure ANY and all  of your plugins or YOUR theme (Avada)  are current including WooCommerce and using jquery 1.12 or higher

     

    http://amantii.com/dealer-locator/

     

     

     

     

    #46245
    Cici
    Keymaster

    Krista, Looking back at your previous topics. You are a web designer/developer and are using the add ons  but have not purchased the SLP  multi site license as a Premier subscriber.   You also have errors on your site that are not from  SLP.   Nonetheless , you can write to support about a refund, (they will have to clear it through the developer who may have additional questions for you)

     

     

    #46308
    Cici
    Keymaster

    This issue has been resolved from SLP standpoint . Apparently it was from your database naming  convention and errors arose when someone or another programmer was moving /transferring to new site. The developer has been working with you one on one on tis issue. This topic will be closed

     

Viewing 17 posts - 1 through 17 (of 17 total)
  • The topic ‘No locations found… Searches not working with Power add on’ is closed to new replies.