Store Locator Plus for WordPress Forums Premier Support Maps in Dev mode – Can’t load Google Maps correctly

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #82542
    SynergEyes
    Participant

    My maps are now (finally) returning location results and moving the map image to the correct location. But the map still has the Development watermark and a warning pop-up that Google Maps can’t be loaded correctly. I’ve got to be missing some setting in the Google cloud console, but I can’t figure out what it would be. Any help would be appreciated. Thanks.

    https://synergeyes.com/

    https://synergeyes.com/find-a-doctor/

    Attachments:
    You must be logged in to view attached files.
    #82547
    Cici
    Keymaster

    Follow the link in the pop up box , that is generated by Google.  It asks if you own this website your answer is yes. Google will then tell you the issue .

    If you also Inspect your site you will see a lot of errors and a warning.

    The warning shows”. Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys”

    If you did not enable billing with Google you will need to set that up now.

    From Google.

    Under certain circumstances, a darkened map, or ‘negative’ Street View image, watermarked with the text “for development purposes only”, may be displayed. This behavior typically indicates issues with either an API key or billing. In order to use Google Maps Platform products, billing must be enabled on your account, and all requests must include a valid API key. For help on finding error messages, see the section on checking errors in your browser.

    The following flow will help you troubleshoot the issue.

    #82548
    Cici
    Keymaster

    See some of the errors on that site url attached

     

    • This reply was modified 5 months, 3 weeks ago by Cici.
    Attachments:
    You must be logged in to view attached files.
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.