Looks like you turned off SLP Maps under General Settings but need them here

Home Forums Store Locator Plus Looks like you turned off SLP Maps under General Settings but need them here

This topic contains 6 replies, has 3 voices, and was last updated by  Cici 6 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #44936

    Richard
    Participant

    I am getting this message on my web page that displays Store Locator Plus: “Looks like you turned off SLP Maps under General Settings but need them here.” However, the box under general settings for this is not checked. All plugins, themes, and WP are up to date. I have attached my a screenshot for environment settings. Here is the link to the page: http://jhcc.biz/search-by-zip-code/

     

    Attachments:
    You must be logged in to view attached files.
    #44958

    Cici
    Keymaster

    Have you  EVER had a legacy Enhanced * add on or CSS before? Other than SLP base plugin? Install Janitor and see if Enhanced Map / Search / Results show up on any of the settings page.

    #44961

    Richard
    Participant

    I don’t quite understand what you are saying. I don’t know what legacy enhanced is. However, I did install Janitor as you said, but nothing changed. Any more advice?

    #44968

    Cici
    Keymaster

    Is this a clean ,new install or copied over from another database?  Do you have a Google API key?

    This is not a widely known issue, I have not been able to reproduce it.

    Someone has either turned that on before , added Javascript, used Forceload Javascript or has CSS overriding

     

    You need to Debug , if you need the developer here to troubleshoot you would need to go through Paid support option

    Here are some notes to get you  started and you should read Troubleshooting guide on how to do more

    What is shown when you use the Browser tools and inspect. You have CSS rules that are overriding. try clearing cache with Janitor or inspect your CSS rules. Enfold: Script  I do not know why it is showing _lpchecked=1…but it is written into your theme

    #searchForm

    <form id=”searchForm” class=”slp_search_form” action=”” onsubmit=”cslmap.searchLocations(); return false;” _lpchecked=”1″><div class=”slp_search_container”><div id=”address_search” class=”slp search_box”>                        <div id=”addy_in_address” class=”search_item”><label for=”addressInput” class=”text length_13″>Address / Zip</label><input class=”label_text length_13″ type=”text” id=”addressInput” name=”addressInput” size=”50″ value=””></div>                                                                <div class=”search_item”>            <div id=”addy_in_radius”><label for=”radiusSelect” class=”text length_6″>Within</label><select id=”radiusSelect”><option value=”10″>10 miles</option><option value=”25″>25 miles</option><option value=”50″ selected=”selected”>50 miles</option><option value=”100″>100 miles</option></select></div>            <div id=”radius_in_submit”><input type=”submit” class=”slp_ui_button” value=”Find Locations” id=”addressSubmit”></div>        </div>                    </div></div></form>

    #44982

    Lance Cleveland
    Keymaster

    If the Turn Off SLP Maps is not checked then something else in your WordPress themes or plugins is forcing the Google Maps API to be removed from the WordPress script list.

    I’ve checked your site URL and it is definitely NOT loading Google Maps JavaScript and our plugin will NOT render that locator interface and skip the “load Google Maps JavaScript” step unless that box is checked.  That means something else took the instruction to load the JavaScript out of the list or decided they own the ‘google_maps’ handle for scripts in WordPress.    I’d look at any Google-centric plugins first.

    Try disabling plugins one-at-a-time and see if the map loads.

    https://docs.storelocatorplus.com/blog/user-interface-settings/

     

     

    #44983

    Richard
    Participant

    I found that the Leaflets Map Marker plugin is what is causing the problem. The two plugins have been working together just fine for the past year or so. I guess a recent update may have caused the problem. I really need both plugins to work. Any ideas of how to accomplish this?

    #45001

    Cici
    Keymaster

    If you have a Google Map API only one can access that at a time.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.