Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #82005
    Juergen
    Participant

    Hi

    Please help me debugging this. I dont get any results when entering some well known cities in Germany, for example “Berlin” or “Nürnberg” or “Erlangen”. SLP is implemented right at the landing page if you wanna try yourself.

    No idea, if I have misconfigured something, I went through the settings several times and dont see any issues. Backend info and error message below.

    Thanks, BR
    Jay

    Error message
    “Could not locate this address. Please try a different location.
    Google Maps API error:
    Tired of fighting the Google Maps API? Try our SaaS offering.””

     

    Info
    Store Locator Plus®:5.5.15
    Experience:5.5.5
    Power:5.5.8

    Site URL:https://www.genol-tankkarte.at
    This Info Cached:1627476680
    Network Active:No

    WordPress Version:5.7.2
    PHP Version:7.3.29
    MySQL Version:5.7.35

    PHP Limit:384M
    WordPress General Limit:40M
    WordPress Admin Limit:384M
    PHP Peak RAM:8 MB
    PHP Post Max Size:100M

    #82008
    Cici
    Keymaster

    Your plugins and add-ons are out of date , you have special div class called “the search” .slp-versions

    Update plugin and add-on for starters, then search using the WP debugger to see if you have outdated or conflicts in your site.

     

    We have no insight into your back end. If you were using the SLP SaaS it would be updated on a regular basis and we could tell what the issue is.

     

    #82013
    Cici
    Keymaster

    Do you have a SLP short code or did you  append Austria to your search?     Using Chrome browser dev tools and typing in search this is what I see for Berlin/{“results”:[],”status”:”ZERO_RESULTS”}

    It is automatically adding Austria to the search even if I type in Berlin Germany

    https://www.genol-tankkarte.at/wp-json/store-locator-plus/v2/geocode/fb33f73d74f687778dfd9151f00d5b9e/at/berlin%20Austria

    #82014
    Cici
    Keymaster

    Do you have a SLP short code or did you  append Austria to your search?     Using Chrome browser dev tools and typing in search this is what I see :

    It is automatically adding the country Austria to the search even if I type in Berlin , Germany

    https://www.genol-tankkarte.at/wp-json/store-locator-plus/v2/geocode/fb33f73d74f687778dfd9151f00d5b9e/at/berlin%20Austria

    Berlin/{“results”:[],”status”:”ZERO_RESULTS”}

    Ditto if I search and inspect other cities  below and this is the issue .

    “code”:”rest_forbidden”,”message”:”Du bist leider nicht berechtigt, diese Aktion durchzuf\u00fchren.”,”data”:{“status”:401}},  

     

    With Store Locator Plus 5 all address lookups are routed back through the WordPress site via the REST API in order to protect Google API keys.

    A while ago SLP was updated, See REST API  blog

    there is a configuration problem on your site

    • This reply was modified 1 month, 1 week ago by Cici.
    #82016
    Cici
    Keymaster

    Also check the radius behavior.

    And recheck the settings under results so that it doesn’t  automatically resolve back to 500 km, (is berlin more than 500 KM from the center search settings. )

     

    And again, as mentioned are you appending Austria in your settings. The search results and Google seems to think so

     

    #82021
    Juergen
    Participant

    Hi Cici

    Thanks for your feedback. We gonna have a look at it this week.

    BR, Jay

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.