Store Locator Plus for WordPress Forums Store Locator Plus Issue with initial zoom level

Tagged: 

This topic contains 23 replies, has 2 voices, and was last updated by  Cici 2 months, 1 week ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #57092

    Paul
    Participant

    My map is not loading with the correct initial zoom.  The initial zoom level of my map is set to 4 and “immediately show locations” is not selected.

    Plugin environment attached for your reference.

    Thanks in advance for your assistance.

    Attachments:
    You must be logged in to view attached files.
    #57103

    Cici
    Keymaster

    Hi Paul,

    The words “immediately show locations is no longer the lingo in current SLP version. there is a check box to show locations or not.
    But that would not effect your map.

    I have reported the zoom issue to the developer.

    #57104

    Cici
    Keymaster

    hi Paul

    Using Janitor, I see my zoom is saved when I changed it and I do not have auto zoom (EXP add-on) activated and the setting did not seem to be reflected on my page. I am waiting to see if it is a cache issue or something else. When the developer has a chance he can take a look at it.

    Did you change the zoom level recently? Or was it always set at 4?

    #57106

    Paul
    Participant

    Thanks for looking into this, Cici. The zoom level was always set at 4. I attempted to change the zoom but those settings were not reflected on my page either.

    #57116

    Cici
    Keymaster

    Ok, Lance did find some javascript issue with WP version 4.9.8 and EXp. His note said if the email style is set to something OTHER THAN popup email form some javascript introduces weird results.

    He is fixing bug with next release. I do not know if it will fix zoom as well, I did report the issue.

    #57117

    Paul
    Participant

    OK, thanks. I wanted to mention that while zoom settings are not reflected in the live version of my page, zoom does appear to behave as expected when viewing my page as administrator.

    #57130

    Cici
    Keymaster

    OY! Now I am wondering if it is something that Google has changed with their MAp API…I would not doubt it!!! Will try to remember to keep this on the burner, the developer is travelling this week. Please let us know if anything changes

    #57262

    Paul
    Participant

    Hi, Cici. Just writing to see if there are any updates regarding this issue. Thanks

    #57277

    Cici
    Keymaster

    Looking at your site url, the issue does not appear to be with the zoom, Do you have a center map at setting? It is correctly showing the middle of the United States if you have not specified an area., if you want to show the whole US set the
    It seems that this is the first thing that is happening with your site locator before a search . it shows a blank map but your cache swift_performance is the primary determination of where it starts.

    If that plugin is cacheing all your settings you should clear the cache to see if that helps

    another plugin or your theme seemed to be overriding the slp power settings. Either way, when a search was performed it appeared to behaving correctly, but I cannot see any of your settings to determine how you wanted it to behave differently or if you are only having issue with the initial map that is being shown

    https://docs.storelocatorplus.com/blog/map-panel-settings/

    #57318

    Paul
    Participant

    Thanks for your reply. I am only having issues with the initial map being shown. I would like to see a map centered in the middle of the U.S. with an initial zoom level of 4.

    The map loads as desired (with z=4) when I’m logged in as administrator. However, when I view the public or live version of the page (directly after clearing cache) the initial zoom level loads at 14 instead of 4.

    The following screenshots are attached for your review:

    1. SLP Settings
    2. Administrator View
    3. Live View

    • This reply was modified 2 months, 3 weeks ago by  Paul.
    Attachments:
    You must be logged in to view attached files.
    #57330

    Cici
    Keymaster

    I have looked at your site and am trying to determine if your  theme oceanwp is overriding the zoom setting or if  the location sensor detection that is now auto shut off by SLP if you do not have https  could effect how the map is displayed.  or if it is because you do not have the Experience add-on and changes were made  via the Google interface on how the zoom performs.  I will have to look back at the changelogs with the developer.

    You do not have the “Do NOT autozoom” function nor the disable initial directory since you do not have the experience add-on .  There are settings in that add-on that  effects the way the map displays ,

    I did have that EXP add-on activated  so to roll it back and to change settings to get the same results  as you is making it difficult to recreate your issues but I do see it on your site.

    I Apologize I do not have a solution for you at the moment.  I have raised the query to the developer to see if he can shed any light on it.

     

    #57366

    Paul
    Participant

    After disabling Power (Version 4.9.17) the map loads with the desired initial zoom of 4. This isn’t an ideal solution but thought it might help you narrow down the problem. Thanks

    #57373

    Cici
    Keymaster

    Got it, I have it on the developers radar. It will help him narrow down what may have changed. The zoom level isnt normally associated with Power, it is a function of the base SLP so that is good info. Thank you

    #57374

    Cici
    Keymaster

    I tested it on my test site and I concur. I have contacted the developer to tell him about the issue. I am wondering if it has anything to do with the way the location sensor is coded now to accomodate the people who do not have https (secure) sites. I do know he wrote some script to accommodate for those users. Hopefully there will be less and less sites that are http instead of https.

    Thanks again for all your help

    #57375

    Cici
    Keymaster

    Paul,
    The developer has Power in beta version. If you have a test site to try it on I can send you the zip file, or you can wait until it is published.

    I tested it and it seems to fix the zoom issue.

    #57378

    Paul
    Participant

    Thanks, Cici. I’ll wait for the update to be published.

    #57380

    Paul
    Participant

    While deactivating Power resulted in initial zoom behaving correctly in Safari, it doesn’t seem to resolve the issue in Chrome or Firefox. Sorry, just noticing this now. Which browsers did you use for your test?

    #57384

    Paul
    Participant

    Please disregard my previous post (August 30, 2018 at 5:17 PM). Must have been a caching issue. I’ll wait for the Power update to be published. Thanks for your help!

    #57385

    Cici
    Keymaster

    Oh good, I was going to say the developer primarily works in Safarai, and I primarily test my settings with Chrome or Firefox and sometimes IE. The developer has a test suite that he can test against all browsers using browser stack when there is a major update. This was not a major update . he has a new version of SLP coming out as well. he said it didn’t have any effect on the Power zoom. Check the versions auto updates later , I have asked him when he will publish, the version will be .19 I think he will publish later today if no other issues are found during my testing

    #57397

    Cici
    Keymaster

    Paul, SLP and Power updates with patches have been published and available for download.

    Gave you a shout out in our news announcement

    https://www.storelocatorplus.com/store-locator-plus-updates-and-patches/

    #57405

    Paul
    Participant

    Updates installed and working as expected. Thanks again for the support and thanks for the shout out! Have a great weekend.

    #57411

    Cici
    Keymaster

    Awesome. You do notn use Location sensor do you? We have a different issue when using Location sensor that I am trying to get to the bottom of. It may very well have to do with Chrome announcement to deprecate SSL certs as of M70. Fisrt release of Chrome M70 was scheduled to be Aug 30 2018 with stable release in Oct. Which means everyone will be scrambling again to update the SSL certs.

    #57412

    Paul
    Participant

    No, I haven’t enabled the location sensor feature as of yet.

    #57415

    Cici
    Keymaster

    Ok, Well there was a bug that effected that and also similar to zoom but it was a Callback time out error that would initially display correctly but then reset to the center map at after x seconds so there will be another update of Power. I am testing that next.

Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.