Store Locator Plus for WordPress Forums Store Locator Plus Help exporting all store locations

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #81758
    Donna C
    Participant

    We have 97 stores within Store Locator Plus. On the backend of Store Locator Plus, the stores take two pages (see attachment, twopages) to scroll through.

    Here are the steps we take to try to export and download all locations (see attachemnt, steps). We do the same for page 2 of our stores, meaning we’ll have two CSV downloads.

    Doing this, Store Locator Plus does NOT download and export all locations. Some locations are being downloaded and exported twice.

    Can someone please tell us what we are doing wrong? Or is this a known bug within Store Locator Plus?

    Thanks in advance very much for your time and help.

     

     

    Attachments:
    You must be logged in to view attached files.
    #81761
    Donna C
    Participant

    Also, if needed to help, here is a screenshot of the versions we are running on with Store Locator Plus and Store Locator Plus – Power.

    Attachments:
    You must be logged in to view attached files.
    #81763
    Donna C
    Participant

    Quick update; on the backend within Store Locator Plus screen options, we put 100 within the “Locations Per Page” box. See the screenshot attachment, screenoptions. All locations loaded to one page.

    Then selected all, and “Export, Download CSV”, and clicked Apply. See attachment, selectedall

    Doing this, when opening the CVS download within a Google Sheet, only 72 locations were exported and downloaded. See attachments cvs1 and cvs2.

     

    Attachments:
    You must be logged in to view attached files.
    #81768
    Cici
    Keymaster

    The screen options for displaying number of locations does not matter when it comes to exporting.  A larger number to display is not advisable if your server cannot handle it

    The screenshots you provided are not showing the headers so I cannot see what you are trying to show me but I can glance and see that you must have some perhaps marked private or that were deleted Such as sl_id 307, etc… I also cannot tell if that is an ID you have added or if the header row indicates that is the sl_id. As noted they are assigned first in so may not match the exact numbering scheme on a screenshot.

    Are you using any of the “Bulk Filters”? If you are using specific filters that could explain some differences.

    For troubleshooting exports

    See docs here.Export to csv file

    https://docs.storelocatorplus.com/troubleshooting-large-scale-exports/

    #81769
    Donna C
    Participant

    Also, the locations missing on the export and download, DO show up when you search within Store Locator Plus on the backend…

    #81770
    Cici
    Keymaster

    P.S. You do not need to click on any buttons such as Apply to all etc unless you are using filters.  Just  export to a csv file.  You are showing me an excel file not a csv file so to is difficult to ascertain your issue. The issue could be in the conversion of your csv file into excel and not the csv file itself.

    Try importing/converting the csv file  into Google sheets instead of Microsoft. Microsoft excel can be quirky.  More info about sl_id https://docs.storelocatorplus.com/csv-import-duplicates-handling/

    #81775
    Donna C
    Participant

    See if this screenshot helps to see what you need. In the top right, it shows our 97 locations. But on the main screen, it shows 72 locations, and that is all that’s exporting

    • This reply was modified 1 month, 1 week ago by Donna C.
    Attachments:
    You must be logged in to view attached files.
    #81778
    Donna C
    Participant

    You asked if we were using the bulk and specific filters… To be 100% honest, I do not know if any are being used or not. Where do you go to set up and view if certain filters are being used?

    These were imported into Google sheets, and not Microsoft.

    Your time and help is greatly appreciated!

    #81779
    Cici
    Keymaster

    The  filters are under the show all drop down and allows you to filter by property.   See screenshot . I haven’t used it for quite a while just make sure you have cleared the cache if you think those were ever used before.

    I think there could be something quirky going on with the latest WP updates . Others have mentioned issues that only appeared when they last updated WP to 5.7 or 5.7.1 and the back end admin area was wonky.   I am still using WP 5.6  so  that may be why I can’t replicate the issue on my test site

    I did test using a MYSLP SaaS customer with 497 locations. I did not change the screen settings so only 50 locations per page .  I exported to a csv file.  I then uploaded it into Google sheets. All 497 locations loaded/imported into the sheet.

    But I am using WP version 5.3 on that site.

    So short answer is. I have no idea what is going on with your site. If its the version of WP or limitations on your server or host or browser.

     

    So if you change screen options to a higher number  (try 125) you may need to also expand your browser window to get the full pagination.  I am sorry I cannot provide more succinct instructions I just can’t replicate the issue

     

    Attachments:
    You must be logged in to view attached files.
    #81773
    Donna C
    Participant

    First and foremost, thank you for your time and help 🙂

    <span style=”color: #5a5b5c; font-family: ‘Open Sans’, ‘Helvetica Neue’, Helvetica, Arial, sans-serif; font-size: 12px;”>”The screenshots you provided are not showing the headers so I cannot see what you are trying to show me but I can glance and see that you must have some perhaps marked private or that were deleted Such as sl_id 307, etc… I also cannot tell if that is an ID you have added or if the header row indicates that is the sl_id. As noted they are assigned first in so may not match the exact numbering scheme on a screenshot.”</span>

    See if this screenshot, psscreenshot, helps to see what you need. In the top right, it shows our total number of locations of 97. In the main screen, it displays only 72 locations, and that’s all that’s exporting.

    <span style=”color: #5a5b5c; font-family: ‘Open Sans’, ‘Helvetica Neue’, Helvetica, Arial, sans-serif; font-size: 12px;”>”See docs here.</span>Export to csv file

    Dead link

    <span style=”color: #5a5b5c; font-family: ‘Open Sans’, ‘Helvetica Neue’, Helvetica, Arial, sans-serif; font-size: 12px;”>”Are you using any of the “Bulk Filters”? If you are using specific filters that could explain some differences.”</span>

    Do be 100% honest, I do not know. Where do you go to see and setup bulk and specific filters?

     

    Attachments:
    You must be logged in to view attached files.
    #81785
    Cici
    Keymaster

     

    Hello

    Bulk Filters are under Show All

    About the Web server  configut=ration timing out etc.

    https://docs.storelocatorplus.com/troubleshooting-large-scale-exports/

    As mentioned I cannot replicate your situation at all. Not sure if you need to contact your server host or use the debugger to see if there are issues perhaps with the last update.  My first thought is actually it has to do with your server or connection timing out.  Suggest you  try to select the first 50 to export and then the next 50. I cannot troubleshoot for you on your site.

     

    #81786
    Cici
    Keymaster

    P.S. The info we normally need to answer your questions are Plug-in environment. That also shows your version of WordPress PHP versions etc.  No one has mentioned issues with exporting for quite a while .

    You provided us with only a screenshot of our two plug-ins.

     

    P.S. Not sure which dead link but I included two above about Exports and the PHP and web server and connections.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.