Store Locator Plus for WordPress Forums Store Locator Plus Google Map doesn’t work

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #79104
    Roland
    Participant

    Since yesterday the Google Map shows the message “For development purposes only”. How can I manage this to show the map again?

    Best,
    Jürgen

    #79105
    Cici
    Keymaster

    Do you have a Google API key? Do you have a billing account with a credit card attached to it?

    Did you r Migrate your site and perhaps need to revist the Google API   set up ?

    I cannot provide specific information without the info requested in posting guidelines.

     

    1) Need Screen shot of your SLP INFO/PLUGIN ENVIRONMENT that shows SLP versions,PHP, MYSQL and WP version

    2} your site url that is  showing the error.

    #79109
    Roland
    Participant

    Hey Cici,

    I already thought that the problem is the missing Google API Key but I don’t know where I have to enter this key into Store Locator. Nether the configuration nor the URL (www.polizei-bw.de/dienststellenfinder) has been changed.
    Remark: the plugin is deactivated at the moment to avoid error-messages.

    Plugins:
    – Store Locator Plus – 5.2.11
    – Store Locator Plus – Experience – 5.2.11
    – Store Locator Plus – Power – 5.2.11

    Environment:
    – PHP 7.3.14
    – mySQL 5.7
    – WP 5.3.2

    Best,
    Jürgen

    #79114
    Cici
    Keymaster

    Ok,

    Well your SLP and add-ons are not latest version. 

    (but that does not effect the directions  where to input  API fields)

    In SLP go to the GENERAL TAB  

    add the

    Google API Browser key

     

    you do NOT need the Google Geocoding key if you have not added referrer restrictions.

    If you already have a key there and have the error still (I cannot see since you have turned off the SLP on your site url)

    then that means perhaps you did not add a billing account, or your credit card with Google is expired?  In that case please read in Google Support for suggestions

     

    #79115
    Cici
    Keymaster

    Alternatively, a lot of our customers are tired of dealing with  Google API keys and their ever changing rules.

    You might want to consider moving over to our MySLP SaaS solution. You do not need to worry about updating your SLP versions, you do not need to worry about Google API, we handle all that. You would most likely need to signup at  the Professional level plan if you decide to go that route and since you already have Power, just export to a csv file, and import into MYSLP account.  You can also import your JSON settings under the Settings/Tools.  You could have it all done and up and running in less than  an hour . A simple embed script and your map will be back on line

     

    See our SLP home page and our news blogs.

    More info on docs site for MYSLP getting started

    #79137
    Roland
    Participant

    Hey Cici,

    thank you for your information. I was able to fix the problem with the map. The reason was the missing credit card.

    Best,

    Jürgen

     

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘Google Map doesn’t work’ is closed to new replies.