Store Locator Plus for WordPress Forums Store Locator Plus Fatal Error Version 5.12.3

Tagged: 

  • This topic has 16 replies, 4 voices, and was last updated 2 weeks ago by Cici.
Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #82530
    CharlieG
    Participant

    Just purchased and uploaded <span style=”color: #000000; font-family: -apple-system, BlinkMacSystemFont, ‘Segoe UI’, Roboto, Oxygen-Sans, Ubuntu, Cantarell, ‘Helvetica Neue’, sans-serif; font-size: 13px;”>Version 5.12.3. Tried to activate and got a fatal error, could not activate. Same was the case with the old version after our server updated to PHP 8. Is this plugin supposed to be compatible with PHP 8? Can’t get it to work.  We are on WordPress </span><span style=”color: #000000; font-family: -apple-system, BlinkMacSystemFont, Segoe UI, Roboto, Oxygen-Sans, Ubuntu, Cantarell, Helvetica Neue, sans-serif;”><span style=”font-size: 13px;”>5.8.2. </span></span>

    Hope you have a solution.

     

    #82531
    CharlieG
    Participant

    I want to add that the plugin works on PHP 7.4 but breaks the site when we update to PHP 8.

    #82534
    Cici
    Keymaster

    I have sent the info to the developer for his input.

     

    #82536
    Cici
    Keymaster

    Charlie,

    There are or were issues that I have uncovered in the WordPress support forumshttps://wordpress.org/support/topic/php-8-and-wp-5-6-php-fatal-error-uncaught-error-call-to-undefined-function/

    Did you save the Fatal error script so we could see the error message generated?

     

    #82537
    CharlieG
    Participant

    With debug enabled, it showed this:

    Parse error: syntax error, unexpected token “\” in /home/lynnmfg/public_html/wp-content/plugins/store-locator-le/include/module/text/SLP_Text.php on line 239

    • This reply was modified 5 months, 3 weeks ago by CharlieG.
    #82553
    Cici
    Keymaster

    Thank you, I will pass this along to the developer

    #82556
    CharlieG
    Participant

    When can I expect a fix? If your plugin won’t work anymore, please refund.

    #82562
    Cici
    Keymaster

    Don’t use PHP 8  until the developer has a chance to address this or you may opt to switch to the SLP SaaS which works fine and is not dependent on you updating the plug-in and has no problems reported with PHP versions.

     

    The WordPress  plug-in details are compatible with the WP version as shown

    Our developer will get to it when he finished his current projects.

    Sorry for the inconvenience

    #82563
    Cici
    Keymaster

    P.S. if you need a refund you need to contact support. This  forum topic does not provide us with enough info to issue a refund.

    #82597
    peter
    Participant

    Is there any update on this? PHP 8 has been out for a while now.

    #82607
    Cici
    Keymaster

    no update

     

    #82689
    Cici
    Keymaster

    All

    HP 8.0 is a major version update with a large number of changes that break backwards compatibility, and many features that were deprecated within the PHP 7.x feature releases have been officially removed. PHP 8 uses much stricter typing than previous versions. Many built-in functions are now pickier about the input they accept, and PHP 8 itself is more stringent about how input is passed to functions. Issues that previously resulted in notices now result in warnings, and issues that previously resulted in warnings now result in errors.

    In other words, PHP 8 is not as lenient as previous versions. It will not try quite as hard to make code work no matter what.

    Since the majority of our customers have not updates to PHP 8, we will not be tacking this in the near future.

    The developer suggests you NOT update to PHP 8 because of the issue with backwards compatibility.

     

    #82757
    jasonfarran
    Participant

    Hello,

    I am getting the same error when I try to enable the plugin. I repurchased the plugin hoping it was caused by some old version I was stuck on, but I’m still getting the error.

    Changing to php 7.4 did not fix the issue. I am not able to use this plugin or the $250 extension I purchased.

    <b style=”caret-color: #000000; color: #000000;”>Parse error</b><span style=”caret-color: #000000; color: #000000; font-size: medium;”>: syntax error, unexpected token “\” in </span><b style=”caret-color: #000000; color: #000000;”>/home/makeitasafehome/public_html/wp-content/plugins/store-locator-le/include/module/text/SLP_Text.php</b><span style=”caret-color: #000000; color: #000000; font-size: medium;”> on line </span><b style=”caret-color: #000000; color: #000000;”>239</b>

    Please advise on what I should do.

    #82758
    Cici
    Keymaster

    Jason,

    I believe you sent an email to support.

    As mentioned in above posts the SLP plug-in does work on PHP 7.4. You did not purchase older versions but have recently purchased the latest version.

    browsers will not open the url you provided   because it is not secure. You need to follow the guidelines for correctly migrating your site and/or obtaining an updated SSL.

    The SLP plug-in works with PHP 7.4.
    Deactivate all plug-ins before activating SLP. Follow these directions
    You should be using a dev or clone site to update and test. 

    #82759
    Cici
    Keymaster

    @jasonfarran

    I double checked your site and it appears you have now loaded , updated and activated the latest version of SLP . Let us know if you have any other questions.  Thanks

    #82796
    Cici
    Keymaster

    @Peter

    Can you double check this. Lance said he had fixed the Issue with PhP 8  — there was a comment line that PHP8 didn’t like.  That has been addressed.

    #82797
    Cici
    Keymaster

    @Charlie

     

    That text line and the issue with PhP 8 has been addressed. let us know if you see anything when you update to PHP 8

Viewing 17 posts - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.