Tagged: , ,

This topic contains 8 replies, has 2 voices, and was last updated by  Cici 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #56278

    Ellison
    Participant

    I began receiving a message that “my destination markers couldn’t be found or were behind an extra layer of security.”

    I ran an update to 4.9.10 and now I don’t even see the section in Settings to add/change my destination marker!

    Please help!
    https://milestonepress.com/how-to-buy/

    WP version 4.9.4

    #56280

    Cici
    Keymaster

    Your marker destination points to this link and the page is 404 (not found) therefore it will not appear since it is not a public accessible link or has moved.:

    https://milestonepress.com/wp-content/plugins/store-locator-le/images/icons/marker.png

    if you have customized markers or icons, add them to your WP media library and copy the link from the media library and paste that url under your Settings/Map/Markers.

    See docs site with tutorial and instructions:
    https://docs.storelocatorplus.com/blog/using-custom-map-markers/

    #56310

    Ellison
    Participant

    As I noted in my post, I don’t even have the Settings > Map > Markers section anymore after the latest update to 4.9.10. The entire markers section just disappeared from Settings.

    Prior to the update, I was just using one of the default markers anyway, not a custom marker.

    It is very likely I am missing something here, but this feels like a canned answer that isn’t taking my situation into account. If you need any sort of login access, let me know.

    #56315

    Cici
    Keymaster

    I did not know which markers you were using or what you had selected. It is not a canned answer but directs you to the documentation.

    i went to your site, I see the marker you chose Flag azure, I went to my test site to see if that marker still exists and it does. Go to the SLP plugin, go to Settings,
    go to map
    scroll down page under markers, Location marker…that is what you are referring to as destination marker.

    i have attached the screenshot.

    Other then that i cannot recreate any issues with selecting a marker

    #56336

    Ellison
    Participant

    The Marker section has disappeared from Settings following the update to 4.9.10 therefore I cannot do anything…

    #56342

    Cici
    Keymaster

    I have no idea why you cannot see them. I cannot recreate the issue. Can you provide a screenshot of your plugin environment/

    Is your site in English?

    #56343

    Cici
    Keymaster

    Something, a plugin or your theme is breaking Javascript in your admin library.
    WordPress Store Locator Plus map rendering and the library management is managed by the slp.js JavaScript file. It sets up the communication with the built-in WordPress AJAX handler, admin-ajax. Your server must be setup to allow the built-in WordPress AJAX handler to execute. Additionally, ANY PLUGIN or THEME that is breaking javascript will break SLP functionality.See the troubleshooting or how to debug your plugins

    https://docs.storelocatorplus.com/blog/debugging-with-debug-log/

    #56350

    Ellison
    Participant

    My colleague found the Store Locator Plus Janitor plugin and cleared the settings and that worked.

    #56361

    Cici
    Keymaster

    Good to know, thanks for getting back to us and letting us know it has been resolved.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Destination Markers’ is closed to new replies.