Store Locator Plus for WordPress Forums Store Locator Plus Address Issues on Import

  • This topic has 8 replies, 2 voices, and was last updated 2 years ago by Cici.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #55004
    Boyd Norwood
    Participant

    I’m having an issue with my address 1 and address 2 getting mixed up when importing from CSV.

    I recently imported about 1270 locations, of which 290 had an issue with the address 1 and 2 fields getting mixed up. It seems like the most common issue is it will ignore address 1 and use the information in address 2 as the main address.

    I have the latitude and longitude for the majority of the locations, so it doesn’t have a problem geocoding, but it’s not displaying the correct address.

    Any help on this issue would be much appreciated!

    #55019
    Cici
    Keymaster

    Hi Boyd,

     

    Versions of the SLP, WP, Power add-ons?

    Are you using the CSV format as shown here in our documentation? Field names

    Can you show an example or  snippet of the file you are importing?

    Are you looking at back end and seeing a location does not have both address lines or are you saying the results on the front end?

    (see attached, I just imported the csv file adding a second address, I then checked back end locations it was there, I just checked front end under results and it was also there, my test : Positive results, worked as expected)

    I did not change my results layout so I should change the results layout to put address 2 on separate line but other then that it shows up correctly, imported correctly anon both back and front end

    Do you have address 2 checked off under screen options?

    (see screenshot)

    If you include the site url that the results page returns I can look at it there as well.

    Attachments:
    You must be logged in to view attached files.
    #55023
    Boyd Norwood
    Participant

    Thanks for responding. To answer your first question, yes, I’m importing a CSV file from my Mac (CSV UTF-8 Comma Delimited)

    I have attached a couple of screenshots that have the discrepancies highlighted.

    The first one shows what I’m importing. The second one shows what is showing up on both the back end as well as the front end of the plugin. (Those screenshots are attached as well)

    Attachments:
    You must be logged in to view attached files.
    #55028
    Boyd Norwood
    Participant

    The page with the store locator plugin is – https://www.kaleidescape.com/find-a-dealer/

    #55029
    Cici
    Keymaster

    I just want to make sure first that you are using current versions of SLP and Power. Could you provide that info as well. (see posting guidelines)

     

    As far as the screenshots with the spreadsheet, I see you have a column with header id…Are you updating an existing location , store that is already in your database and that has been assigned an sl_id? ?  In other words, was that store id exported from your current locations and did you check it against the store id column in your locations admin panel, it has to be an exact match. using the duplicate handling feature

    #55030
    Boyd Norwood
    Participant

    I’m using Version 4.8.7 of the Store Locator Plus and Version 4.8.4 of the Experience add-on.

    What I did prior to the upload was export the list from the plugin, update the address fields, and then import the updated list. In the files settings, under the Import menu, I have it set to update duplicates.

    I’ve even gone as far as deleting all of the locations from the plugin and uploaded the updated list.

    Should I remove the id column?

    #55033
    Cici
    Keymaster

    So you  have the POWER addon correct?   Assume you do since you are importing.

    If only some of the locations are messed up then there is something awry with your file.

    If you deleted all the locations  and they no longer have an id then if you  import fresh without the id column. my import worked  correctly so something in those rows that did not update correctly is askew on your file is my guess.  If you are still having problems  after reviewing the docs, under imports you can send your file to the contact us.

    #55034
    Boyd Norwood
    Participant

    Correct, I have the Power addon.

    It’s strange, because the file that I’m uploading is the download from the plugin…I just updated the address.

    There are over 120 entries (out of 1250) that uploaded the address 2 information in the address 1 field.

    I’m going to work on cleaning some of these up and trying it again. Do you have any other suggestions that I can try?

    Do you think that having a space behind the address could be causing it?

    #55043
    Cici
    Keymaster

    I would look at the difference in  formatting, if as you said many loaded and some didn’t. If that is the difference then a space could throw it off but it shouldn’t unless you hit a hard enter when creating the spreadsheet.  Nothing should “move” address 2 into the address 1 column , so that indicates that perhaps there was a configuration issue in your original spreadsheet.

    The only  other information I can offer, if you were merely updating and followed the Duplicate import handling instructions, did you double check to see that the store ID was correct?

     

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.