Store Locator Plus for WordPress Forums Store Locator Plus Store Locator Plus Power v4.9 crashes site

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #55165

    I’ve had the Store Locator Plus Power plugin working for a while but today my site went down with this error:

    Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in … /wp-content/plugins/store-locator-le/include/base_class.addon.php on line 328

    So I deactivated both the Store Locator and Power plugins. I updated the Power plugin to version 4.9. The Store Locator plugin was already at version 4.9. Then I activated the Store Locator Plugin and it works on the site fine. Then I activated the Power plugin and it took down my site again with the same message as above.

    I am using WordPress version 4.9, Store Locator Plus version 4.9 and Store Locator Plus Power version 4.9 with PHP version 5.3.

    Also, how does one find out about Store Locator Plus plugin updates before your site is taken down? The plugins tab in WordPress didn’t show the Power plugin needed updating.

    URL of plugin use:

    You must be logged in to view attached files.

    I cannot recreate your issue. I just deleted my Power 4.8.6 and Added Power 4.9 no problem, except that I forgot to delete the Power add-on and received an error message when i tried adding plugin, error message said file directory already existed.  I do not know if the issue is because you are using PHP 5.3,

    I will have to ask the developer. I am guessing that could be the issue, that version of PHP. I believe you would need at least  5.4 or higher.


    PHP version   5.3 was in  2009… there any way you can update that?

    The author/developer did not opt to auto update peoples SLP plugin and add-ons but he is considering doing so. I have mentioned that some people may have issues with that, such as the one you are experiencing. So it is something that he is considering and your feedback is helpful.


    The problem with the add-ons not automatically being shown is because of the WP-CRON. When WP has a major update, like they just did, thousands and thousands of plugins also update, by the time it goes through all the thousands of plugins it may not get to the  add-ons which are not sold in the WP directory.  The SLP auhtor is aware of this and , again, that may be something he will do in the future (auto update when SLP updates)


    You must be logged in to view attached files.

    you have something using old jquery 1.11,   Check the jquery versions of all your plugins and theme.

    1. In addition you will  have issues if you do not have a valid SSL  cert. See Lance’s post in reply to the security patches, SSL and what WP is doing to update.

    One of the best tools for searching for errors in the HTML page headers is to use Firefox with the Firebug plugin.

    Turn on the console and check the responses tab for any errors.

    When I visited your site I got this error message

    Error: Script terminated by timeout at:

    Lance Cleveland

    @Dan – thank you for the report.   I was able to find the changes in SLP 4.9 that are causing the problem.  Some of the code that I added to 4.9 turns out to be supported with PHP 5.4+ only.

    I am working on the SLP , Power, and Premier 4.9.1 updates that restore PHP 5.3 compatibility.    I hope to have those 3 updates out within the next few days.


    For our PHP 5.2 users, unfortunately we can no longer support that release of PHP.   We are using a new architecture based on a PHP function that was added to PHP in February 2012.   That change in SLP 4.9 means sites using PHP 5.2 can no longer use PHP.

    For all users, you really should be on PHP 5.6 at a minimum.  There are literally dozens of security patches in PHP between each point release (5.2 => 5.3 => 5.4, etc.) some of which are significant.

    For reference, here is the PHP Version Release History.   Supported until means the last date the PHP language was fixing problems and patching security holes.
    Version Latest Supported until
    5.2 5.2.17 6 January 2011
    5.3 5.3.29 14 August 2014
    5.4 5.4.45 3 September 2015
    5.5 5.5.38 21 July 2016

     If your host is not allowing you to upgrade to a newer release or a WordPress plugin or theme breaks on PHP 5.6+ you should ask why.    WordPress (and Store Locator Plus) run perfectly well on PHP 7 which is the current recommendation from WordPress due to the notable performance improvements in version 7.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.