Store Locator Plus for WordPress Forums Premier Support Stop map zooming out to worldview

This topic contains 3 replies, has 2 voices, and was last updated by  Cici 3 weeks, 6 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #59135

    Dan
    Participant

    I have just upgraded to Premier. Before the upgrade, the map loaded at my preferred zoom level per the longitude/latitude entry I added, then zoomed out to just show Australia and New Zealand.

    Now after the upgrade the map loads as before BUT now zooms out to show the worldview. I have played with various settings to try and achieve the original AUS/NZ view but to no avail.

     

    URL: https://clicknride.com.au/stockists

    My Map Settings are:

    “Do not autozoom” is off (If I turn it to ON, then the map stays at zoom level but re-centers to middle of Africa)
    “Zoom level” is 10 (to initially show home location up close)
    “Zoom adjustment” is 0
    “Search when map moves” is on
    “Map domain” is Australia (maps.google.com.au)
    “Zoom” is on
    “Full screen” is on

    Software:

    WP version 5.1.1
    StoreLocator Plus WordPress plug-in – 5.05
    StoreLocator Plus Experience – 5.04
    StoreLocator Plus Power – 5.1
    StoreLocator Plus Premier – 5.1

     

    Thank you.

    #59137

    Cici
    Keymaster

    Things that also effect the initial display are center map at, radius always on, or only  after search   and also the  results settings , display all, etc.

    Are you saying you only want Australia and New Zealand displayed and not any of the other locations you have worldwide?

     

    #59138

    Dan
    Participant

    Yes that’s correct (almost) – I’d like the map to only show AUS/NZ as the initial view for customers in that region. Similarly, customers in Europe to only see locations for Europe and so on. To put it another way, customers in each region to more or less see only their part of the world (map only partially zooms out rather than to full worldview).

    #59141

    Cici
    Keymaster

    You should  turn on Location sensor and set the distance to a lower distance under results settings. and/or  disable initial directory from results if you do not want all the locations to appear.

     

    https://docs.storelocatorplus.com/blog/results-panel-settings/

     

    Also you might want to turn off the cluster map markers or change the settings for it  if you believe you had the correct settings to have the map and results working the way you described before upgrading.  . I am not sure if you had the Power add-on before with location sensor available. but upgrading to Premier would not automatically change any of your previous settings or css. The cluster  feature is however a default (turned on in Premier automatically)  That feature does show the map differently.

     

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.