SLP JS Error

Home Forums Store Locator Plus SLP JS Error

This topic contains 6 replies, has 2 voices, and was last updated by  Cici 2 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #45896

    Julie
    Participant

    Hi, we’re experiencing an issue where the SLP is working but is showing an uncaught type error in the console.
    <p class=”MsoNormal”>Store Locator Plus: 4.7.9</p>
    <p class=”MsoNormal”>Experience: 4.7.9</p>
    <p class=”MsoNormal”>Site URL: http://www.tomaleche.com</p&gt;
    <p class=”MsoNormal”>This Info Cached: 1493267019</p>
    <p class=”MsoNormal”>Network Active: No</p>
    <p class=”MsoNormal”>WordPress Version: 4.7.4</p>
    <p class=”MsoNormal”>PHP Version: 5.6.10</p>
    <p class=”MsoNormal”>MySQL Version: 5.5.42</p>
    <p class=”MsoNormal”> PHP Limit: 256M</p>
    <p class=”MsoNormal”>WordPress General Limit: 40M</p>
    <p class=”MsoNormal”>WordPress Admin Limit: 256M</p>
    <p class=”MsoNormal”>PHP Peak RAM: 61 MB</p>
    <p class=”MsoNormal”>PHP Post Max Size: 32M</p>
    <p class=”MsoNormal”>Nerdery Skeleton Theme v2.1</p>
     

    #45898

    Cici
    Keymaster

    I do not see SLP anywhere on your site as a WP plugin. I cannot help you without additional in formation or the error log you are referring to.

     

    #45912

    Julie
    Participant

    I apologize for original post. It was originally installed on my local dev environment.

    I just installed in our staging server. We just purchased the Experience Plug-in Add-On.

    Please visit page:

    Map Demo

    Please view Chrome Developer Tools for console errors.

    The errors only appear on a page that is using SLP [SLPLUS].

    Once I disable the Experience plug-in, the errors go away. Please advise. Thank you.

    Plug-in Versions:

    Store Locator Plus:4.7.9
    Experience:4.7.9
    Power:4.7.9

    Site URL:http://staging.tomaleche.com
    This Info Cached:1493686555
    Network Active:No

    WordPress Version:4.7.4
    PHP Version:5.5.35
    MySQL Version:5.5.54

    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:18 MB
    PHP Post Max Size:500M

    #45919

    Cici
    Keymaster

    Do you have forceload javascript checked under General settings ?  See Troubleshooting here.

    Is your theme using a version of jquery that is at least v. 1.12?

    Here is the EXP Locator shortcodes Cheat sheet

    and the data field names 

    I cannot help you with this staging dev site, I will refer this to the developer when he has time to take a look at it… but in the meantime see doc site, this is a good one to look at , (ignore the Q.)

    #45921

    Julie
    Participant

    Forceload javascript is NOT checked. I actually did a test on that setting and turned it on/off to see if errors go away, same result.

    Updated Jquery to version: 3.2.1

    Updated require.js to version: 2.3.3

    Not sure if its the same console errors, but still getting errors.

    Again, it only happens when we activate the Experience add-on we just purchased for $250.00. As soon as we deactive extension, no more console errors.

    Please advise. Thank you.

     

    #45924

    Cici
    Keymaster

    Check the theme and plugins as well. I cannot recreate your issue and did discuss with the developer and he also took a look.

    Your system is preventing the WP jquery-ui-dialog from loading or is removing it.    You are likely forcing an invalid version of jQuery to load or another plugin/or theme is forcibly removing jquery-ui-dialog from the user-facing pages.

    Please read through the Troubleshooting, Debug tool (WordPress)

    The first stage of debugging is to turn on the built-in WordPress debugging messages and debug log.

    Find your wp-config.php file and make the following changes.

    Find the line:

    1
    define('WP_DEBUG', false);

    Edit that line and add another to the wp-config file to turn on logging:

    1
    2
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);

    Read this Debugging WordPress article for more info.

     

    #46447

    Cici
    Keymaster

    Update ypour SLP and EXP add-on to version 4.8 released this week to see if that helps with your issue

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.