Store Locator Plus for WordPress Forums Premier Support “Remote File Retrieval” Doing nothing

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #79116
    Geek Town USA
    Participant

    I am trying to schedule hourly updates of SLP locations based on “Remote File Retrieval” of a specific CSV. I have placed the file in my uploads folder, set it to upload hourly, and left the “Import Time” section blank. I’ve continued to check the file every 15m or so, and haven’t seen any of the new locations added. I tried setting a time, tried changing the schedule to “Daily”, and nothing seems to make any real difference. The file doesn’t seem to be touched.

    I’ve also tried manually importing the spreadsheet, which seems to work correctly, so I believe my CSV file is properly formatted.

    • Does it matter where the file is saved, so long as it is publicly accessible (via browser, for example)?
    • Does it matter if the file is locked?
    • Does it matter what the file permissions are? 777, etc?
    • Is there a log of all attempts by “Remote File Retrieval”, to show any errors that may have occurred? If so, where can I find this log?
    • Any other suggestions?

    WP 5.4, SLP 5.5.2, SLP-Experience 5.5.1, SLP-Power 5.5, SLP-Premier 5.5.

    Thanks in advance!

    Attachments:
    You must be logged in to view attached files.
    #79118
    Cici
    Keymaster

    Yes to al.

    It does matter where the file is saved,  It needs to be publicly accessible.

    yes it matters if the file is locked. (It cannot be)

    As far as File Permissions, review WP, 

    Configuring your server and PHP limits technical article still applies even thought his was published a while ago

    Turn on General /Schedule   if you haven’t already

     

    #79146
    Cici
    Keymaster

    Also, an update, there will be  an update for Power and SLP. You should update when you see it available, it might help with your Cron job and remote file retrieval. but you will still need to maintain and have the file somewhere it can communicate with WordPress.  (Not be behind an extra level  of security which blocks communications if you are using remote file retrieval)

    #79150
    Geek Town USA
    Participant

    Hi Cici,

    (I sent 2 replies last week, but neither are public; I don’t know if they were deleted or what… if this one doesn’t show up, I’m going to attempt emailing you to see what’s going on. Just FYI).

    I just updated SLP & Power. So far, nothing new.

    What happens when I click “Locations > Import > Remote File Retrieval > Import Locations”? Should it be attempting to import the linked file, or just saving my settings?

    So far, nothing seems to be working. The file is publicly accessible and file permissions seem to be set correctly. I’m open to suggestions!

    #79156
    Cici
    Keymaster

    Ok, I see this post now.

    It should be attempting to import the locations from the remote file retrieval.

    I am working with the developer to see what may be happening here.

    If you have a test or staging site , try importing from our google drive (Public ) as a remote file retrieval and let us know if that is working for you (try it on your test site or staging site) .

     

    https://docs.storelocatorplus.com/example-csv-import-files/

     

    #79157
    Cici
    Keymaster

     

    One quick way to tell is put the URL you are using for your imports into your browser.Does it download a CSV file you can open with a text editor?No?Then It isn’t a vanilla CSV file readable by the “Internet”.

    This is the link you can use to see if remote file retrieval is working

    For example — if you go HERE it tries to download a file…
    https://demo.storelocatorplus.com/wp-content/uploads/2020/04/9-Restaurants-With-Lat-Lng-Cat.csv

    Google changed how share links on drives are working and we found no way to get to the raw CSV file with any links they provided.

    So Google Drive hosted CSV files is likely never going to work again.   Just one more way for them to track everything you do online by using an embed object vs. a flat CSV that they give you access too.

    #79158
    Geek Town USA
    Participant

    One quick way to tell is put the URL you are using for your imports into your browser.Does it download a CSV file you can open with a text editor?

    I tried this, and yes, the CSV downloads correctly (so I believe the file is publicly accessible). Also, if I manually import the CSV into SLP, all of the locations load correctly (so I believe the CSV is properly formatted).

    What else can I try? Should I post some screenshots of anything? Please let me know what you’d recommend and we’ll take it from there. Thanks!

    #79159
    Geek Town USA
    Participant

    I’m also getting errors while searching:

    slp_core.js?ver=1586800379:1569 Uncaught TypeError: Cannot read property ‘trim’ of undefined
    at slp_Map.saneValue (slp_core.js?ver=1586800379:1569)
    at process_geocode_response (slp_core.js?ver=1586800379:1399)
    at Object.<anonymous> (slp_core.js?ver=1586800379:122)
    at i (jquery.js?ver=1.12.4-wp:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4-wp:2)
    at x (jquery.js?ver=1.12.4-wp:4)
    at XMLHttpRequest.c (jquery.js?ver=1.12.4-wp:4)

    Maybe I’ve got some sort of conflict going on?

    #79161
    Cici
    Keymaster

    Without the site url where you are seeing those errors I could not tell you but it does sound like you may have a conflict or you do not have your Google API keys set up correctly(?). If you could provide me with the site url where you are experiencing the issues, the developer will ask about it as well since all our tests with remote file retrieval is working.  If you do not want to post here, you can send an email with the info, including a screenshot of plugin info, versions, url, a link for the remote file (we should be able to test your remote file if the list isn’t too large)   There is  paid support option if you need additional help that is not within the scope here.

     

    #79162
    Cici
    Keymaster

    P.S> Please contact us, I do not see you as having a current premier subscription. The user profile shows an issue with the renewal of your premier subscription dating back a few years

    • This reply was modified 1 month, 1 week ago by Cici.
    #79164
    Geek Town USA
    Participant

    Sure, no problem. I’ve sent you a Contact Form message with my information, as well as order details for our active subscriptions.

    I’ll wait to hear from you there. Thanks!

    #79165
    Cici
    Keymaster

    Ahh, I see what happened, there was a year skipped or cancelled (2017)  and then the newer payments went through. I checked with the support emails and  haven’t seen an email come through to support  as yet. We were having some issues with the third party support email systems so I will check again. Or you can try to send an email again if you do not hear back in a timely manner.

    Thanks

    #79166
    Geek Town USA
    Participant

    If you want to contact me at the email address on file, I can send you whatever information you need that way.

    Also, I went through and tried disabling all plugins to see if there was a conflict, and had no other results. Unless it’s a script or something that’s causing a conflict, I’m not sure what’s going on there.

    Again, any advice on getting this feature working would be great. Thanks!

    #79172
    Geek Town USA
    Participant

    Cici, were you able to find my message?

    Please let me know what I can do to accelerate this process; my first post is from 2 weeks ago, and currently my entire Search is down. I’m open to suggestions, I just need to know where you look.

    Thanks again!

    #79176
    Cici
    Keymaster

    The post  I was referring to was here in the forum We are not seeing any emails from you to support. The developer is working this weekend with an essential relief provider during the covid 19.  What do you mean your search is not working now??????? I thought it was just remote file retrieval you were having issues with and was going to email to us to see if we could access (but you were able to manually upload  imports.)

    What is the url  where you say search isn’t working now?   Are you still on the versions above? A screenshot of your current plugin info is best it shows us everything we need. You have back-ups I assume? Hopefully , you are only experimenting on test or clone or staging sites/

    I do not believe you ever have provided us with any urls?

     

    P.S.  The only email I found was for christine@geektownusa

    I checked the spam in support email and did not see anything from you.

     

    #79190
    Geek Town USA
    Participant

    (This post just submitted, but does not show up. I tried resubmitting, received an error “Duplicate reply detected”, however no reply is posted. The last time this happened, you said you never received my response, so I’m resubmitting this one until I see it stick. Sorry if you get it 20 times…)

    (Trying again with no attachment).

    (Trying again from a private window).

    (4th try, private without attachments…).

    (5th try, removing links. Either I’m losing it, or something’s wrong with your forums.)

    (6th try, removing all links that could be interpreted as code or spam…)

    The previous post I linked here comes up anytime I run a search.

    The site we’re working on currently lives (redacted). Locations are found, however new searches do nothing. This is technically a second issue (a much bigger one, TBH), however I do not know if they’re related or not.

    I’m attaching a screenshot of the plugin environment from our Info page.

    I’m not sure why you didn’t get my previous contact form submission. Maybe I sent a request to the wrong place?

    I can be contacted at jason (at geektown usa ). Christine is another developer here, she can receive emails regarding this issue as well, if that is easier.

    I’ll wait to hear from you via email, but would be glad to expand on any of this in private.  🙂

    Thanks, Cici!

    #79195
    Cici
    Keymaster

    Let me send you an email from support…Someone else just reported no emails went through using the contact us form..UGH>>>> The developer is so tied up right now with customizing for a relief organization so he doesnt have time to fix the contacts us…I am so sorry about that. I have no idea whats going on, its like the whole world has gone crazy including software .

    #79208
    Cici
    Keymaster

    We sent you the beta pre releases for SLP and EXP but your file server blocked them.    if you would like to test you would need to download them from your account downloads marked pre release with premier account

    #79244
    Cici
    Keymaster

    Hi Jason,

    We have a pre release beta version of Power add-on that is addressing the remote file retrieval. If you want to test it go to your account and at the bottom of the page in footer you will sere Download above the Premier support text. If you click on download there you will see all the beta pre releases but you should only test on a clone or dev site as mentioned before. We need to do more testing before the patch is published

Viewing 19 posts - 1 through 19 (of 19 total)
  • You must be logged in to reply to this topic.