Store Locator Plus for WordPress Forums Premier Support Red text after installing Premier plugin

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #81709
    mike.bullen
    Participant

    I’ve been trying to make some changes to the Map Domain, but even after activation and successfully linking my premium account, some features are still coloured red and aren’t doing anything.

    Here is the SLP Environment Info:

    Store Locator Plus®:5.8

    Experience:5.5.5

    Power:5.5.8
    +Pages

    Premier:5.5.3-beta-1

    Site URL:https://staging.automasters.com.au

    This Info Cached:1619580364

    Network Active:No

    WordPress Version:5.7.1

    PHP Version:7.2.34

    MySQL Version:10.2.37

    PHP Limit:256M

    WordPress General Limit:40M

    WordPress Admin Limit:256M

    PHP Peak RAM:82 MB

    PHP Post Max Size:64M

    The site is a staging subdomain, is this what is affecting the ability to use some settings? I would really like to be able to use all the settings in the plugin.

    • This topic was modified 1 week, 2 days ago by mike.bullen.
    • This topic was modified 1 week, 1 day ago by Cici.
    #81712
    Cici
    Keymaster

    Hi Mike,

    What exactly are you referring to as far as red text?  What Gallery style are you using?

    I noticed on that staging site you have installed Smushit. There is a conflict or at least there was, between Smush it and WPSLP, whereas our plug-in already has a minifier .

    Disable Smush it.

    next I noted there seems to be some error regarding your theme header.

    As fas as. CSS in general there is some info in our docs about handling CSS

    #81715
    mike.bullen
    Participant

    I’ve attached a image of the red text error in the settings below. Any settings in red are having no affect, but I’ve successfully registered the premier version:

    <h3 style=”font-size: 13px; margin: 1em 0px; font-family: ‘Open Sans’, sans-serif; line-height: 1.4em;”>Premier Subscription</h3>
    <p id=”_p” class=”slp_subheader_description” style=”font-size: 13px; line-height: 1.5; margin: 1em 0px; color: #3c434a; font-family: -apple-system, BlinkMacSystemFont, ‘Segoe UI’, Roboto, Oxygen-Sans, Ubuntu, Cantarell, ‘Helvetica Neue’, sans-serif;”>Your Premier Subscription has been validated. Thank you for your continued support.</p>

    I’ve disabled Smushit and the errors are persisting.
    The theme_header error happens on the live site too, I don’t think it’s affecting the backend settings though?

    Attachments:
    You must be logged in to view attached files.
    #81725
    Cici
    Keymaster

    You are referring to the text in the back end/ So some are red and some are black text instructions. I never noticed, but essentially are you saying for example…under Settings/Search, there is distance units…your choices are miles or kilometers.  Are you saying if you choose KM instead of miles and then save and then look at the front end , the distance unit does not change?

    Or  in another example if you select the functionality under Settings/Results to set Initial Search Radius

     

    that it is not changing (example set initial search radius to 15000 and it would show anywhere you have results in the world)

    If you are saying none of your settings are working  or you can’t click on them to change and you have deleted smushit then you need to look at another conflict and troubleshoot.

    The way we test it is by disabling all the other plug-ins. switch to a plain vanilla theme. And see if you can make changes.

    As far as where to have premier on a multi site install see https://docs.storelocatorplus.com/how-to-validate-premier-with-multi-site-installations/

    if you are only saying you can’t change the text color in the back end that is something totally different and really shouldn’t effect anything in the front end.

     

     

    #81731
    mike.bullen
    Participant

    Hey Cici,

    I’ve turned all other plugins and reverted to the old theme. I found that changing <i>Distance Unit</i> from Miles to KM is working correctly. Is the red is an internal styling choice then?

    I’m using two separate DBs for the two sites. I just wanted to confirm that that isn’t a multisite installation?

    I was trying to get the Map domain to work, <i>No locations found.  </i>message, but I realize it might be to do with something else. I’ll make another ticket instead.

    Thank you for your help Cici.

    #81735
    Cici
    Keymaster

    Two separate databases….then are you using shortcodes  on separate pages?  I am not sure how you are displaying with the plug-in using two completely different sets of locations. Is that the database you are referring to or are you using one big location dataset and using shortcodes and/or widgets to display them on different pages or for different customers?

     

    #81736
    Cici
    Keymaster

    As far as the red text in the back end. I am not sure when that came about. The developer switched to Vuefy quite awhile ago.

    As far as the map domain I answered in a different post. But there are NEWS articles about accuracy in other countries

    #81739
    mike.bullen
    Participant

    Buefy? Vuetify?
    I had a look at the html and the red is being applied to all “.quick_save labels”. I just assumed because it was red that it was broken or required.

    Thank you for answering the other Map Domain question.

    #81743
    Cici
    Keymaster

    Yes Vuetfy ,  seo-pages-and-12-column-grid-support

    Not sure when the back end changed to tell you the truth , but you are correct usually the red text as opposed to black text means something specific like required but because the foundation of MySLP SaaS was built from the original plug-in that may not be the case.

    You’ve now peaked my interest and I will have to ask the developer during a fireside chat.

    🙂

    If you have any problems with Google not finding some of the locations in Australia correctly you might want to switch over to SLP SaaS.

     

    https://storelocatorplus.com/according-to-google-kansas-city-has-moved/

    #81744
    Cici
    Keymaster

    Better address accuracy outside the United States

    The biggest change to the My Store Locator Plus® software as a service was the implementation of region data handling. The map domain, aka “region” setting under Store Locator Plus | Settings | Map influences the accuracy of the results returned for new location addresses as well as user searches.

    Users in countries like Australia or parts of Western Europe should see a notable improvement in the accuracy of locations returned when searching for an address. The map engines, primarily Google, that are used to geocode addresses are more heavily influenced by the region setting in those countries.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.