Store Locator Plus for WordPress Forums Store Locator Plus Power 5.3 and Store Pages showing 404 pages randomly

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #71141
    Super Web

    Good morning,

    We’ve been having a strange issue with the Store Pages displaying 404 pages randomly.

    The issue resolves itself after a bit, or we can instantly fix it by going to “Settings > Permalinks” and clicking save.
    We have this issue on our main website randomly (perhaps every few weeks), and fix it simply by doing this.

    Our main website is running “Store Locator Plus” & the “Power” addon both Version 5.2.11

    Recently, we started to rebuild our website (from scratch) on a subdomain.
    We installed “Store Locator Plus” & the “Power” addon Version 5.2.11, and started to rebuild the website … keeping all plugins to a bare minimum.
    We don’t have any website caching plugins installed (yet).
    No issues with 404 pages at this point.

    After updating “Store Locator Plus” & the “Power” to 5.3 … we started to get the issue with Store Pages displaying 404 pages very frequently, perhaps every 5-10 minutes.

    The issue still occurs fairly randomly, and when “doesn’t occur” it’s generally good for an hour or so.

    When any store page displays a 404 page, all of them do.
    The .htaccess file hasn’t been modified, and no other URLs/pages/posts have any issues displaying.

    Any suggestions ?

    The below details are from the website that we’re rebuilding.

    Store Locator Plus®:5.3

    Site URL:

    This Info Cached:1573430854

    Network Active:No

    WordPress Version:5.3

    PHP Version:7.2.24

    MySQL Version:5.7.28

    PHP Limit:256M

    WordPress General Limit:40M

    WordPress Admin Limit:256M

    PHP Peak RAM:26 MB

    PHP Post Max Size:128M



    Thank you.

    • This topic was modified 6 months, 1 week ago by Super Web. Reason: Clarification of software being referred to by the version 5.3
    Super Web

    Curiously, if I use the page with the [STORE-LOCATOR] on it to search for a location, and then click on the link to view the store page … the page is accessible every time.

    If I refresh then refresh the store page’s URL (or visit the URL directly), that’s when it’s disappearing shortly after.




    That short code Store-Locator is not ours.

    Please provide a screenshot of your plugin environment and the actual url that you are using our plugin on


    Which url? I do not see any 404 errors on the
    Site URL:

    Are you usign the SEO Pages and is it a linl? is it the link “About Suburb” that is your Store Pages? i.e

    Not sure I am following your question

    Super Web

    Thank you for checking this Cici.

    Sorry, we’ve been using the [STORE-LOCATOR] shortcode from quite a few versions back, and hadn’t updated it to [SLPLUS] yet.  I’ve just updated it (on the page) now.

    Yes, the “About Suburb” link is our store pages, created via the “Store Locator Plus® – Power” plugin. is one of the URLs that was randomly showing “404 Page not found” errors if we refresh the page after visiting.

    The store page works fine if we click on the link to visit the page via the “About Suburb” link.
    However, if we wait a few minutes & then refresh the page … we get the “Error 404 – page not found” message.


    I’m guessing that there’s some sort of Permalink conflict between the plugins, but I’ve tried disabling all of them (including Yoast SEO) … the problem still reoccurs after a random few minutes.

    You must be logged in to view attached files.

    Deactivate Smush. (Yoast has absolutely no conflicts with our plugins.)

    I am curious why only random pages are returning 404 on refresh or time out, we do not control any of that here .WPSLP is a do it yourself plugin and you host it on your server. . If it was a bug in our plugin it should effect all your locations not just random ones. I can mention it to our developer to see if he has any ideas , he has abroad base knowledge of servers etc. but I really cannot troubleshoot “randomness” for you. Every time I search and follow the steps and refresh your SEO Pages it is fine…I have noted there is a date under the header on the pages though It shows NOV 19, 2019 on the front end, why is there a date in there at all? Does it serve a purpose or is it something coming from your theme? That is the only anomaly I see.

    See docs about HOW SEO Pages SLP works

    Did you try using the WP DEBUGGER?

    P.S the screenshot you are showing us is not what is meant by Plugin environment, we are referring to the SLP TAB called INFO that has the Plugin environment under it

    Super Web

    Sorry, I posted a reply, but it disappeared.
    (So forgive me if this is a double-up).


    Yes, this issue affected all Store Pages at the same time.
    (When 1 returns a 404 pages, every single Store Page does at the same time.)

    Curiously, the Store Pages are still listed when the using the basic WordPress search.
    And will also reappear when the search result is clicked.


    The “Plugin Environment” screenshot is attached.
    (It’s what I copy & pasted in my original post, with the exception of the “This Info Cached” value being different.)

    I’ve disabled Smush Pro, but the issue is still occurring.
    The “date” was coming from the Theme.

    I’ve enabled WP_DEBUG & WP_DEBUG_LOG , but no debug.log file is being created.


    Thank you for taking the time to look into this issue for us.
    I’m quite puzzled here. It feels like some sort of Permalink corruption (targeting only the Store Pages, even though it’s a fresh build of a website with plugins I’m familiar with using.


    You must be logged in to view attached files.

    Ok, Thanks for clarifying I Spoke briefly to the developer at a meeting and he suggested try flushing permalinks. With WP 5.3 updates who knows what craziness is happening, I have seen issues with people using the Avada theme whereas a bug was introduced.


    I just visited your site again, and searched postal code 2000 and clikced on the first result link to go to SEO page and it came back quickly with the results. This is the link I see.

    Super Web

    Thank you.

    Our developer (last night) managed to determine it was a conflict with the Theme (“Enfold”) that we were using, when a custom post type was not using the Gutenberg editor (WordPress 5.x ‘s default editor).

    We needed to add the following code to our child theme’s functions.php file

    /*  */
    function change_editor_for_store_pages() {
    global $wp_post_types, $wp_rewrite;
    $object = get_post_type_object(‘store_page’);
    $object->show_in_rest = true;
    $object->supports = array(‘editor’);
    add_action( ‘init’, ‘change_editor_for_store_pages’, 999 );
    /* */

    The Store Pages are now working perfectly.


    Thank you for your time looking into this for us.


    Ahh, awesome, I am glad you were able to find a solution. Thanks for sharing your solution so others might benefit.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.