Map Not Showing

Home Forums Store Locator Plus Map Not Showing

This topic contains 4 replies, has 3 voices, and was last updated by  Cici 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #46853

    john19
    Participant

    Hi, I’ve recently encountered a problem with the SLP plugin. My map no longer shows the map or the pins. Here’s the page that is supposed to show the information

    Locations

    I’ve generated a new Google map API key and inserted that into the settings and am still not seeing what is causing the issue. I’ve deactivated a few of the plugins in an attempt to see if it was a plugin conflict – and was not able to resolve this problem.

    Can you provide some trouble shooting tips in going about finding the issue?

    Thank you for your assistance.

     

     

    #46855

    Cici
    Keymaster

    To assist you we would need the information regarding your Plugin environment as stated in the Posting guidelines.

    For instance do you have any add-ons?

    It appears that the problem maybe with your theme and which SLP Gallery style you chose, or didn’t choose.  Error failure being shown here.

    http://smilingmoosedeli.com/smd-wp/wp-content/themes/the-moose/css/bootstrap.css.map

    There is a troubleshooting guide in our documentation. See the info under Grey Map or Map not loading

     

     

    #46856

    Cici
    Keymaster

    P.S. You only need a Google API if your site starting using maps after June 2016 or if you changed domains

    #54513

    scott15
    Participant

    Please help 🙂
    I am hoping someone will be able to help.  The map is gray or blank.  I believe the API is set correctly.  Here is the page the SLP Plugin appears on:  http://stephenhealthinc.com/?page_id=56

    Here is the plugin Enviro.:

    Store Locator Plus:4.8.3
    Site URL:http://stephenhealthinc.com
    This Info Cached:1504192613
    Network Active:No
    WordPress Version:4.8.1
    PHP Version:5.2.17
    MySQL Version:5.0.96
    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:8 MB
    PHP Post Max Size:33M

    </div>
    </div>
    </div>
    </div>
    The problem happened when WordPress was upgraded from 3.6.1 to 4.8.1 and the Plugin upgraded there after to reflect that upgrade. It worked perfectly for years and now isn’t.

    Any help would be greatly appreciated.
    Thank you to those who take their time to debug this stuff for free.

    #54514

    Cici
    Keymaster

    Do you have a back-up of your site? Assume since you jumped from WP pre version 4 that you may have other plug-ins that are outdated and not using the jquery versions required by WP or are breaking javascript.

    “The Store Locator Plus map is a very visible indicator that something is wrong with the JavaScript on your site.  It is often the first thing you will notice.  Often the problem is not with the Store Locator Plus code.   Since the SLP plugin cannot control if its JavaScript is run first or last there is a high likelihood that some other broken JavaScript runs before it.  When that happens and there is a fatal error in the other code ALL the scripts stop running on the page, including the SLP JavaScript.  That means the SLP script won’t talk to Google and that means Google won’t get the request to load the map tiles.”

     

     

    Jumping multiple versions if never recommended.  Try using the WP debugger (see docs) to  try and isolate the problems.

     

    You would not need to obtain a new Google API key unless you have changed the domain IP address

     

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.