Locator isn't centering map on correct location with large radius set

Home Forums Store Locator Plus Locator isn't centering map on correct location with large radius set

This topic contains 1 reply, has 2 voices, and was last updated by  Cici 3 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #46476

    Michael Guay
    Participant

    <b>WP Plugin Environment or MySLP Profile:</b> Store Locator Plus:4.7.9

    This Info Cached:1499294435
    Network Active:No

    WordPress Version:4.7.5
    PHP Version:5.5.9-1ubuntu4.21
    MySQL Version:5.5.55

    PHP Limit:256M
    WordPress General Limit:40M
    WordPress Admin Limit:256M
    PHP Peak RAM:25 MB
    PHP Post Max Size:64M

    <span style=”color: #333333; font-family: Georgia, ‘Times New Roman’, ‘Bitstream Charter’, Times, serif; font-size: 16px;”>Hi,</span>

    I am a WP developer working on this client’s site, and I am using your great plugin. They have one request and I am not sure why the plugin isn’t performing like it should.

    They have 53 store locations on the east and west coast of the US. Now, before the user searches anything (on map load), we want the map to display all 53 locations (east and west coast). The only way to do this is to up the map radius to 25000, as the plugin suggests.

    The problem is, that when we up the map radius to 25000, it becomes uncentered and zooms out WAY to much, with a view of the entire US. We want the map centered on Boston, Massachusetts while still displaying all locations in the US.

    Thanks,

    Michael

    #46481

    Cici
    Keymaster

    1)) See under Center Map at under Settings/Map. In the box center map at just type in Boston MA

    2) check your map zoom levels.

    3) You can also add the shortcode on the locator page such as this [SLPLUS center_map_at="Boston ,MA" radius="50"]

    See my examples

    Under results check your settings do you want locations to display immediately or after search? (you may want the Experience add-on to fine tune or add more defined settings) See documentation for Experience add-on

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.