Store Locator Plus for WordPress Forums Premier Support Locations showing at startup despite being turned off

Tagged: , ,

This topic contains 9 replies, has 2 voices, and was last updated by  Cici 2 years, 4 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #39716

    Rob
    Participant

    Hey there,

    I recently updated to the most recent version of all of the SLP plugins and migrated my staging site to the live VPS server. It was then that I noticed that the map will automatically show locations around the Long/Lat that the map centers on (the center of the US). I’ve checked the setting “Show Locations at Startup” but it’s unchecked. I’ve tried toggling it on and off thinking it might have been a data issue from the migration, but nothing works.

    The “Disable Initial Directory” option worked to prevent the results from populating underneath the map, but the markers still show up and the map will then auto-zoom on these results. I’ve attached an image of my plugin environment. Any thoughts on why these locations are loading regardless of the option set on the backend? Thank you in advance for your help.

    The link to my locator page is: http://biggreenegg.com/find-a-dealer/

    Attachments:
    You must be logged in to view attached files.
    #39724

    Cici
    Keymaster

    Hi Rob,

    So it was working on your dev site but when you migrated it it didnt work the way it did before?

    Well one thing I noticed immediately when I loaded your site: is it is saying SLp did not send a Valid JSONP response., that indicates you have something wrong that will mess up especially the Results ordered by settings (see Troubleshooting section under AJAX blocked)

    Invalid JSON responses means the site you migrated to either has broken/outdated JavaScript or an issue with the WP AJAX processor.
    The error message is coming from your theme possibly… http://biggreenegg.com/find-a-dealer/jquery
    If you forced jquery and didnt follow the WP best Practices it can cause some issues that will create havoc display an the results ordering, map etc.
    You may know right where to look, if not try debugger:

    Here is some info from WP on the jquery best practices.

    I just checked out the settings and how they save on my site and it is behaving properly.

    Some notes:
    Your zoom level is set at 4 that is very close to the center map at… which default if you have chosen US Google map domain, is the center of the US.

    Looking at your site with a quick inspect I am seeing that you have order by Features Ranked, distance. options[featured_location_display_type]:show_within_radius

    But you have Always show featured if within Radius…so it will always show the featured around the center map at and the zoom is going to be very tight around the middle of kansas or wherever Google thinks the center of the US is.

    #39824

    Rob
    Participant

    Hey there,

    Sorry to just now be getting back to you. Thank you for your response. I checked into the JSON request issue using the method described in the “AJAX blocked” portion of the Troubleshooting page, but it looks like everything is OK. I used this link here to check my JSON request and it doesn’t return an error or anything that I can see. The website is an exact duplicate of the version on the staging site, just on a new server (which we’ve setup as a VPS). The staging site is on a shared server. You can click here for a link to the staging site if you’d like to take a closer look.

    I’m getting this error in the console on the live site but not the staging site: “Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience”. Any thoughts on if this error might be the culprit?

    I’ve also gone ahead and adjusted the order option for the site to not use Featured to order the results. This shouldn’t have been much of an issue anyway since we don’t have any locations marked as “Featured”.

    Thanks again for your help.

    #39827

    Cici
    Keymaster

    Rob,

    The” invalid JSON response”  could have been as a result of a combination of settings under Experience  (involving radius) that may effect a handful of people, The developer was troubleshooting  for a client and found a bug that could cause this in some instances but only with a few combos of settings. He thinks he fixed that in the  SLP pre-release 4.4.31. If you want to download that and see if it addresses that issue it would be great. (Testing is best done  on your staging or dev site not the live production site)

    As far as the message “Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience”.  

    That is not something generated from SLP.  SLP uses the built in jQuery method to build AJAX calls, not a custom method. So something that was built in (custom build?) on your site is breaking it.

    you can look up that error message like I did for more info…below link is one of many  and there are suggestions out there for fixes. One is to check the versions of jquery that other plugins or your theme is using.

    http://www.aspsnippets.com/Articles/jQuery-Synchronous-XMLHttpRequest-on-the-main-thread-is-deprecated.aspx

    Not sure if everything else on your site has been resolved. Let me know if it isn’t or if you see a new issue.  Did the disable intial directory stay set for instance? It works for me…

     

    #39828

    Cici
    Keymaster

    Hey Rib, Yep I am looking at the live site and you are getting the SLP did not send back a valid JSONP response, so try the SLP pre release 4.4.31. The Production “live site” is backed up to a staging site right?

    If you don’t want to try it on live site…It should be published soon, undergoing some testing because there was a lot of other code updates included in 4.4.31 (not  associated with JSONP response)

     

    #39831

    Rob
    Participant

    I appreciate the response. It’s just odd that the error was occurring despite all of the settings being the same from the staging site to the live site. I’m not sure if testing the pre-release on the staging site would be that helpful since I’m not receiving that error on the staging site. I might just have to keep an eye out for the next release of the main plugin.

    As far as the message, I had tried looking it up as well but know that I’m not adjusting the async settings anywhere in my code. I am using W3 Total Cache to cache/minify my pages and resources, so that could potentially be causing some issues by blocking the loading of certain scripts. I’ll update this thread if I discover what the root of the problem is or after an update comes to the plugin that fixes the issue.

    Thanks again for all your help.

    #39836

    Cici
    Keymaster

    That sounds good.  I agree it does sound odd if all the versions are updated to the same degree and you aren’t having AJAX blocked on the live site. If it isn’t resolved after the 4.4.31 update than I will ask Lance to delve into it when he has a moment.

    #39854

    Cici
    Keymaster

    Rob can you send an admin login to Lance to help you out, send it to support@storelocatorplus.com

     

     

    #39877

    Rob
    Participant

    Hey there,

    Fortunately I think I might have resolved the issue through a happy accident. I had gone into the wp_options table in the database to search for some instances of the old file path from the staging site that I had noticed were messing up the backup plugin I have on the site. One of the db fields that came up as still having a file path from the staging site was ‘csl-slplus-options_nojs’. I went in an updated the file path using the path of my new installation and it worked. I can’t confirm that this was the right solution as I did have to go in and reset several of the options under the Experience tab since it switched my theme from the custom one I’m using back to the default theme.

    The moral of the story is that it now works! haha Thank you again for your help and support.

    #39886

    Cici
    Keymaster

    That is great Rob,,,,by the way SLP 4.4.34 fixes the JSON issue and is out and published. While testing (that is why it is now 4.4.34) I found an error in how Enhanced Search was not keeping the radius box selectors checked or unchecked. So perhaps what you found was similar to that and it just didn’t clear out when you updated to EXP. Anyway it is also fixed in 4.4.34, so update would be good for you now.

    Lance looked at your sites as well, I was going to write to you earlier but got tied up with the new releases. He said

    slpexperience_settings on the STAGING site has immediately_show_locations = “0″

    slpexperience_settings on the LIVE site has immediately_show_locations = “1″

    You can see it in Firebug the same way you can look at SLPLUS stuff.
    So it sounds like that slp_options had to be cleared, perhaps it was leftover as you mentioned form the custom theme?
    Anyhow, I have let Lance know you fixed it and he has the link to this post if he has any questions.

    Thanks for letting us know that it is working now and let is=us knoow if any new issues. I will be closing this forum post ok? 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Locations showing at startup despite being turned off’ is closed to new replies.