Store Locator Plus for WordPress Forums Store Locator Plus Locations disappear if I do not answer browser location pop-up

This topic contains 14 replies, has 2 voices, and was last updated by  Cici 1 week, 3 days ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #65526

    andrew8
    Participant

    I upgraded to the newest version and when I load the map it shows all locations and then the browser pop-up shows asking allow location or do not allow.

    If I do nothing all locations disappear and if I click on the list it says the following message

    <span style=”color: #0a0a0a; font-family: Roboto, sans-serif; background-color: #f5f5f5;”>Could not locate this address. Please try a different location.
    </span>API keys with referer restrictions cannot be used with this API.

    If I click on allow it works, and I believe if I click on block it still works. This appears to be in firefox, brave, and chrome

    I read a post this post
    https://www.storelocatorplus.com/tag/location-sensor/
    and ours was unchecked. I checked it clicked save and the unchecked it and clicked save. Still getting popup.

    Is this supposed to function like this after your latest update?

    Attachments:
    You must be logged in to view attached files.
    #65530

    Cici
    Keymaster

    If you see a message about anything to do with API restrictions that is google. I believe we had answered a few similar questions last year in the forums about this and the developer wrote a few articles such as this one.
    If Google says you cant use restrictors with your API key, click on their message and it will redirect you
    The error message I see on your site when I click on Allow and search is this
    Uncaught ReferenceError: GambitSmoothScroll is not defined
    at (index):4

    And that is under your locations index. I would clean up that error if you can since you have a lot of customization going on.

    You might also want to use WP debugger to see if any errors are coming from your theme , another plugin or SLP. We do not see any errors related to WPSLP
    When I open the window and DO NOT allow access, I see the warning not to share credit card info etc. Maybe Google Chrome has tightened up or is covering their butt by announcing privacy….

    The Do you want this site to allow access has to do with security measures with most browsers now as part of their privacy policies. That has been an auto pop up with Firefox, Avast web browsers and many others for quite some time. Chrome would block it if you were not running the latest security certificate and HTTPS and not even ask you. Apparently they now are asking .
    Location sensor talks to Google and as the article suggests it shows locations nearest you. I do not know where you are in relation to the sites locations so I am not sure how to guide you. There are no locations near me and you do not have the radius dropdown so i cant change radius

    Attachments:
    You must be logged in to view attached files.
    #65541

    andrew8
    Participant

    that is not our website. I attached the server info file so that you could see the details.

    The site works if we click allow or block that is from all browser prompts but if we do not make a selection all icons disappear. This did not happen prior to the update.

    The website is https://www.racewaycarwash.com/locations/

     

    #65840

    Cici
    Keymaster

    If you are using Location sensor, then the pop up window will always ask the customer to allow locations. This is a privacy issue.
    Also you have an error on that site.

    Uncaught ReferenceError: GambitSmoothScroll is not defined
    at (index):4

    Since you have a customized solution we cannot recreate your issue. You have no where to enter a zip code, you have drop down menus with unique widgets below in info and above and you have the search widget in multiple areas with multiple choices. If you believe there is an error in the set-up, please use the WP debugger and provide the error log pertaining to SLP via email.

    #65907

    andrew8
    Participant

    The error code doesn’t seem to be the source of the issue like you thought. Now that there is not an error on the page will you support the product and help get to the issue at hand.

    Again, I have all options unchecked for the SLP > General > User Interface (this means not using use location sensor)

    I have SLP > Settings > Map > At Startup
    Center Map At: United States
    Center Latitude Fallback: 37.09024
    Center Longitude Fallback: -95.712891

    If you load the page and do not make a selection about your location (which I thought that was the location sensor which is not checked) shows all icons and if you wait about 5 seconds they all disappear and then you get a slp.core.min error that says
    Google JavaScript API geocoder failed with status REQUEST_DENIED results 0 then it removes all icons.

    BUT, If you choose allow or deny for the location popup it keeps all the locations without the slp.core.min error.

    This was not happening until the most recent update was done.

    The search option is disabled because it defaults with all location. The filter services are just category options.

    attached is the debug log that you requested

     

    #65908

    andrew8
    Participant

    One thing to note:

    If you choose “block” for the browser location popup the console still shows the slp_core.min error
    Google JavaScript API geocoder failed with status REQUEST_DENIED results 0

    But it DOES NOT remove the locations, just shows same error.

    So if you make no choice you get the same error but locations disappear.

    Attachments:
    You must be logged in to view attached files.
    #65917

    Cici
    Keymaster

    Andrew, If you look at your debug log, all the issues point to the Bridge theme and plugin and PHP  undefined, there is not one that I can see that shows any errors for SLP.  Normally I would suggest you go with the paid support but since there are no errors for SLP , the developer would probably point you in the direction of contacting the theme developer or plugin.   If yiou need him to troubleshoot he will be back on Friday or Sat after the hurricane has passed.

    When I visit your site I do not see any issues….and under the SLP plugin you have Rocket lazy load which is customized js but it is loading.

    there is NO search form for me to add an address, only categories so I do not  know how I can recreate your issue .  I inspected but was “forbidden access” This is above  and beyond the SLP support . you have a ton of customization and I am not sure what you expect to happen when some buttons are checked off. When I did a search and followed the network path I see: http_query: {QUERY_STRING: “”, address: “no address entered”, lat: “37.09024”, lng: “-95.71289100000001”,…}

    response: [,…]

    slp_version: “5.2.8”

    success: true

    type: “search”

    I did not say we would not support the plugin, I only said I could not recreate your issue because I have no set ups at all with your type of customized multi level ways to search by list byt map by category, etc but with no actual address search box.

    did you do a back up that you can restore to  before you updated? If you believe it is simply an update issue, restore and test.

    Where are you seeing the Geocode activate request denied?

     

    #65918

    Cici
    Keymaster

    Please note that the developer will tell you to back up and if you need him to log in and troubleshoot your site that is a paid support option so I would suggest you restore  to your back-up.  also check the PHP , javascript issues mentioned in troubleshooting , that may help you . I do not see your plugin environment so do not see what versions  of PHP you are using

    On your test site or any site, save and back up first, try a WP theme , try turning off other plug-ins, suggest the Bridge. If you migrated JavaScript make sure all the  WP tables were migrated.

    What is this? //# sourceMappingURL=lazyload.min.js.map

     

     

    #65925

    andrew8
    Participant

    would it help you if I made a video showing you what is happening, so you can see what I am saying?

    #65926

    Cici
    Keymaster

    Not really, that is outside of my purview for support, when the developer is back in town, if you choose a paid support option we may be able to get him engaged but for in depth troubleshooting the ticket is high. For email support, please note there is no same day option since we are in the middle of a hurricane evacuation and expect to lose power. As mentioned in previous replies your site is highly customized so it could be a plethora of conflicts but the most likely is your theme. Did you restore to a back-up and try that?

    #65927

    andrew8
    Participant

    I have a ticket in with the theme vendor, but am pretty sure that the problem is not there. Again this happened after the last update. If I disable the wp rocket it still does it.

    #65980

    Cici
    Keymaster

    You can restore your back up then…you did do a back up before updating anything correct?

    #66035

    andrew8
    Participant

    Hope you guys are safe from the storm.

    Yes I have a backup, and I am thinking about restoring it on a different sub-domain so the live data is not affected.

    As I figured here is the response from the theme vendor

    These are just notices, not errors and they are not harmful for your website. They are used for development environment only, to see what’s going on in the back-end. You can ignore them. They should be disabled on live server environment as explained in the article:

    https://aristath.github.io/blog/wp-hide-php-errors

    Again, not to sound like a broken record, this didn’t happen until the most recent update and everywhere I look it seems like it is not doing what it is suppose to be doing with the on/off option.

    https://docs.storelocatorplus.com/blog/location-sensor/says it can be turned on or off and it doesn’t work without ssl.

    If set to off

    • the permissions still popup. (I thought it should not do this, am I wrong?)
    • if nothing is done the icons disappear.
    • If I click block the icons stay showing
    • If I click allow the icons stay showing

    If I turn on the option

    • the permissions still popup.
    • If I do nothing they stay showing.
    • If I click block they disappear.
    • if I click allow they stay

    Your sites say that the sensor can be turned on or off.  This used to work. This does not seem to be the case after this last update. It was working correctly before this. All other plugins are up-to-date. WordPress is up-to-date, browsers are up-to-date.

    Some possibilities that were suggested

    • it was due to the https not existing.
    • the the site had errors.
    • it was wp rocket
    • Showed logs  and only notices existed
    • theme vendor confirmed these should not have an affect.
    • After fixing all of the above, it was suggested that our site was too custom.
    • the console shows the same details in both scenerios

    How much is a support ticket and what type of response can we expect?
    If they find it to be a bug are we still on the hook for the money?
    If it is just an order of operations being called are we still on the hook for the money?
    What is the process working with support on this? What access do they need to have?

    We do not have a problem paying for custom support, but if the end result is just something simple that changed with the script, I do not think that is right. Especially when we paid the one time setup fee and and yearly subscription.

    • This reply was modified 1 week, 5 days ago by  andrew8.
    #66106

    Cici
    Keymaster

    Andrew, Spoke to the developer. Since your update did not correct the location sensor issue as intended, which was fixed with the last update with SLP and Power, we started thinkibng of other things to ty firt.
    Did you flush your caching/
    You may need to manually clear the WordPress cache that relates to WordPressor plugin updates. Specifically, whenever plugin and theme updates occur, you should purge the cache afterward to ensure that any changes made to the code, files, or the outward appearance of the website go into effect on the next HTTPS request.
    Since you are using lazy load, the scripts in the updates may not have loaded in the correct order. The developer says that can be a big reason why the update did not work properly for you.

    To answer your question about support.
    1) if it is a bug within the SLP plugin and not a conflict with your configuration, your load process or another plugin then you are reimbursed.
    2) the reason for so many suggestions, each site is unique. And each site set-up and configuration is unique. There are thousands of combinations so it is not one answer fits all. As you know over the years the WPSLP plugin and add-ons have more features and are more complex.
    3) The most expensive Log in support by the developer is the most costly. Because he would need to have access to your backend , you would need to have a full back up of your site and you would need to give him sign in admin privileges, he will NOT change your configuration, nor fix your themes, nor fix your other plug-ins nor settings, he troubleshoots and tells you what the problem is. As mentioned there are so many other products and plugins and themes and things like WP Rocket and lazy load of assets and caching all play a part in your particular site update process.

    If you flush the caching, and that doesnt fix it. Turn off the WP Rocket lazy lpoad and update the SLP and Power plugin manually.

    If these do not help you can email support and when the developer has time next week he will use the browser inspect tool and will be more explicit, he is knowledgeable about all sorts of other things that I may not be able to think of..

    Since you are using premier, you may want to also request access to SLACK via email. he will only add a contact who is technical and understands basics of javascript, he isnt always on SLACK but that is another way to reach him when he is working on SLP.

    #66107

    Cici
    Keymaster

    I just noticed the first screen shot you provided shows this :This Info Cached:1557439858

    And now I visited your site (now shows the https://www.racewaycarwash.com/wp-content/cache/busting/1/wp-content/plugins/store-locator-le/js/slp_core.min-1567088649.js
    which is the current version..) and no location sensor pop up

    Did yoiu figure it out already and clear the cache? Or did it clear itself?

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.