Store Locator Plus for WordPress Forums Premier Support Links not working on plugin settings?

This topic contains 3 replies, has 2 voices, and was last updated by  Cici 1 month, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #56988

    Shaun
    Participant

    Hi, I just updated SLP and the Power plugin. When updating Power and reactivating it I have to go back into my settings to set the location sensor. However, when I go into SLP plugin I cannot change anything. The links seem to be inactive and not working. Caching issue? Plugin compatibility issue? Is there an easy work around?

    I tried deactivating and reactivating plugins. That doesn’t seem to fix it. SLP works fine alone but adding Power breaks the links in dashboard.

    WP 4.9.7
    SLP 4.9.16
    Power 4.9.15

    #56990

    Cici
    Keymaster

    Are you using Smush it? A few users reported that Smush it broke areas of the back end of SLP admin panel because of the way it was compressing.

    f you could provide a screenshot of your plugin environment or if you could use the Debugger in WP to find any conflicts and post the debug log that would be helpful.

    Do you have a Google APi key? Google had a drop dead date of yesterday to add a Google API key and biling account. That shouldnt break the back end unless you added Protocol referrer restriction and then forgot to also obtain a geocoding key. We have published quite a few articles and documentation about that subject.

    https://docs.storelocatorplus.com/blog/google-geocoding-browser-keys/

    I

    #57042

    Cici
    Keymaster

    Hi Shaun,

    Are you referring to the text and links under results that indicate “website” If so that was fixed with SLP 4.9.18. If you are referring to the back-end, you might want to refer to the News posts the developer wrote about the Manual vs auto updates process here. 

    is this your site?
    https://gueriniusa.com/

    if so, you are receiving errors in the browser console that need to be addressed.  It appears that there may be some other plug-ins or theme that are breaking There is also a  no Google API key warnings on one of the pages.

    If that isnt the site you are referring to, apologies, without your site url or additional information I can not  help you troubleshoot. You can refer to the troubleshooting guide for additional suggestions.

    #57396

    Cici
    Keymaster

    Under the cesar site you are still showing the warnings which will become  errors soon as soon as google catches up with all the sites using the MAPS javascript APIS. No more freebies

    .
    ALso it appears there is another plugin or theme also using the Google API. The message that says sensor not required is not coming from SLP and usually indicates to us that another plugin or the theme also has google MAPS built into the core somewhere:

    jquery.js?ver=1.12.4:4 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.
    send @ jquery.js?ver=1.12.4:4
    util.js:223 Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys
    Ww.j @ util.js:223
    util.js:223 Google Maps JavaScript API warning: SensorNotRequired https://developers.google.com/maps/documentation/javascript/error-messages#sensor-not-required
    Ww.j @ util.js:223

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.