Store Locator Plus for WordPress Forums Store Locator Plus Google JavaScript API geocoder failed

This topic contains 1 reply, has 2 voices, and was last updated by  Cici 3 weeks, 5 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #59144

    dev6
    Participant

    Store Locator Plus®:5.0.1
    Site URL:https://www.sloggers.com.au
    This Info Cached:1556273216
    Network Active:No
    WordPress Version:5.1.1
    PHP Version:7.2.17-1+ubuntu18.04.1+deb.sury.org+3
    MySQL Version:5.7.25
    PHP Limit:512M
    WordPress General Limit:40M
    WordPress Admin Limit:512M
    PHP Peak RAM:64 MB
    PHP Post Max Size:100M

    URL: https://www.sloggers.com.au/store-finder/

    Steps To Replicate Issue: Search “Black Rock, Victoria”
    Errors: Google JavaScript API geocoder failed with status ZERO_RESULTS results 0

    Details:
    We tried searching for different suburbs/state within Australia ex. “bordertown victoria” and the pin/marker will show a result. But when we tried searching for “Black Rock Victoria” we are getting this error “Google JavaScript API geocoder failed with status ZERO_RESULTS results 0”

    Attachments:
    You must be logged in to view attached files.
    #59147

    Cici
    Keymaster

     

    There are numerous articles and documentation  about setting up your Google API.  I do not see that error when visiting your site so cant be sure if that is your issue.  But also you  should update to SLP version 5.0.5  ( See changelog here under development, that was fixed in version 5.04)  That may fix the issue, there was an issue  with Map regions /domains not saving and defaulting to the US, make sure you have selected Australia for your  Map domain under the Settings/Map  functionality

    I went to your site and nothing as far as Google geocoding  came back when searching that suburb.

    BUT

    What i do see is this error

    Mixed ContentThe page at ‘https://www.sloggers.com.au/store-finder/‘ was loaded over HTTPS, but requested an insecure favicon ‘http://sloggers.wpengine.com/wp-content/uploads/2015/03/favicon.jpg‘. This request has been blocked; the content must be served over HTTPS.

     

    And that can on  cause the Google API to hiccup.   See Mixed Content info 

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘Google JavaScript API geocoder failed’ is closed to new replies.