Store Locator Plus for WordPress Forums Store Locator Plus Glitch in which locations load

This topic contains 3 replies, has 2 voices, and was last updated by  Cici 2 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #41797


    I have “show locations at start enabled” – this has worked fine historically.

    However recently I installed a plugin called Anspress (

    There seems to be some sort of confilict as now, only 4 locations appear on startup (out of 60+)

    If I temporarily disabled Anspress, then SLP works as normal again.

    Otherwsie everything works fine with SLP.

    I can’t see any common connection as to ‘why these 4’ show up and not others.

    This is the page in action –

    ANy ideas to resolve this would be gratefully recieved!


    Plugin environment
    <div class=”left_side”>
    <div class=”content_pad”>
    <p class=”envinfo”><span class=”label”>Store Locator Plus:</span>4.5.06</p>
    <p class=”envinfo”><span class=”label”>This Info Cached:</span>1467015653</p>
    <p class=”envinfo”><span class=”label”>WordPress Version:</span>4.5.3</p>
    <p class=”envinfo”><span class=”label”>Network Active:</span>No</p>
    <p class=”envinfo”><span class=”label”>Site URL:</span></p&gt;
    <p class=”envinfo”><span class=”label”>MySQL Version:</span>5.6.28</p>
    <p class=”envinfo”><span class=”label”>PHP Version:</span>5.6.22</p>
    <p class=”envinfo”><span class=”label”>PHP Limit:</span>256M</p>
    <p class=”envinfo”><span class=”label”>WordPress General Limit:</span>128M</p>
    <p class=”envinfo”><span class=”label”>WordPress Admin Limit:</span>256M</p>
    <p class=”envinfo”><span class=”label”>PHP Peak RAM:</span>97 MB</p>
    <p class=”envinfo”><span class=”label”>PHP Post Max Size:</span>128M</p>



    Go to your site, open in browser, use Inspect tools..look at your  console and here is your issue”

    Uncaught Error: Syntax error, unrecognized expression: ‰PNG



    jquery.js?ver=1.12.4:4 Uncaught Error: Syntax error, unrecognized expression: ‰PNG

    IHDR(pæ oPLTEÿss\))

    Y((e35e45q>@}GK~HLŠQU–X]£_d¯ej¼joÈnrÔptáruísuùstústÿssº¢ºïtRNS/?O_oŸ¿ÏßïõÏziÏIDAT(ύ“ë‚ …-3ËÄPóŠä¾ÿ3ÆÅ%Yíüä[†Ýåœ øW1¡®HìàB‚+Y¬ È/VdÅ)lÅ6¼­› @Ôuïå•jëƒî®÷piúnsjÊ0nåãÀÞøx·péí¿Z_÷ð)·˜#óƒ08Ÿ0æP|~ã£çwsáý¿£ÿ?òòc3˜–ë?­t´¼¼ø-|kíŠÄâai° ^„fäÞ)<ð EdvÞ ÙÞñ^žî†ôJC÷à ‡Y5¶—è;œIEND®B`‚

    util.js:211 G

    It  is broken and not in EnglisH AND FULL OF SPECIAL CHARACTERS…, they need to fix it.

    ERRORS ARE bright red , you need to fix it

    See Troubleshooting and tutorial videos on debugging

    Also you have an invalid key:

    Google Maps API warning: InvalidKey

    See our recent INFO and NEWS blog about this

    Google requires all new site domains to obtain the API key (as of June 22 2016)








    Coming back to this. THey say “No, its not AnsPress. And AnsPress have no JS code which is related to PNG etc. See the console log its not AnsPress but their plugin.” And quote…

    Cross-Origin Request Blocked: The Same Origin Policy disallows
    reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

    Error: Syntax error, unrecognized expression: �PNG

    You’ll have to forgive me, I’m not familar with using the console to debug, and understand it’s messages, so am a bit in the dark here & frustrating to have come back to you…



    Please provide a screenshot of Your Plugin Environment, you have more than just the SLP base plugin when I view your site.

    And I have no idea how you are getting the drop down menu with a list to select from unless you have either ProPack, tagalong, or the Power add-on. How are you creating the list with the dropdown menu? as well.

    1) Yet when you disable Anspress the Store Locator Plus works the way you expect it to. Are they also your theme provider?  We cant tell you how many times we hear this from the theme developers…it isn’t us its you. It is easy to figure out.

    2) Turn off Plugins one by one, change theme to a standard WP theme and see how your results display.  Also when I loaded your site and selected “any” and default of 50 miles  many many markers showed up.   Have you tried changing your results settings to display more and a larger radius?

    3) What are your settings under Experience , i.e. under search, under results?  Do you have show 50 and radius 10000 under the results settings in your UI?   As far as search, Do you have only load  after selection made?

    4) Error message about png. that is a media format and there shouldn’t be a symbol in front of it. Where did you obtain those markers? We do not have heart markers like that so assume you must have them residing somewhere else or it was from an old icon set. You can load the icons into the WP Media area under Tagalong  and use that URL instead.  As mentioned I do not know if you were using,  tagalong or ProPAck and/or  what version

    There is something strange and a conflict somewhere because I see this error message:

    ‘//@ sourceURL’ and ‘//@ sourceMappingURL’ are deprecated, please use ‘//# sourceURL=’ and ‘//# sourceMappingURL=’ instead   .

    If you need someone from support or the developer to log onto your site as an admin to do Troubleshooting  that is through Paid Support.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.