Store Locator Plus for WordPress Forums Store Locator Plus Filtering by categories does not work

This topic contains 9 replies, has 2 voices, and was last updated by  Cici 5 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #56624

    Michael
    Participant

    I keep trying to post to this forum but it outputs no errors… do posts have to be approved by an admin? Any notification would be awesome.

    Seeing as my “test” post went through but not the one I actually need I won’t post any shortcodes or websites, because it may break your form?

    So I’ve been using this plugin and the shortcode doesn’t work properly. I am trying to display only locations from a certain category but that part of the shortcode gets ignored completely.

    Please advise, as I don’t know if this form works properly.

    Thanks…

    #56628

    Michael
    Participant

    Running on fusionmineralpaint dotcom /where-to-buy/online-retailers/

    [slplus only_with_category=”online-retailers”] — online-retailers being the slug of the category

    #56629

    Cici
    Keymaster

    Please read posting guidelines, we need your plugin environment

    #56652

    Michael
    Participant

    As I stated before, I tried to upload pictures and add the necessary urls but those posts went into the unknown, without any error or feedback.

    Hopefully this time the image will get attached. Here it is.

    Attachments:
    You must be logged in to view attached files.
    #56654

    Cici
    Keymaster

    I will test the only with categories, thank you for providing all the info. And I will get back to you as soon as I have tested

    #56655

    Cici
    Keymaster

    Could you also let me know which Plugin style you are using? is it a Gallery style and if so which one?. I just checked my site, I have added a shortcode

     

    [SLPLUS only_with_category=”entertainment”]

     

    i disabled the intital directory. When I first searched within 10 miles no results, I checked my locations again and found that my locations marked as entertainment category  were 100 miles away , using the drop down miles I selected 500 miles and searched again. All the locations within 500 miles marked as entertainment appeared, no other categories appeared.  The Plug-in style I tested was  default Store Locator Plus layout.   This is the basic layout for the locator.  It allows default browser and website themes to dictate the element styling.

    I am conducting further tests though….I am having a problem with an old category I had that was a child category and then changed it, it had hyphenated slug.  I will test it with the new Power and SLP beta release as well as soon as it is available.

    #56656

    Cici
    Keymaster

    If you have Premier as it appears you do, you can post in the Premier forum and will receive faster response

    #56657

    Cici
    Keymaster

    Looking at your site, I cannot tell which widget I should be looking at to find the only with category page. Could you provide specific url, you can post in the premier forum and if we cannot resolve the developer can look at the specific page url.

    #56665

    Michael
    Participant

    Hi! So I am using the “A Gallery Style”, but that’s the only option in the dropdown.
    Please see attached screenshot.

    Also, we are using these plugins (all activated):
    Store Locator Plus – Experience
    Store Locator Plus – Power
    Store Locator Plus – Premier

    Disclaimer: I am a new developer trying to clean up this website, I wasn’t here when all the decisions were made…

    Should I deactivate any of them? From what I read they compliment eachother, adding features.

    Thank you so much.

    Attachments:
    You must be logged in to view attached files.
    #56667

    Cici
    Keymaster

    Check your Google API key for restrictions and/or referrers. I now have tested the only_with_category shortcode and all is working correctly. I had to ensure i had a google API key for geocoding correct and all is working now.

    Do you have a staging site where you can clean up the site or to do your testing on?

    when I inspect that site using the browser tools I do not see any fatal errors but I do see these warnings:

    (index):686 A parser-blocking, cross site (i.e. different eTLD+1) script, https://widgets.shopifyapps.com/assets/widgets/embed/client.js, is invoked via document.write. The network request for this script MAY be blocked by the browser in this or a future page load due to poor network connectivity. If blocked in this page load, it will be confirmed in a subsequent console message. See https://www.chromestatus.com/feature/5718547946799104 for more details.
    (anonymous) @ (index):686
    client.js:4 [ShopifyBuy] Config property apiKey is deprecated as of v1.0, please use storefrontAccessToken instead.
    (anonymous) @ client.js:4

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.