Store Locator Plus for WordPress Forums Store Locator Plus Email Addresses do not appear in info bubble results

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #81668
    Joseph
    Participant

    We have responded to this thread TWICE now and our responses keep disappearing. What is going on???

    We have stripped the site down to the latest plugin, Twenty-Twenty-One. There is no “email” div in the info bubble. So it is not being hidden; it just simply is not showing up.

    All listings should have email addresses. Try 60540 and the result Bob Barc if you want one definitely with email.

    Demo site:

    https://illeopsstaging.wpengine.com/peer-supporters/

    Plugin environment:
    Store Locator Plus®:5.7

    Power:5.5.8

    Site URL:https://illeopsstaging.wpengine.com

    This Info Cached:1618409414

    Network Active:No

    WordPress Version:5.6

    PHP Version:7.4.16

    MySQL Version:5.7.32

    PHP Limit:512M

    WordPress General Limit:40M

    WordPress Admin Limit:512M

    PHP Peak RAM:22 MB

    PHP Post Max Size:100M

    #81670
    Cici
    Keymaster

    I cannot replicate what you are describing. The emails show up in any that have them in my test site.

    See screenshot, I added Bob Barc with a zip code and an email address that I made up and it shows up exactly as intended

    Use developer tools and inspect your site to see if. you have errors, I do not know how you have your site set up.  You can also use the Debugger to see if there are conflicts.

     

    If you have Power add-on have you Enabled contacts? 

    That will have additional fields under results

    If you are referring to the map info Bubble

    Seee

    https://docs.storelocatorplus.com/map-info-bubble/

    https://docs.storelocatorplus.com/results-layout-shortcodes-and-attributes/

     

    If you need to change layouts use the Experience add-on.  It appears you are using Peoples names instead of stores and I do not see addresses in your url site.

     

    • This reply was modified 3 weeks ago by Cici.
    Attachments:
    You must be logged in to view attached files.
    #81675
    Joseph
    Participant

    We do not have the People add-on. We have the Power Pack. And if there is an email added, it should show up. But as you can see, it is not appearing.

    Can we provide you with a login to look around?

    #81678
    Cici
    Keymaster

    There is No “Peoples add-on”. It was meant to read as  “instead of a store name you have an. individual(persons) name”

    We were referring to  if you should consider as part of the Power add-on to enable contact included with the Power add-on that you already have

    We do not log-into a users WPSLP Do it yourself sites to debug them or to change or write CSS to work with their overall themes.

    Suggest instead you try a different Locator Style, and  clear your cache if or when  you change styles

    When inspecting your site url under that page you have an error. You need to clear this error

    https://illeopsstaging.wpengine.com/wp-json/store-locator-plus/v2/options/bubble_footnote

    {“code”:”invalid_option”,”message”:”Not a valid option slug.”,”data”:null}

    Also when inspecting that site url the element under Bob B, the element for that entry  is inherited from your

    <body class=”page-template-default page page-id-1934 wp-embed-responsive is-light-theme singular has-main-navigation”>

    If you had Experience add-on installed you would be able to adjust the Locator Styling

    See Locator Appearance Layouts

    #81679
    Joseph
    Participant

    So to be clear, you are stating in the documentation that the Email should show up by default.

    But since it’s not (which sounds like a bug) you are suggesting we purchase an add-on to do it another way?

    #81680
    Cici
    Keymaster

    I am suggesting you use the Debugger and see why your set up in the staging is not behaving the same way as everyone else. Check  your configuration and how you have set up your site. If there is a theme overwriting SLP such as mentioned above in the one case you can change the layouts and add css via the Experience add-on.

    Why email is not showing up in your staging site we have no insight since it is appearing on our test sites, as well as our SLP SaaS customers.  Example of someone doing similar to what you are trying to accomplish .   https://www.thecancerspecialist.com/specialist-directory/

    As you can see email shows up in the results after search performed. search zio code 29464 or any.

    They have our Professional Level plan. They are using the “Defaut” gallery style. I can tell what they are using because we have insight as a SaaS provider. For your site we have no such insight into how or  what you are using or how you have set up your site themes etc.  For example if we look at your map info bubble for the person you mention ,  the description goes beyond the bubble space and the photo of the person is too large for the space.  I can inspect your site using any browser and dev and see that you do not have EMAIL  shortcodes for the info bubble.

    I have no idea what layout you are using or your overall theme.

    What I can see by Inspecting

    https://illeopsstaging.wpengine.com/peer-supporters/

    you have error messages

    Uncaught (in promise) TypeError: Cannot read property ‘includes’ of undefined

    at VM6 content.bundle.js:703

    jquery-migrate.min.js?ver=3.3.2:2 JQMIGRATE: Migrate is installed, version 3.3.2

    content.bundle.js:1 observing

    content.js:52311 action frameLoad

    VM6 content.bundle.js:703 Uncaught (in promise) TypeError: Cannot read property ‘includes’ of undefined

    at VM6 content.bundle.js:703

    c

    #81681
    Cici
    Keymaster

    Also this error as mentioned before you have errors.

    Error :Failed to load resource: the server responded with a status of 500 ()

    https://illeopsstaging.wpengine.com/wp-json/store-locator-plus/v2/options/bubble_footnote

    I do not know where that is coming from V2. Go to the SLP account and download a fresh install after backing up your site

    Or export from the  Power add-on.  you can export and check the columns  in the csv fie and then import on a fresh install.

     

     

    #81682
    Cici
    Keymaster

    Another suggestion: Try a different WP theme not twenty twenty one.

    #81741
    Cici
    Keymaster

    @Caitlin aka joseph

    Your client has allowed the Premier  subscription to expire. Was there a setting in your premier subscription that was impacted by your other updates?

    Suggest you move over to the SLP SaaS platform if you need us to “look around” your various settings. We have more control of what the back end is doing as well as some of the settings. We will not be logging into non-SLP SaaS accounts,

    Thanks

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.