Zoom Level – List Results Immediately

Home Forums Store Locator Plus Zoom Level – List Results Immediately

Tagged: , ,

This topic contains 3 replies, has 3 voices, and was last updated by  Lance Cleveland 3 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #12781

    NEFCO
    Participant

    I’m having a bit of trouble with how far out the maps zooms when I turn on “immediately show listings”. It ends up showing all of the locations two or three times because the entire map just repeats (see NEFCO-Map.png).

    I lowered the radius, but too small and west/east-most locations then don’t show. I made the map wider and narrower and certain widths help, but it is always too far out.

    Is there a way to show all of the locations on the map AND pick a zoom level to be at initially (see NEFCO-Map-2.png)?

    http://nefco.us/?page_id=1340

    • This topic was modified 3 years, 11 months ago by  NEFCO. Reason: Added second image
    Attachments:
    You must be logged in to view attached files.
    #12844

    Lance Cleveland
    Keymaster

    You can use Zoom Adjustment to get the map to not zoom out as far.   How much it can be adjusted is based on Google algorithm that determines how to best bound all the locations you are trying to show, which is the “maximum worldwide view” in  your case which shows the world wrapping on itself (not quite sure why they do that).

     

    #14316

    WriteCraft
    Participant

    I have this same problem when trying to show all locations worldwide: http://kiwigrip.com/where-to-buy-kiwigrip/

    I use enhanced map, enhanced search and enhanced results, as well as tagalong and pro pack.

    This is the short code on the page [SLPLUS center_map_at=”bermuda” initial_radius=”8000″]

    If I make the radius around 3000 miles, the map will show correctly, but only a few of the locations are found.

    User Experience > Results > Radius to Search Initially is 8000, immediately show locations is on

    User Experience > Map > Map Settings >Zoom Level =2, Zoom Adjustment =1, Do Not Auto-zoom is off.

    If I turn Do Not Auto-zoom to on, then the map displays correctly, but my other maps do not, where I do want auto-zoom to zoom in to a region.

    http://kiwigrip.com/where-to-buy-kiwigrip/european-dealers-distributors/

    Any suggestions on how I can get the worldwide map to not over-zoom out?

     

    Is there a way to turn auto-zoom on and off in the short code?

     

    #14766

    Lance Cleveland
    Keymaster

    Great idea – I’ve added shortcode “autozoom” on/off to the Enhanced Map wish list.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.