Store Locator Plus for WordPress Forums Store Locator Plus Tag missing in pro pack

Tagged: ,

This topic contains 12 replies, has 3 voices, and was last updated by  Cici 2 years, 1 month ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #39249

    Lefteris
    Participant

    Hi,

    We are unable to add or modify tags to locations. The tag-field is missing.

    The tags are still available in the overview.

    Store Locator Plus version 4.4.27

    Store Locator Plus Pro Pack: 4.4.02

    cfr screenshots

    We bought the Pro Pack for the tagging-functionality. Hope thuis can be fixed soon.

    thx!

    Attachments:
    You must be logged in to view attached files.
    #39263

    Cici
    Keymaster

    Please provide your Plugin Environment and your site url. Your second screenshot does not show the full page there the Tags would be in the second section under the add or manage locations tab, it is not laid out the same way as it used to be in earlier versions

     

     

    Attachments:
    You must be logged in to view attached files.
    #39272

    Lefteris
    Participant

    Hello,

    Thank you for the quick reply.

    The second section under the add or manage locations tab is missing. cfr screenshot.

    I’ve been searching for a way to make it appear, but without any result.

    website: http://www.mmood.be

    Not sure what you mean with ‘provide Plugin Environment’

    Any idea?

    wordpress version: 4.4.2.

     

    Attachments:
    You must be logged in to view attached files.
    #39274

    Cici
    Keymaster

    Plugin Environment as shown in screenhsot under INFO (see Posting Guidelines) and the url needed is the actual page url for Locator

    #39275

    Cici
    Keymaster

    I do not see Store Locator Plus installed under WP Plugins on that url site link you provided.

    Reviewing your order, it appears you bought ProPack in 2014, I did not see any additional purchases after that time. Were you updating versions as you went along? A sudden jump in versions can create issues. Version 4.1 are not compatible with SLP 4.3 and higher.

    #39277

    Lefteris
    Participant

    OK! Found the Plugin Environment. Screenshot attached.

    one of the page urls: http://www.mmood.be/detail/ovale-tafel-170-cm/

    It is possible that a version jump was made… The client is maintaining the website…

    So what are the next steps? Any idea how to get these tags back?

    Attachments:
    You must be logged in to view attached files.
    #39282

    Cici
    Keymaster

    Try deactivating, Deleting and reinstalling. I will check with the developer, are you on a multilingual site? Did you change themes or anything else recently?

    #39284

    Lefteris
    Participant

    OK. I did some more steps:

    1/ deactivated and deleted both store locator plugins, then downloaded fresh latest versions. Without any results…

    2/ deactivated all other plugins, leaving only both store locator plugins activated: no changes

    3/ switched to default WordPress theme Twenty Sixteen: no result

    Both localhost (older WP version) and production have the same issue. I am using WPML multilanguage, but even when deactivated, I still don’t get to see the tags.

    Out of ideas. Hope development can help quickly.

    thx!

    #39313

    Lance Cleveland
    Keymaster

    The language files for the native translation of the Tagalong tabs , subtabs, and group names (labels on top of the boxes) must be correct and in the translation files (the .po and .mo language files).    Using Loco Translate, using sync, and then filling in any missing translations should fix the issue.

    SLP 4.4.28 with the upcoming Power add-on will eliminate this issue as the settings system will rely on language-agnostic slugs versus actual text translations when rendering the settings screen.

    #39314

    Lefteris
    Participant

    Hi,

    This is what I did for now: I downloaded Loco Translate, synced the po-files (both of Store Locator Plus and Store Locator Plus Pro) and ‘copied’ all the missing items into Dutch (nl_NL). I didn’t translate the missing items, just copied the English string from the original file. Translating them would take too much time.

    After saving both files, I checked again, but still no option to add tags…

    Did I miss something?

     

    #39338

    Cici
    Keymaster

    Are you trying to use it in Dutch or English?
    You must translate it if you want the correct add-on to be found in the language you are using. It cant be in English if you have selected Dutch as the language.

    It has to match EXACTLY with the base language you have set for the site.
    See the INFORMATIoN or
    Video

    If you want to wait for it to be translated for you then that’s fine but it wont be changed in the older versions until a later date, we are concentrating on the newer Add-on Packs such as Power.

    Otherwise translate the top tags such as ProPack and Send the po. mo file to us at info@charlestonsw or to support.

    Example if you bought Tagalong:
    If the word on the top tab changes from “Tagalong” to “tagvitchuem” and the subtab changes from “Dog” to “petodi” when you set your site to Deubagish as the language then ALL the add-on packs must have the same EXACT translation for Tagalong and Dog. If you translate “Tagalong” to “tranvestium” instead then that add-on will not connect the page to the right place and it won’t appear.

    Same thing if you set the translation for “categories” to “categories” in Dutch when it should be something different.

    #39487

    Cici
    Keymaster

    Update to SLP 4.4.30 There is a video explaining some of the issues that were fixed..

    ProPack also has been updated,,,,
    Thank you for your help in finding this issue.

    #40393

    Cici
    Keymaster

    Lance has found some quirks and strings in the base plugin that could effect  ProPack …I am not sure if this would effect you

    He tried running   a test site in Spanish (no translation file for Pro Pack) and the tags section is showing up properly.

    It isn’t out in pre release as yet but when it does come out ,  if you want to help us test it, that would be awesome.   I am not sure if it will be v 4.4.38 or if he is ready to launch 4.5 to stay in sync with the WP updates

    eventually he is hoping to only use the WP translation files instead of the local translations in the SLP .po .mo directories

     

    pre release 

     

     

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Tag missing in pro pack’ is closed to new replies.