Search Not Working Properly.

Home Forums Store Locator Plus Search Not Working Properly.

This topic contains 12 replies, has 3 voices, and was last updated by  Lance Cleveland 3 years, 7 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #18175

    brent
    Participant

    The search is not working properly in my store locator. When you choose San Antonio, TX from the drop-down, it shows no locations. If you search for LAVERNIA, TX which is nearby, the locations from San Antonio, TX show up. If you search for Austin, Tx and many other cities it works. I have noticed its not working with about 10 other cities as well.

    http://margaritatexas.com/store-locator/

    Sore Locator Plus: Version 3.11.23
    ProPack: Version 3.11.004
    Enhanced Map: Version 0.9

    #18177

    Lance Cleveland
    Keymaster

    Read this first:

    /documentation/store-locator-plus/how-slp-search-works/

     

    With SLP 4 there is a new “discreet state search” option.   There is no discreet city or country search (yet) but both are on the wish list for development.

    #18180

    brent
    Participant

    its still not working how its supposed to. If you search, for example, an address in san antonio, lets choose the San Antonio Zoo (3903 N St Mary’s St, San Antonio, TX 78212) no results are found.

    but if you search for an address in nearby Lavernia, 102 E. Chihuahua Street, lavernia, tx (Lavernia city hall) it picks up all of the san antonio locations.

    • This reply was modified 3 years, 7 months ago by  brent.
    • This reply was modified 3 years, 7 months ago by  brent.
    #18190

    brent
    Participant

    Just upgraded to:
    Store Locator Plus Version 4.0.032
    Pro Pack Version 4.0.018

    And the address search is still not working for certain areas, including San Antonio.

    #18193

    brent
    Participant

    Reports are now working:
    I can see when i search for San Antonio that it is returning results in the area but they icons are not showing and it still shows a different areas icons. like they arent refreshing.

    Top 10 Results Returned

    City State Zip Tags Total
    SAN ANTONIO TX 78230 15
    SAN ANTONIO TX 78251 15
    SAN ANTONIO TX 78213 10
    SAN ANTONIO TX 78217 10
    SAN ANTONIO TX 78223 8
    SAN ANTONIO TX 78250 7
    SAN ANTONIO TX 78212 5
    SAN ANTONIO TX 78201 5
    SAN ANTONIO TX 78237 5
    SAN ANTONIO TX 78224 5

    I am also now receiving this message:
    “The create_InputElement method is no longer available.
    It is likely that one of your add-on pack is out of date.”

    I uninstalled and re-installed the plugins

    #18194

    Haris
    Participant

    Most of the time when you enter a full or the street address it gives no results but it works if you enter just the city name or zip code.

    #18196

    brent
    Participant

    I fixed this. it can be closed. I used the Janitor plugin, removed everything and reinstalled. It looks like remnants of 3.x and 4.x were still there even though wordpress was showing both were on 4.x

    #18201

    Haris
    Participant

    Hi Brent,

    I tried it with the Janitor plugin and it’s still not working, in fact I noticed something else.

    If I search for the following address:

    2124 Military Rd Benton , AR 72015 or

    2124 Military Rd Benton , Arkansas 72015

    it gives me no result but when I search for:

    2124 Military Rd Benton , Arizona 72015

    it finds a result but if you look at the map you are in fact in Arkansas and not Arizona.

    #18202

    Haris
    Participant

    Hi Brent,

    Here is the csv of the location if you need it

    Attachments:
    You must be logged in to view attached files.
    #18212

    brent
    Participant

    all of our search results are in Texas so I am not concerned about Arizona or Arkansas at this time.

    #18233

    Lance Cleveland
    Keymaster

    @Haris – you have found a bug in the location algorithm that is dropping locations when the address entered in the search box is EXACTLY THE SAME as the the address of the store in the database.    This has been in the software for years, so I’m surprised it has not been discovered before.    I guess if people have 10 locations in the system they never notice if just one goes missing… but with ONE location it is fairly obvious.

     

    I’ll have this patched in the next release of the base plugin.   Hopefully get that out next week if all goes well.

     

    #18234

    Haris
    Participant

    Thanks Lance

    #18261

    Lance Cleveland
    Keymaster

    SLP 4.0.033 was published tonight and should fix the exact address matches problem.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.