Store Locator Plus for WordPress Forums Store Locator Plus Problem with SLP_BaseClass_Addon?

This topic contains 9 replies, has 2 voices, and was last updated by  Cici 2 years, 7 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #36559


    Just updated a website to the latest versions of Store Locator Plus, SLP Pro and WordPress itself.

    Problem 1: When I try to activate SLP Pro, I get the following error message: Fatal error: Class ‘SLP_BaseClass_Addon’ not found in /homepages/29/d252517728/htdocs/skinfirstdev/skinfirstdevsite/wp-content/plugins/slp-pro/slp-pro.php on line 40

    I’ve tried installing SLP Janitor but get a similar message. The lines referred to in the error messages all revolve around ‘SLP_BaseClass_Addon’. Is there an easy way to update or replace this incorrect or missing bit of code?

    Problem 2:  Store Locator Plus works without SLP Pro but when searching for locations, only one result is ever returned, this is the nearest location to any given town/city/postcode searched for.

    Any help and advice appreciated. This plugin has work flawlessly until today.




    In order to assist you we need more information about your Plugin environment and the versions you are using.

    Please read the Posting Guidelines, it outlines the information needed to be able to answer your questions.

    If you are mixing versions (i.e. SLP 4.3 with add-on pack 4.2) the plugin additions wont work properly.  For more information:





    Store Locator Plus Version:4.3.24


    This Info Cached:1449419738

    WordPress Version:4.3.1

    Site URL:


    MySQL Version:5.1.73

    PHP Version:5.2.17


    PHP Limit:256M

    WordPress General Limit:40M

    WordPress Admin Limit:256M

    PHP Peak RAM:22 MB

    PHP Post Max Size:8M

    PHP Modules:



    [5] => bcmath

    [6] => bz2

    [7] => calendar

    [48] => cgi-fcgi

    [8] => ctype

    [9] => curl

    [0] => date

    [10] => dba

    [11] => dbase

    [12] => dom

    [39] => exif

    [14] => filter

    [15] => ftp

    [16] => gd

    [17] => gettext

    [13] => hash

    [19] => iconv

    [20] => idn

    [33] => imap

    [22] => json

    [1] => libxml

    [23] => mbstring

    [24] => mcrypt

    [25] => mhash

    [26] => mysql

    [37] => mysqli

    [2] => openssl

    [3] => pcre

    [29] => PDO

    [35] => pdo_mysql

    [30] => pdo_sqlite

    [31] => posix

    [32] => Reflection

    [18] => session

    [34] => shmop

    [27] => SimpleXML

    [36] => soap

    [28] => SPL

    [38] => SQLite

    [21] => standard

    [40] => tidy

    [41] => tokenizer

    [42] => wddx

    [43] => xml

    [44] => xmlreader

    [45] => xmlwriter

    [46] => xsl

    [47] => zip

    [4] => zlib




    Store Locator Plus: Version 4.3.24

    Store Locator Plus: Pro Pack: Version 4.3.02

    WordPress: Version 4.3.1



    Hi Quentin,

    I reviewed your site and saw the error messages.” Uncaught TypeError: jQuery(…).on is not a functionputMarkers @ slp.js?ver=4.3.24:577process_ajax_response @ slp.js?ver=4.3.24:873(anonymous function) @ slp.js?ver=4.3.24:1477c.extend.handleSuccess @ jquery.min.js?ver=4.3.1:142w.onreadystatechange @ jquery.min.js?ver=4.3.1:141″

    Normally this indicates that one of your  Plugins (or theme) is forcing an old version of jquery which will render it incompatible and cause all types of issues. Your blog/site theme or one of your plugins uses jQuery or a javascript library versions that is older than 1.3

    Solution:  shut off each plugin until you see your store locator map working again this should narrow down the one that is forcing an old version. If it is your theme, contact the theme author and ask them to fix it.  There are articles and warnings  in WP about this:” WP standards say “don’t EVER enqueue your own personal/specific version of included libraries like jQuery”

    Info article about jquery versions and conflict

    The troubleshooting section in the Store Locator Plus Documentation explains how to identify common issues using the debugging tool. WordPress also has extensive information available at: Debugging in WordPress.

    Also I noticed  you have an error message with a “reference image and you cannot reference images from a different URL.   Browsers see that as a cross-site origin security issue.   You need to load the images from the same domain or reconfigure your server & browsers to allow cross site references…(NOT recommended BTW)



    Thanks for taking the time to look at my problem. I’ve fixed the JQuery issue and the SLP map now returns all the locations within a given radius as expected.

    I still can’t get the ProPack to activate. I’m still getting the “Fatal error: Class ‘SLP_BaseClass_Addon’ not found in /homepages/29/d252517728/htdocs/skinfirstdev/skinfirstdevsite/wp-content/plugins/slp-pro/slp-pro.php on line 40” message.

    Could this be linked to the cross-site images or do I need to look elsewhere to get the ProPack activated and working?



    Hi Quentin, your screen shot of the SLp plugin Environment does not show ProPack. What version are you using?



    Store Locator Plus: Version 4.3.24

    Store Locator Plus: Pro Pack: Version 4.3.02

    WordPress: Version 4.3.1



    The reason the SLp plugin Environment does not show which version of ProPack I’m using is that when I try to activate the ProPack plugin, I get the “Fatal error: Class ‘SLP_BaseClass_Addon’ not found in /homepages/29/d252517728/htdocs/skinfirstdev/skinfirstdevsite/wp-content/plugins/slp-pro/slp-pro.php on line 40” message.

    Basically, I can’t run the ProPack 🙁

    I’m trying to use Store Locator Plus: Pro Pack: Version 4.3.02, which I believe is the latest version and therefore should be compatible with Store Locator Plus: Version 4.3.24.

    I tried deleting the ProPack and re-downloaded from the website but it made no difference.

    I get the same fatal error message when I try to run the Janitor plugin too 🙁



    Hi Quentin,

    I have never seen the error message or it referred to as “Base Class Addon” So I did a little investigating into your account.  Apparently you purchased ProPack in Oct 2013. That was arounf the time that SLP{ and add-ons were being switched with a major version upgrade fro 3 to 4. There were discount copons offered. I cant tell if that would have been you situation or effect you but I noticed that your order had a value in the download access field as 1 only allowing you to download 1 time.  I just added the download again for you, try it again.

    I am confused though as to why you cant download Janitor….so that makes me think there is something else going on.

    If the granted access doesn’t work then I can only suggest  the same answer the developer gave to another customer on a similar issue:

    “You are either running out of disk space or someone changed the permissions on your plugin directory(ies) and it is not allowing the plugin files to be updated.”

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.