Store Locator Plus for WordPress Forums Store Locator Plus Problem with import bulk

This topic contains 8 replies, has 3 voices, and was last updated by  Lance Cleveland 2 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #39464

    Marijn
    Participant

    Dear,

    I found problems with the bulk import of the pro pack. As you can see everything works fine, but in the locations it doesn’t show the name / id and address 1. Rest is fine, and file is named in .CS V. As I just updated the plugin, it still din’t solve the problem. <span style=”box-sizing: border-box; font-weight: bold;”>This is a multi site which are in total 4 sites.</span> Maybe that could be the issue. Address is also right, as it’s been triple checked. And I tried many more addresses.</p>
    <p style=”box-sizing: border-box; margin: 0px 0px 1.618em; color: #60646c; font-family: ‘Helvetica Neue’, sans-serif; font-size: 12px; line-height: 19.416px; background-color: #fbfbfb;”>I attached plugin environment, the problem in the interface and the EXCel. file</p>
    <p style=”box-sizing: border-box; margin: 0px 0px 1.618em; color: #60646c; font-family: ‘Helvetica Neue’, sans-serif; font-size: 12px; line-height: 19.416px; background-color: #fbfbfb;”>Previous post I forgot the environment.</p>
    <p style=”box-sizing: border-box; margin: 0px 0px 1.618em; color: #60646c; font-family: ‘Helvetica Neue’, sans-serif; font-size: 12px; line-height: 19.416px; background-color: #fbfbfb;”></p>
    <p style=”box-sizing: border-box; margin: 0px 0px 1.618em; color: #60646c; font-family: ‘Helvetica Neue’, sans-serif; font-size: 12px; line-height: 19.416px; background-color: #fbfbfb;”>Regards,</p>
    <p style=”box-sizing: border-box; margin: 0px 0px 1.618em; color: #60646c; font-family: ‘Helvetica Neue’, sans-serif; font-size: 12px; line-height: 19.416px; background-color: #fbfbfb;”>Marijn</p>

    Attachments:
    You must be logged in to view attached files.
    #39559

    Cici
    Keymaster

    I don’t know how you got the one star to import but make sure you follow the guidelines and avoid special characters.
    the three star symbol after the first persons name when saved in csv file format appears as

    ???

    That is not being read properly as far as I can see

    #39565

    Marijn
    Participant

    Hi,

    This is still not an answer on my question. I also uploaded the file without the starts. So my question is why does it not show the name/id and adres 1? I can’t deliver my work to my client, which annoyed me because it doesn’t work appropriate.

    Waiting for your response,

    Kind regards,

    Marijn de Jong

    #39575

    Marijn
    Participant

     

    PS: Maybe you can attach a format, because I tried everything you said. Still not working..

     

     

    #39589

    Cici
    Keymaster

    You also did not have the correct slug….As I mentioned…and if you have a special character that cannot be read by UTF8 in your CSV file import WILL BREAK the import

    The sl_id slug is not “Name” (that will be changed to be allowed in the future Power add-on but it is not allowed in your versions of proPack) the name column slug is sl_store. I do not know what youa re checking off in your import column, are you checking off first line has field names, there are little question marks next to the boxes that if clicked on will explain what that box is and also has a link to approved field names,

    I dont know what else to tell you…see the CSV file formatting and data field names documentation and under FAQ

    Attachments:
    You must be logged in to view attached files.
    #39595

    Cici
    Keymaster

    and the field name for the address columns are sl_address
    I understand that it appears you are using a foreign language but unless that field has been translated it will not be recognized as an import field name slug for the SLP plugin. Make sure you are also using the synced version of your language. There is documentation about that and there is also a video on how to do that as well on the SLP youtube channel.

    #39639

    Marijn
    Participant

    The field name fo rthe address coumns are indeed sl_address.. But how ever I disabled the translation of the website. Which will make the plugin all natrual, but still not works. See attachment. It doesn’t reconise the name and adress.. ?!?! Could you explain? See also the attachment of the file that im using.

    Cheers,

    Attachments:
    You must be logged in to view attached files.
    #39663

    Lance Cleveland
    Keymaster

    The CSV file imports with Pro Pack without any issue.

    Your site language settings have no impact on the imports.   The header (field name / first row) of the CSV file is field slugs, which are always English field names (note to self: would be cool to make that multilingual as well.. but so many other things to work on first…)

    [caption id="" align="alignnone" width="432"]Test Environment Test Environment[/caption]

    [caption id="" align="alignnone" width="675"]Test Settings Test Settings[/caption]

    [caption id="" align="alignnone" width="675"]Test Results Test Results[/caption]

    #39664

    Lance Cleveland
    Keymaster

    Curious why you are skipping geocoding when your location file does not contain lat/lng data.  That will load the locations but not show any on the map.  They need to be geocoded to get the lat/long before they will appear on the user-facing part of the maps.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Problem with import bulk’ is closed to new replies.