Map icons not showing on map / Map Only (No Results) / Draft Issues

Home Forums Store Locator Plus Map icons not showing on map / Map Only (No Results) / Draft Issues

This topic contains 5 replies, has 2 voices, and was last updated by  Cici 7 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #44918

    Kaitlyn
    Participant

    I recently upgraded my WordPress and Plugins, to WP 4.7.2, SL 4.7.4, Power 4.7.1, and all sorts of customizations have changed.

    1) Client preferred a “map only” version. There used to be a template that hid the text results under the map.

    2) Icons on map are not appearing – I checked and custom icon is still linked under Experience > Map > Map Marker… but not showing on actual map page when zipcode is entered.

    3) All pages now have a green “draft” icon next to them- I don’t see where to publish. Maybe this is the grand issue? I tried publishing in “Store Pages” but it makes no difference.

    4) I see many themes were deleted, including the one mentioned in #1, but I can’t seem to switch between new themes- nothing updates on the page, old map remains.

    The website is wakanine.com/where-to-see and if you enter “10001” as the zipcode, you can see the results.

     

    Thank you

    #44954

    Cici
    Keymaster

    Kaitlyn it is hard to answer you without your plugin environment screenshot and you went from what to what?  Can you provide a screen shot of your Plugin environment per the Posting guidelines.

    Looking at your site right off the bat I can see your theme is using old Jquery under Prettyphoto /*! jQuery UI – v1.11.1 – 2014-08-15

    Troubleshooting  look at the various issues that can happen and how to debug

    Do you have a back up of your site before updating multiple plugins or WP?  It is strongly suggested that you back up your site before updating versions. Any part of your theme that is using outdated jquery will interfere with all sorts of things, especially any maps.

    As far as what is available for plugin styles; are you trying to do a new client install based on a copy of a previous install you developed for someone?  Nothing went away if you updated your existing site you already have running. If you tried to install same setup on a new site…yeah, you wont see the same options and you would need to be a Premier subscriber to have multiple sites with one version of any of our add-ons.

    Check the Info news about versions and for articles about those potential  jquery issues.

    In the meantime, I suggest using the Debugger, there are tutorial videos as well

    #44962

    Kaitlyn
    Participant

    Attached is plugin environment.

    I’ll look over the Troubleshooting again and focus on the Jquery.

    I have not used this plugin for any other site. I switched over the site I was working on from their subdomain to main domain, but this was back in October and map has functioned fine until this past update. Perhaps that could be an issue?

    Thank you for your help.

     

    #44971

    Cici
    Keymaster

    Hi Kaitlyn,

    The Locator “remembers” and has most likely assigned store ids to your pages.  SEO Pages Docs

     

    Plugin styles were not deleted they are still there, you need to scroll down and select something besides Gallery style. If this is a new domain, you may not have the options you had on an old domain without the suggested add-ons

    I have tested my site and see all  Plugin styles , both Gallery and the older SLP plugin styles that allow you to select a variety of settings and  hide the map (part of Experience) There are now  more Plugin styles that utilize the  experience add-on.  Are you trying to hide results? The results immediately show locations or “disable initial directory”  is part of the Experience add-on.  https://docs.storelocatorplus.com/blog/results-panel-settings/

    There is some documentation that the author put together regarding moving sites. If any of the wp-option tables were not moved correctly, or if the media files are located under a different directory path, or if you updated WP recently, you could see some errors or your map not appearing or loading correctly

    https://docs.storelocatorplus.com/blog/q-we-are-developing-a-new-website-and-want-to-move-the-content-can-i-add-the-plug-in-data-we-already-have-into-the-new-website/

    #44997

    Kaitlyn
    Participant

    I’ve noticed in my google searches some people seem to have a problem with the map icons not displaying UNTIL a zipcode is entered, however mine do not appear at all, even when zip is entered. So I’m having a hard time using the tutorials to troubleshoot since the jquery scripts don’t apply to my issue… (such as: this youtube tutorial)

    I followed the other, general debugging tutorials and the “Console” did not mention any outdated JS, but did give me this error:
    JQMIGRATE: Migrate is installed, version 1.4.1  jquery-migrate.min.js:2:542

    My jQuery is at v1.12.4:

    ! jQuery v1.12.4 | (c) jQuery Foundation | jquery.org/license

    Also regarding prettyPhoto, I could not find the query version via the debugger but found this:

    Class: prettyPhoto
    Use: Lightbox clone for jQuery
    Author: Stephane Caron (http://www.no-margin-for-errors.com)
    Version: 3.1.5

    I am going to look into how to update this prettyPhoto lightbox somehow… and still looking into the possibility some files did not transfer when I moved from the subdomain to the main domain.

    Attached is a screenshot of the themes available to me currently via the dropdown menu- this is a small portion of the ones available before the update- I wonder what happened to these? Particularly the one that does not have results showing under the map.

    Thanks so much for your continued help.

    #45010

    Cici
    Keymaster

    Hi Kaitlyn,

    If you had CSS legacy see other forum posts about finding old plugin styles (see Wolframs post)  that might not be currently supported. The author cannot keep maintaining and adding more and more styles, the overhead for the few people that may have used them is not sustainable. The new JSON styling is much easier and quicker and works best with certain add-ons. Any new installs will NOT show all the plug-in styles.  The video explaining about the plugin styles changes  and the dev process here

    Did you see the Debug using Firefox video?  And another debug video  HERE about a customer who said he was seeing  NO results

    Someone posted in the forums a while ago about Pretty Photo Lightbox and an issue, Ill try to find the post for you.

    Another thought . are people searching with different browsers?  That could very possibly be an issue. I know that Google Chrome version 55 stopped allowing location sensor if you had an unsecured site, ( see my post last June 2016) (I looked and you are not HTTPS, no SSL cert)  in other words if its not https://

    P.S  A bug was reported and Lance is publishing 4.7.5 to fix the bug, not sure it has anything to do with your issue though, stay posted  but also added Set MAP markers from Media single step

    See youtube video

     

     

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.