Map displayed, but does not display any results

Home Forums Store Locator Plus Map displayed, but does not display any results

This topic contains 15 replies, has 8 voices, and was last updated by  Lance Cleveland 3 years, 1 month ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #22229


    I’m not sure when this plugin broke, but it used to work perfectly. There are over 1200 listing, but none of them come up. They all have lat/long and I’m not sure what the problem could be. When I go to the page, only the map is displayed:



    I should add that I have tried disabling all other plugins and also switched the theme. Still a no-go.



    I’m having the exact same problem. It happened when I updated the plugin through wordpress today. Nothing happens when I input an address, I just get “Results not found.” It was working earlier today so I know it’s not a problem with another plugin. Can I revert back to the last version?



    I have the problem since the update, my map onyl centers at the centre of my start-country independent from what city I enter.

    When I enter a zip code it even switches the country to spain almost every time. I have over 600 Locations, so there would be everywhere a result in my country. It new, entering the zip code did work until the update.

    In the screenshot I entered “Hamburg” as start (zip is not working anymore for this region”) and the map still using the centre of germany, same with every other city.



    I downgraded to 4.18 and restored a backup database and it’s working again. So something update related, this happens in software development and that’s why kids wordpress tells you to always make a backup before upgrading.



    I have the same problem too after upgrading.

    Some notes:

    First the page was throwing “too many recursions” js error.
    After entering a starting centering position for the map the error was gone but there where other problems.
    The search form wasn’t working and it always pointed at Malaga region (all my locations are in Greece). If I hit refresh after entering a postcode the form submits correctly and show all locations in this postcode (ignoring – I think – the radius).

    I hope all these will help you fix this



    I am experiencing the exact same issue.  After upgrading to SL PLUS Version 4.1.28 the search form does not display results and after a search it displays SPAIN on the map.  I do not have an older version to downgrade to and  if anyone can provide a link to get an older version that would be appreciated.

    I really hope a fix for this will be available today!



    Same problem….



    Just fyi.  Went back to 4.1.08 also, and all is well.



    are old versions of SLP4  posted on this site for download as I do not have a copy of the original I downloaded?




    Take a look here



    I downgraded, but it still doesn’t work. I tried three of them:
    <ul class=”unmarked-list”>

  • 4.1.08 (svn)
  • 4.1.07 (svn)
    4.1.00 (svn)


Also having the same issue of no results showing when map loads or being searchable.  However if I log in as an admin and view the map the results show along with all the pins on the map.


I have tried downgrading to all these versions with no results showing:



I have also disabled all the plugins I have on the site and still nothing.  Same goes for the beta site that I have running.


Details of the installation is:


Store Locator Plus Version:4.1.28

WordPress Version:3.9
MySQL Version:5.5.35
PHP Version:5.2.17
PHP Peak RAM:52 MB
Would love any suggestions.  Thank you

  • This reply was modified 3 years, 2 months ago by  Steven.
  • This reply was modified 3 years, 2 months ago by  Steven.


Tried the beta software Lance posted in another thread (.29) however no change.  Looking in the console I get this error when I’m not logged in as Admin:
Uncaught SyntaxError: Unexpected token
SLP server did not send back a valid JSONP response for csl_ajax_onload.
When logged in as myself, the Map loads fine without this error

  • This reply was modified 3 years, 2 months ago by  Steven. Reason: Showed html code
  • This reply was modified 3 years, 2 months ago by  Steven.

Lance Cleveland

If you are still having this issue please post:

  • which version of SLP you are using
  • which web browser and version you are using
  • a website URL where I can see the problem

I cannot reproduce the issue on my test systems and without a site to look at I cannot see why some sites have been breaking.

Obviously something has gone wrong in one of the updates but I cannot tell what has happened by reading posts that say not much more than “something broke”.

All past releases of the base plugin are here:


The prerelease copy of 4.1.30 can be downloaded here:


Keep in mind that prerelease copies, while working on my test system, has not been run through a full test cycle.   Do not use on a production system without testing on something less-critical first.     If you must try it on a production system absolutely make sure you have everything backed up.   I use VaultPress for my WP backups.


Lance Cleveland

@Bjoern – the centering of the map in Spain, etc. was fixed in SLP version 4.1.29 over a month ago.

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.