Store Locator Plus for WordPress Forums Store Locator Plus Experience Pack – Results Layout not working

This topic contains 3 replies, has 2 voices, and was last updated by  Cici 2 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #38478

    Ryan
    Participant

    Hello. I have recently installed a lot of the SLP plugins and wanted to customize the layout for the results of a search using the Experience Add-on. I have the field available to me in the back end of the interface and have edited it to my liking. But it does not render to the page. Nothing I change in the Results Layout box changes the layout of the results.

    Try typing in “Edmonton” and clicking FIND on http://www.devnwu.com/pitapitcan (scroll down to locations section first)

    Please help as I need to format these search results properly. I have searched all documentation and attempted most troubleshooting methods. It simply does not change the layout of the search results.

    Here is my plugin environment attached:

    Attachments:
    You must be logged in to view attached files.
    #38506

    Cici
    Keymaster

    It looks like you have a bug or conflict in your theme (not in SLP).  I would suggest you turn on the WP debugger to find where your javascript errors are.   Refer to  the information under   Troubleshooting   There is a newer video on what to look at and how to use the Firefox debugging on the Store Locator Plus You Tube channel as well.  Just a quick inspection on that page of your site   shows errors that are  preventing loading , here are two that were obvious on first inspection so there may be more with your theme or another plugin using old jquery versions or loading javascript before SLP has a chance

    Uncaught SyntaxError: Unexpected token ILLEGAL http://www.devnwu.com/pitapitcan/assets/js/languages.js

    Also  404 error : failed to load resource http://pitapit.ca/wp-content/uploads/2013/08/menusbreakfast2_grey_360.png

    #38509

    Ryan
    Participant

    Turns out the setting “Force Load JavaScript” was enabled and that was blocking it. I am unsure if this was enabled by default or if someone before me had it enabled, but now that it is off the add-on functions properly.

    Thank you.

    #38525

    Cici
    Keymaster

    Ahhhh. Glad you found the issue. I will close the post for now. If you have a new issue you can always open a new post. And thank you for sharing the resolution.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Experience Pack – Results Layout not working’ is closed to new replies.