CSV Import stops at 2 records

Home Forums Store Locator Plus CSV Import stops at 2 records

Tagged: 

This topic contains 7 replies, has 3 voices, and was last updated by  Lance Cleveland 3 years, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #18123

    Michael
    Participant

    Hi,

    I am trying to import a CSV file.  I am using “skip first line” and “first line has field name”. The sample file I have attached only has 6 records yet the import stops at two records.  The two records are imported fine.  Ultimately, we will import about 1000 records.

    <span style=”line-height: 1.5em;”>Could you please let me know what we are doing wrong so we may import the file.  Thank you very much!</span>

    <span style=”line-height: 1.5em;”>–</span>

    Michael

    Attachments:
    You must be logged in to view attached files.
    #18148

    Lance Cleveland
    Keymaster

    Try debugging while importing.

    from: /documentation/store-locator-plus/troubleshooting/

    Admin and Map Issues

    WordPress Debugging

    Often there are hidden warnings or errors.  Sometimes they are generated by the plugin.   Many times they are generated by OTHER plugins or your custom WordPress theme.   The first stage of debugging is to turn on the built-in WordPress debugging messages and debug log.

    Find your wp-config.php file and make the following changes.

    Find the line:

    1
    define('WP_DEBUG', false);

    Edit that line and add another to the wp-config file to turn on logging:

    1
    2
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);

    Read this Debugging WordPress article for more info.

    #18187

    Michael
    Participant

    Thank you Lance.

    My debug output is as follows.  I rechecked the feed and did not see any issues.  The CSV is using text delimiters (even for blank fields) .  There are no other plugins running.

    [23-Dec-2013 17:43:17 UTC] PHP Strict Standards:  Declaration of CSVImportCategories::create_BulkUploadForm() should be compatible with CSVImport::create_BulkUploadForm() in /Users/WebDev/phpDev/milbon-salon/wp-content/plugins/slp-tagalong/include/class.csvimport.categories.php on line 21

    [23-Dec-2013 17:43:18 UTC] PHP Fatal error:  Call to undefined method SLPTagalong_Admin::debugMP() in /Users/WebDev/phpDev/milbon-salon/wp-content/plugins/slp-tagalong/include/class.csvimport.categories.php on line 79

    Thank you!

     

    • This reply was modified 3 years, 8 months ago by  Michael.
    #18227

    Lance Cleveland
    Keymaster

    Which version of Tagalong are you using?

    From: /documentation/store-locator-plus/troubleshooting/

     

    Check Your Add On Versions

    The base plugin and add-on packs are updated on a regular basis.  Often the updates include fundamental changes that are designed to improve performance by reducing the memory and/or disk request load when your visitors are interacting with the map.   Making these baseline changes often requires removing unused code or relocating it within the Store Locator Plus system.  What does this mean for the casual plugin user or system administrator?

    Whenever you update the base plugin make sure ALL of  your SLP add-on packs are updated to the latest version as well.

    Since this is a significant issue when it comes to maintaining site stability, newer versions of the add-on packs now communicate more details to the base plugin to help provide at-a-glance add-on pack information on the main Store Locator Plus / Info tab.    However if you have not yet upgraded your add-on packs or if the upgrade communication server is offline you can still check your add-on packs manually.

    Upgrading An Add-On Pack

    First upgrade the base plugin.   It is a standard WordPress plugin and the WordPress plugin directory is kept up-to-date with the latest release.  Go to dashboard / updates and click “check again”.   If there is a newer version of Store Locator Plus available it will show up here.  Install the update as usual.

    If there are any SLP add-on packs available they should show up on the upgrade list, however the WordPress hooks that query remote servers do not always respond fast enough to notify you when a non-WordPress-hosted add-on pack has an upgrade available.   Follow these steps to upgrade your add-on packs:

    • Check the most recent change log post to see what the latest add-on versions are.
    • Go to  your WordPress admin panel plugins page.    Compare your installed versions to those listed on the change log post.
    • Login to your account on the Store Locator Plus website.
    • Download your add-on packs for any that are out-of-date.
    • Via your WordPress admin panel, deactivate and delete the outdated add-on packs.
    • Via your WordPress admin panel, install the zip files you downloaded from the Store Locator Plus site, activate the add-on packs.
    #18240

    Michael
    Participant

    Thank you.  All add on packs are up to date and the issue is still occurring.

    #18260

    Lance Cleveland
    Keymaster

    Can you send me your import file to info@ this website domain?  Or post it here if you are comfortable doing that.

    #18281

    Lisa
    Participant

    I’m having the same issue. My test file has 13 records and the import stops after the first 2.

    Here is the error message:

    Fatal error: Call to undefined method SLPTagalong_Admin::debugMP() in /home/tileroof/public_html/top/wp-content/plugins/slp-tagalong/include/class.csvimport.categories.php on line 79

    The first 2 records are imported, although the custom icon I have for my categories doesn’t display on the map until I manually edit/update the location record once it has uploaded.

    I also noticed when I downloaded the records that it is duplicating the category for each record. I’m attaching both the test upload csv file and the exported file (slplus_locations.csv)

    Everything is up to date. I just bought the software last week.

    I’m hoping to go live this week, so any help you can give will be greatly appreciated!

    Thank you.

    Attachments:
    You must be logged in to view attached files.
    #18316

    Lance Cleveland
    Keymaster

    SLP 4.0.034 and Tagalong 4.0.018 were release moments ago.  Try the patched version and let me know if it patches the issues for you.

    /slp-4-0-034-tagalong-4-0-018/

     

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.