CSV Import Settings Won't "Stick" – Cannot Upload Without Geocode / Add Duplicat

Home Forums Premier Support CSV Import Settings Won't "Stick" – Cannot Upload Without Geocode / Add Duplicat

This topic contains 7 replies, has 3 voices, and was last updated by  Cici 8 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #45468

    emilie
    Participant

    Please see attached for Plugin Environment details. Let me know if more information is needed

    I am having a problem with bulk CSV upload to Store Locator Plus. It seems like in the latest version of SLP, any settings that are modified in the Locations > Import menu do not seem to “stick” and are unrecognized. I have a couple thousand of locations that I am looking to import, and due to limitations with our server (or the plugin itself, this has been a continuing problem for as long as we’ve used the plugin, despite upgrades and changes to our server configuration, much to my chagrin) I upload in smaller batches, without running the geocoding right away – this avoid the errors that are apparently caused by trying to upload too much at once. (For us, it looks like the CSV upload process starts to choke around 30 rows of a CSV)

    However, I am unable to do this right now, because even when I select Skip Geocoding and Add Duplicate contacts, it still will geocode the addresses upon upload, and is skipping our duplicates. (We have a lot of locations that are in more than one category, so since there is no way for SLP to handle this we upload an instance of each locations for each category. It’s not ideal but it works – I wish there was a way to “merge” contacts upon import, but that is probably a difficult problem programmatically…).

    I have even gone so far as trying to change the options on the back-end inside the  sitedatabase using phpmyadmin (after some digging, I believe the setting is in the options table) but as soon as the Locations tab is reloaded the setting is changed back. For whatever reason, I also cannot use Janitor to manually change the value – the options are all greyed out.

    I even went so far as to set up a completely fresh copy of WordPress, on a completely fresh database, installed the plugin, and see that the problem is still there! Leads me to believe there is a problem/bug that needs to be addressed.

    Help! I am desperate to get SLP going properly again – the reliability of the CSV upload function is critical and I’ve experienced nothing but issues with it over the years.

    #45486

    Cici
    Keymaster

    SLP is on 4.7.7. try updating, as far as you csv file.

    See the developers  release notes  about 4.7.7

    Store Locator Plus 4.7.7 Released

    If you have been using the SLP for quite a while, I assume you have locations that have a unique sl_id.  You MUST have the sl_id header column with the correct sl_id for the extended options, such as Contact extender to work properly . Please refer to these pages in documentation:

    Additional Import Data field headers

    CSV Import Duplicates Handling

     

    Q: How Does Store Locator Plus Handle Large Location List Imports?

     

    As far as only importing 30 rows…..Your PHP version is outdated and upgrading or asking your host to update makes a difference . WP recommends version 7.  They even have a little blurb that you can send to your HOST provider.  If you are shared host such as Go Daddy you are going to have issues and it is not something that SLP can rectify.

    .

    Troubleshooting Large scale Exports

    #45490

    emilie
    Participant

    Hi Cici,

    Thanks for getting back to me. I went ahead removed the version of SLP I had installed, and installed PHP version 7 on that subdomain, then re-installed the SLP plugins from fresh downloads off your site, but it looks to me like the main problem I am having right now persists – when I select “Add” and “Skip Geocoding” in the import menu the settings are not actually followed when I run the import process.

    I am confused about your reference to the slp_id. Right now I am trying to import a completely fresh batch of contacts generated from an separate database I have elsewhere, after previously removing all existing location records from SLP, so I don’t have slp_ids set in my CSV. Do I still need to set the slp_ids in my .csv file before import? If so, what do I set them to? I’m also not familiar with what this has to do with the Contacts Extender.

    See attached for new Plugin Environment settings.

    #45495

    Lance Cleveland
    Keymaster

    Emilie – can you email your CSV file or attach it here so I can play with this and see if there are import issues?    support@storelocatorplus.com will go to our support mailbox.

    You can import multiple categories, you should be able to upload without doing the geocoding immediately.   With Premier you can also upload the entire file without geocoding and now set a recurring scheduled job to geocode all uncoded locations.    I can go over all of that with you in a future post, but I’d like to have your data first.   I’d also like to get a copy of the data with the multiple categories you’d like… list them in the category column as  “Category-Parent::Category-child, Category-Parent2::Category-Child2”  … the quotes do not need to be in the CSV cell, when you export as CSV it should add those automatically.

    #45498

    emilie
    Participant

    Hi Lance,

    Just sent you a sample of my .csv file format for upload.

    I’ll have to find a way to merge my records so that I can put both categories in the same row, instead of listing the same place twice in two rows, when a Location is in more than one category. If I can do that then I can send that along later… It would actually be a huge plus if we can get that going.

    The main problem right now seems to be that I cannot actually change the options in the Locations > Import menu don’t seem to be retained when selected, so I cannot import without doing the geocoding immediately.

    #45504

    Cici
    Keymaster

    Emile, Lance and I are looking at your files and have answered via email with the email from Andrew

    As mentioned you have a column header sl_id with no data in that column. If importing in fresh install where there is no sl_id that column should be deleted. Second, you have incomplete addresses which will not geocode.

    Next, try importing the CSV file into google sheets, cleaning them up  there and then saving as csv file from Google sheets.  You also can absolutely  have more then one category assigned per location,  you should not be adding them same location on separate row or you will have two separate data entries, instead keep in same row and in the categories  column , in the cell, just separate the categories with a comma. (If you are not trying to import parent child)

    All of this info can be referred to in the documentation , I provided you the links above. The instructions regarding the sl_id and duplicating is very specific.

    Additional info on how to import categories.

    Additional Import Data field headers

     

    FURTHER documentation and information that you should review , it is specific to what you are doing , moving  or importing data, exporting from old and importing to a new site

    Tables and Category Data System

     

     

     

    #45509

    emilie
    Participant

    Hi Cici,

    Noted on the sl_id and on the incomplete address. Although I don’t expect that an incomplete address should break the import – SLP should just skip over that record and geocode the next.

    I see what you are saying about the multiple categories now, I think. But it’s not a great way to do things, because different systems will interpret the csv differently if commas are included in a field, and it makes the data manipulation I need to do on my end more difficult. When I exported from my system to generate the .csv, the multiple categories were in the same field, separated by commas, but when you opened it, your system read it differently, because commas have special meaning in .csv I presume I will have to encapsulate all my fields with quotation marks, or use some other means, when I generate my csv? Is there any way to use another character as a divider between categories? Like a “/” or “&” or something? Maybe something for you to think about in the future. Extra commas in .csv throws everything out of whack.

    I will try running it through Google sheets now and see what I can else I can do with it.

     

    #45512

    Cici
    Keymaster

    Did you get the sample file I sent?

     

    Do not put quotes in the header row, not single not commas, nor apostrophes, nor any characters other then what is specified in the documentation and the sample files I sent you.  According to your email you are not using a standard spreadsheet to create a file that will then be downloaded or saved as a csv file. Perhaps that is why when I imported the file you sent into a simple google sheet, it put the additional categories in a separate cell and a separate column. If that is the case, I do not know how else to help you with that issue. I am not familiar with your  Filemaker Pro and Python tools.

    Also the file you sent had a repeated row at the end with the Data field HEADER row (with single quotes) so when you save that to a csv file format you will introduce a new issue.  I have tested out imports with multiple categories assigned for one location, just separating the text in that cell, it imports fine.  I sent another email to  the Andrew email. i.e. about changing contacts.

    Let us know via reply email about that.

     

     

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.