Store Locator Plus for WordPress Forums Store Locator Plus API outdated: Store Locator Plus Pro NOT functioning for website visitors

This topic contains 9 replies, has 2 voices, and was last updated by  Cici 2 years, 1 month ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #40666

    Rosie
    Participant

    Hello Keymasters,

    We have the latest version of the plugin including the Store Locator Plus:: Pro Pack 4.4.04 .

    Here is the link to our store locator: http://briolovesyouback.com/store-locator/

    The zip code entry is not pulling up any lists, nor the map.  When looking in the inspector, 3 errors show up and one of them states that the Google API is outdated.  I’ve attached a screenshot of the errors I see.

    Another error shows up briefly, so I can only do a screenshot of the one’s that show up longer.  (If you inspect and then submit a zip code, you will see another error load very briefly that says “uncaught type error: cannot read properly searchLocations of undefined”).

    Can you please help us to resolve this issue soon? We have customers telling us the locator isn’t working and it has been down for what we can see might be for at least a week now.

    Thank you.

    (This is for a WordPress site using the Bridge theme by Qode).

    Attachments:
    You must be logged in to view attached files.
    #40677

    Cici
    Keymaster

    Read Lances answers in  Troubleshooting .

    there is a video on that page you should also watch.   WP4.5 where is my map Article

     

    :excerpt”  In the ever-increasing effort to close security holes and tighten up the running environment of JavaScript,  version 1.12.3 is more apt to stop running ALL scripts and report an error if something is wrong.    One manifestation is the oft-cited a[href*=#] error message; you can learn more about the jQuery issue and this error on the WordPress 4.5 jQuery support thread.

    In cases where a plugin is forcing a specific version of jQuery, some plugins will expect to see jQuery version 1.12 and utilize newer API calls that did not exist in the older release. ”

    Your error tells all:   Best guess is that your theme or whatever,  the mobile menu.. is not using current versions of jquery  and now that WP is using 1.12 it is going to reveal all the errors and what went wrong …

    That error is not being generated by SLP plugin but it IS breaking SLP and we cant fix it, your theme or another plugin is stopping scripts in their tracks.

     

     

    #40678

    Cici
    Keymaster

    That does not state the Google API is outdated by the way…it is a warning, not an error, telling you that you do not have a Google API key…you are responsible for getting your own API key . We already have one for our sites

    See the article I posted back in November 

    #40685

    Rosie
    Participant

    Thanks for the clarification.  The store locator was working and now it doesn’t. Will take this up with the theme developers and get an API key.  Will get back to you if there are any additional issues.

    #40711

    Rosie
    Participant

    the JS folder was replaced with new files, so it appears to be working now.

    #40714

    Rosie
    Participant

    Site entirely down now with error code for store locator file

    Attachments:
    You must be logged in to view attached files.
    #40746

    Cici
    Keymaster

    @ Rosie

    Please update to SLP 4.5.01, there was an issue that was not caught in 4.5…Let me know if that resolves your issue,,,thanks

     

    #41050

    Cici
    Keymaster

    Rosie, Is this resolved?

    #41139

    Cici
    Keymaster

    SLP update to 4.5.03 is the current release version.

    #41140

    Cici
    Keymaster

    Hi $Rosie, I see that your map is working but I am seeing multiple failures that are a result of theme issues. Also there is an error message about Google APIS multiple google APIS.   Do you have another program loading maps with a API key?  Although your map seems to be loading now,  I do not know if your store locator map is responding the way you had intended.  I would like to close out this post if you are all set. Here is some Troubleshooting guidelines:

    Video Tutorial on finding Issues

    Failed to load resource: the server responded with a status of 404 (Not Found)

    http://briolovesyouback.com/wp-content/themes/bridge/css/elegant-icons/style.min.css?ver=4.5.1 Failed to load resource: the server responded with a status of 404 (Not Found)

    http://briolovesyouback.com/wp-content/themes/bridge/css/print.css?ver=4.5.1 Failed to load resource: the server responded with a status of 404 (Not Found)

    jquery-migrate.min.js?ver=1.4.0:2 JQMIGRATE: Migrate is installed, version 1.4.0

    js?language=en&ver=4.5.01:92 You have included the Google Maps API multiple times on this page. This may cause unexpected errors.Og @ js?language=en&ver=4.5.01:92

    jquery.js?ver=1.12.3:4 Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.

    jquery.js?ver=1.12.3:4 XMLHttpRequest cannot load http://37.60.255.21/~briolove/wp-content/plugins/store-locator-le/images/icons/marker.png. No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://briolovesyouback.com’ is therefore not allowed access.send @ jquery.js?ver=1.12.3:4

    util.js:222 Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

    http://briolovesyouback.com/wp-content/themes/bridge/css/linea-icons/style.css?ver=4.5.1 Failed to load resource: the server responded with a status of 404 (Not Found)

    http://briolovesyouback.com/wp-content/themes/bridge/css/elegant-icons/style.min.css?ver=4.5.1 Failed to load resource: the server responded with a status of 404 (Not Found)

    http://briolovesyouback.com/wp-content/themes/bridge/css/print.css?ver=4.5.1 Failed to load resource: the server responded with a status of 404 (Not Found)

    jquery.js?ver=1.12.3:4 XMLHttpRequest cannot load http://37.60.255.21/~briolove/wp-content/plugins/store-locator-le/images/icons/pin_red.png. No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://briolovesyouback.com’ is therefore not allowed access.send @ jquery.js?ver=1.12.3:4n.extend.ajax @ jquery.js?ver=1.12.3:4__init @ slp.js?ver=4.5.01:186slp_Marker @ slp.js?ver=4.5.01:220addMarkerAtCenter @ slp.js?ver=4.5.01:450(anonymous function) @ slp.js?ver=4.5.01:699(anonymous function) @ geocoder.js:5(anonymous function) @ geocoder.js:4jaa @ geocoder.js:2(anonymous function) @ geocoder.js:4(anonymous function) @ common.js:53(anonymous function) @ common.js:26(anonymous function) @ common.js:53d @ common.js:46(anonymous function) @ GeocodeService.Search?4s29464&7sus&9sen&callback=_xdc_._sdzwx6&token=119777:1

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘API outdated: Store Locator Plus Pro NOT functioning for website visitors’ is closed to new replies.